summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-01-15 14:41:49 +0100
committerUlrich Müller <ulm@gentoo.org>2022-01-15 14:42:50 +0100
commit52ef53c09c72a3a0ba0a24c9f248abe957631bfe (patch)
treed4c129d1c3f69375a1d0755bd2bac590be608558 /app-editors/emacs/emacs-28.0.91.ebuild
parentmedia-gfx/pdf2svg: Drop unused GTK+2 dependency, EAPI-8 bump (diff)
downloadgentoo-52ef53c09c72a3a0ba0a24c9f248abe957631bfe.tar.gz
gentoo-52ef53c09c72a3a0ba0a24c9f248abe957631bfe.tar.bz2
gentoo-52ef53c09c72a3a0ba0a24c9f248abe957631bfe.zip
app-editors/emacs: Restore Motif support for emacs-28 and master
Following upstream. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/emacs/emacs-28.0.91.ebuild')
-rw-r--r--app-editors/emacs/emacs-28.0.91.ebuild37
1 files changed, 26 insertions, 11 deletions
diff --git a/app-editors/emacs/emacs-28.0.91.ebuild b/app-editors/emacs/emacs-28.0.91.ebuild
index bf16d7665b2c..89ae30752e40 100644
--- a/app-editors/emacs/emacs-28.0.91.ebuild
+++ b/app-editors/emacs/emacs-28.0.91.ebuild
@@ -40,7 +40,7 @@ DESCRIPTION="The extensible, customizable, self-documenting real-time display ed
HOMEPAGE="https://www.gnu.org/software/emacs/"
LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
-IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif +gmp gpm gsettings gtk gui gzip-el harfbuzz imagemagick +inotify jit jpeg json kerberos lcms libxml2 livecd m17n-lib mailutils png selinux sound source ssl svg systemd +threads tiff toolkit-scroll-bars wide-int Xaw3d xft +xpm xwidgets zlib"
+IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif +gmp gpm gsettings gtk gui gzip-el harfbuzz imagemagick +inotify jit jpeg json kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source ssl svg systemd +threads tiff toolkit-scroll-bars wide-int Xaw3d xft +xpm xwidgets zlib"
RESTRICT="test"
RDEPEND="app-emacs/emacs-common[games?,gui(-)?]
@@ -102,16 +102,24 @@ RDEPEND="app-emacs/emacs-common[games?,gui(-)?]
)
)
!gtk? (
- Xaw3d? (
- x11-libs/libXaw3d
+ motif? (
+ >=x11-libs/motif-2.3:0
+ x11-libs/libXpm
x11-libs/libXmu
x11-libs/libXt
)
- !Xaw3d? ( athena? (
- x11-libs/libXaw
- x11-libs/libXmu
- x11-libs/libXt
- ) )
+ !motif? (
+ Xaw3d? (
+ x11-libs/libXaw3d
+ x11-libs/libXmu
+ x11-libs/libXt
+ )
+ !Xaw3d? ( athena? (
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXt
+ ) )
+ )
)
) )"
@@ -227,14 +235,21 @@ src_configure() {
See <https://gitlab.gnome.org/GNOME/gtk/-/issues/221> and
<https://gitlab.gnome.org/GNOME/gtk/-/issues/2315>.
If you intend to use more than one display, then it is strongly
- recommended that you compile Emacs with the Athena/Lucid
- toolkit instead.
+ recommended that you compile Emacs with the Athena/Lucid or the
+ Motif toolkit instead.
EOF
myconf+=" --with-x-toolkit=gtk3 $(use_with xwidgets)"
- for f in Xaw3d athena; do
+ for f in motif Xaw3d athena; do
use ${f} && ewarn \
"USE flag \"${f}\" has no effect if \"gtk\" is set."
done
+ elif use motif; then
+ einfo "Configuring to build with Motif toolkit"
+ myconf+=" --with-x-toolkit=motif"
+ for f in Xaw3d athena; do
+ use ${f} && ewarn \
+ "USE flag \"${f}\" has no effect if \"motif\" is set."
+ done
elif use athena || use Xaw3d; then
einfo "Configuring to build with Athena/Lucid toolkit"
myconf+=" --with-x-toolkit=lucid $(use_with Xaw3d xaw3d)"