summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans Fredrik Nordhaug <hansfn@gmail.com>2021-10-18 13:18:43 +0200
committerSam James <sam@gentoo.org>2021-11-12 01:33:52 +0000
commitf31ce7ecbd751a7ed7e9375f8627db9db5f72468 (patch)
tree9f9b92e8eaf13904cb410ac8ac3524a113e985b2 /app-editors/featherpad/featherpad-1.0.1.ebuild
parentnet-misc/asterisk: 13.38.3-r2 (diff)
downloadgentoo-f31ce7ecbd751a7ed7e9375f8627db9db5f72468.tar.gz
gentoo-f31ce7ecbd751a7ed7e9375f8627db9db5f72468.tar.bz2
gentoo-f31ce7ecbd751a7ed7e9375f8627db9db5f72468.zip
app-editors/featherpad: Bump to 1.0.1
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans Fredrik Nordhaug <hansfn@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/featherpad/featherpad-1.0.1.ebuild')
-rw-r--r--app-editors/featherpad/featherpad-1.0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-editors/featherpad/featherpad-1.0.1.ebuild b/app-editors/featherpad/featherpad-1.0.1.ebuild
new file mode 100644
index 000000000000..ce5b1b855fdc
--- /dev/null
+++ b/app-editors/featherpad/featherpad-1.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg cmake
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherPad"
+SRC_URI="https://github.com/tsujan/FeatherPad/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FeatherPad-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="+X"
+
+RDEPEND="app-text/hunspell:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ )
+ cmake_src_configure
+}