summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans Fredrik Nordhaug <hansfn@gmail.com>2022-08-03 12:49:05 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-08-18 10:06:17 +0300
commit5dc48665f7d024b0c53910474280e77b0476d5ad (patch)
tree8dc52c3a8118be9286001a2e08723581e93ae503 /app-editors/featherpad
parentdev-games/aseprite: drop 1.2.35 (diff)
downloadgentoo-5dc48665f7d024b0c53910474280e77b0476d5ad.tar.gz
gentoo-5dc48665f7d024b0c53910474280e77b0476d5ad.tar.bz2
gentoo-5dc48665f7d024b0c53910474280e77b0476d5ad.zip
app-editors/featherpad: add 1.3.1
Signed-off-by: Hans Fredrik Nordhaug <hansfn@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors/featherpad')
-rw-r--r--app-editors/featherpad/Manifest1
-rw-r--r--app-editors/featherpad/featherpad-1.3.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-editors/featherpad/Manifest b/app-editors/featherpad/Manifest
index a7937f86cb79..5c76058c3047 100644
--- a/app-editors/featherpad/Manifest
+++ b/app-editors/featherpad/Manifest
@@ -2,3 +2,4 @@ DIST featherpad-1.0.0.tar.gz 1010200 BLAKE2B 22a11a0655ed57f7a7d53949e59c3b989a3
DIST featherpad-1.0.1.tar.gz 1014744 BLAKE2B 1525b0894e47facdc51da0c6417d69b12d630bb0e6e8d7b3916b0c4e82380243b1b4dd0ddf82f7954d83edcd7b30346cff0305d98296b4aeccc1fe3cab325cd7 SHA512 8d1a07f8f32f63ec77e6bff8a39badd1eef87b0675096f964ff2fa770dda7c79ec9a1f788cbfa77528163aeb6c6067ca74e009293eca2e718dce92a48aef5f98
DIST featherpad-1.1.0.tar.gz 1061070 BLAKE2B 78c7ddf0b7961a300fe2e425876bfaf32a1186eb88c2619202cb2f07a780aed3c2f8d1ced0e963b1868c94e890d1d809baae534fe1f3d06b3f3036aeeccf7414 SHA512 c734619ea8eda2709ccfa4d1b3c2ac541f32d52f31f0896ddf3c1c5733f175da9d955458a62a34221400a73003970cf796f59cf574b499831267b6f4d1a28d21
DIST featherpad-1.2.0.tar.gz 1091776 BLAKE2B f63ddcc8bf02b3f9ad5f6ad2b56b8f99cc8566f70351a293fbe339930b41542e9ba27888afabfcf98a04ec6a1087dd77aa35006ea33526e1a7d6c45f5fe3b7d9 SHA512 cf21ed9394444920fcf3a8ce3a8338814d69322389c4652e79f0754fe67ee61260f81604c91adf0a864fb1441307706c60ee1bd29efd2e617ab8e1f5fc254cdd
+DIST featherpad-1.3.1.tar.gz 1096886 BLAKE2B 360940f0fe781676baa89a99f3d0a7c8ff8219da05fc5757b2e96654ab6c937534e2ef1cd216a3df73fd417353a3285716d09198b27626183c58d031abed363e SHA512 d17eb4691c759a7e97f24bf149152d104141162bef9f819cb09ecdd440916d1f5aa1a56252e64b859220237ea078a072c75308ec7b2e131078df938a171f506f
diff --git a/app-editors/featherpad/featherpad-1.3.1.ebuild b/app-editors/featherpad/featherpad-1.3.1.ebuild
new file mode 100644
index 000000000000..caabbdc69a62
--- /dev/null
+++ b/app-editors/featherpad/featherpad-1.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg cmake
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherPad"
+SRC_URI="https://github.com/tsujan/FeatherPad/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FeatherPad-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="+X"
+
+RDEPEND="app-text/hunspell:=
+ >=dev-qt/qtcore-5.15.0
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ )
+ cmake_src_configure
+}