summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-03 11:23:02 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-05 13:29:53 -0500
commit13293fb67dba8150dc77017d36b977df40cee537 (patch)
tree9b17ac64fac9636d15b04f3446de1d6d7aa7928f /app-editors/gedit-plugins
parentapp-editors/gedit: Version bump to 3.38.1 (diff)
downloadgentoo-13293fb67dba8150dc77017d36b977df40cee537.tar.gz
gentoo-13293fb67dba8150dc77017d36b977df40cee537.tar.bz2
gentoo-13293fb67dba8150dc77017d36b977df40cee537.zip
app-editors/gedit-plugins: Version bump to 3.38.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors/gedit-plugins')
-rw-r--r--app-editors/gedit-plugins/Manifest1
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-3.38.1.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
index e9433da16461..a6aa3a829921 100644
--- a/app-editors/gedit-plugins/Manifest
+++ b/app-editors/gedit-plugins/Manifest
@@ -1 +1,2 @@
DIST gedit-plugins-3.36.2.tar.xz 980648 BLAKE2B 37f55b742258b233d161ce808483ba10f158b951f06eaee53d966edc275dad67a2d11eae342fed7bc9b185d1309c5795f645eabf24db99a6e6551a3dae19ddb6 SHA512 d46a5ec69f69838144333ca3e66abc7c64cdb3248877b38298f869027dd3bab16102957e723ad1b0d3c6af55745c2b7ce321949acb2575734c649a388bb0100b
+DIST gedit-plugins-3.38.1.tar.xz 957616 BLAKE2B 9cf5fe5343b513bd841add5d4e85f8fe2e8f62524af7c124bdfc41b81e653a41d1a7417f8cc06f764cca730927f471598cae914a1581c5cd3712b89c464a075d SHA512 d5cc3e82ac6a488f5ab06eaf4eb5ad32bdbe50b74f2f215e114b5cb3bb0a089da00caa3815d6638a679c1c902983a0754a16ef88e15ff88d8321a247288ad237
diff --git a/app-editors/gedit-plugins/gedit-plugins-3.38.1.ebuild b/app-editors/gedit-plugins/gedit-plugins-3.38.1.ebuild
new file mode 100644
index 000000000000..c91a098c30f2
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-3.38.1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="xml"
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="Collection of extra plugins for the gedit Text Editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+IUSE="charmap git +python terminal vala"
+REQUIRED_USE="
+ charmap? ( python )
+ git? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ terminal? ( python )
+"
+
+RDEPEND="
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=app-editors/gedit-3.38
+
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtksourceview-4.0.2:4
+
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=app-editors/gedit-3.36[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_MULTI_USEDEP}]
+ ')
+ >=x11-libs/gtk+-3.9:3[introspection]
+ >=x11-libs/gtksourceview-4.0.2:4[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ git? ( >=dev-libs/libgit2-glib-0.0.6[python] )
+ terminal? ( >=x11-libs/vte-0.52:2.91[introspection] )
+" # vte-0.52+ for feed_child API compatibility
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dplugin_bookmarks=true
+ $(meson_use python plugin_bracketcompletion)
+ $(meson_use charmap plugin_charmap)
+ $(meson_use python plugin_codecomment)
+ $(meson_use python plugin_colorpicker)
+ $(meson_use python plugin_colorschemer)
+ $(meson_use python plugin_commander)
+ -Dplugin_drawspaces=true
+ $(meson_use vala plugin_findinfiles)
+ $(meson_use git plugin_git)
+ $(meson_use python plugin_joinlines)
+ $(meson_use python plugin_multiedit)
+ $(meson_use python plugin_sessionsaver)
+ $(meson_use python plugin_smartspaces)
+ $(meson_use python plugin_synctex)
+ $(meson_use terminal plugin_terminal)
+ $(meson_use python plugin_textsize)
+ $(meson_use python plugin_translate)
+ -Dplugin_wordcompletion=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ use python && python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}