summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-02-19 12:09:31 -0800
committerMatt Turner <mattst88@gentoo.org>2022-02-19 12:13:42 -0800
commit840007d32b599e8d5c31e6785bcc5277fd630cf0 (patch)
tree47d464f67056ba647e2305377712418749e43e9e /app-editors/gedit-plugins
parentapp-editors/gedit: Version bump to 41.0 (diff)
downloadgentoo-840007d32b599e8d5c31e6785bcc5277fd630cf0.tar.gz
gentoo-840007d32b599e8d5c31e6785bcc5277fd630cf0.tar.bz2
gentoo-840007d32b599e8d5c31e6785bcc5277fd630cf0.zip
app-editors/gedit-plugins: Version bump to 41.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors/gedit-plugins')
-rw-r--r--app-editors/gedit-plugins/Manifest1
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-41.0.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
index 0b10f6559558..1041baed2247 100644
--- a/app-editors/gedit-plugins/Manifest
+++ b/app-editors/gedit-plugins/Manifest
@@ -1 +1,2 @@
DIST gedit-plugins-40.1.tar.xz 951024 BLAKE2B 8a5fa07d6b9a5848e66de995c05f389b288e7863fa506476fd82157dc203e472b8ac8b8bdd15b09513e5d819fc58ce4d1077e62e6c5b90f93b14775052bf2737 SHA512 71649d157ac5591e4dd317c44ae167c98fb59e253c45f8c1ff8ef397a9e3f0bb968f0ef2486f9021354269e77defb9e5e305f1538f69818480a250966143c7a3
+DIST gedit-plugins-41.0.tar.xz 948364 BLAKE2B d5efe779e1f0f70e23a7dadb01b0e5b22c47d3326df6530559698ace274e2a4a3647d34640e89bb250d76bee1f6369d5728316730ce9cf89f3a7db627b3c4d49 SHA512 e0389e8be68406fdcd3c9537b2d2dad0faf19d9a49804a7b5d9cf8e1006254906605dd0b14e2fa1eb7a22d6533d9b55d7f5593fe01a5b412df6361c8b9089f34
diff --git a/app-editors/gedit-plugins/gedit-plugins-41.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-41.0.ebuild
new file mode 100644
index 000000000000..9375e8402944
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-41.0.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml"
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="Collection of extra plugins for the gedit Text Editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+SLOT="0"
+
+IUSE="charmap git +python terminal vala"
+REQUIRED_USE="
+ charmap? ( python )
+ git? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ terminal? ( python )
+"
+
+RDEPEND="
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=app-editors/gedit-40.0
+
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtksourceview-4.0.2:4
+
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-editors/gedit[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+ >=x11-libs/gtk+-3.9:3[introspection]
+ >=x11-libs/gtksourceview-4.0.2:4[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ git? ( >=dev-libs/libgit2-glib-0.0.6[python] )
+ terminal? ( >=x11-libs/vte-0.52:2.91[introspection] )
+" # vte-0.52+ for feed_child API compatibility
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dplugin_bookmarks=true
+ $(meson_use python plugin_bracketcompletion)
+ $(meson_use charmap plugin_charmap)
+ $(meson_use python plugin_codecomment)
+ $(meson_use python plugin_colorpicker)
+ $(meson_use python plugin_colorschemer)
+ $(meson_use python plugin_commander)
+ -Dplugin_drawspaces=true
+ $(meson_use vala plugin_findinfiles)
+ $(meson_use git plugin_git)
+ $(meson_use python plugin_joinlines)
+ $(meson_use python plugin_multiedit)
+ $(meson_use python plugin_sessionsaver)
+ $(meson_use python plugin_smartspaces)
+ $(meson_use python plugin_synctex)
+ $(meson_use terminal plugin_terminal)
+ $(meson_use python plugin_textsize)
+ $(meson_use python plugin_translate)
+ -Dplugin_wordcompletion=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ use python && python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}