summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSobhan Mohammadpour <sobhan@gentoo.org>2019-05-26 14:07:47 -0400
committerSobhan Mohammadpour <sobhan@gentoo.org>2019-05-26 14:50:36 -0400
commit565e5bde87543e739adaefd0d1b43eca860ef018 (patch)
tree8a780373c0a7fce73108b0f1a242d0e09c93828f /app-editors/gedit
parentapp-backup/dar: Removed old. (diff)
downloadgentoo-565e5bde87543e739adaefd0d1b43eca860ef018.tar.gz
gentoo-565e5bde87543e739adaefd0d1b43eca860ef018.tar.bz2
gentoo-565e5bde87543e739adaefd0d1b43eca860ef018.zip
app-editors/gedit: 3.32.0-r1 -> 3.32.2
Package-Manager: Portage-2.3.66, Repoman-2.3.12 RepoMan-Options: --force Signed-off-by: Sobhan Mohammadpour <sobhan@gentoo.org>
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/Manifest2
-rw-r--r--app-editors/gedit/files/3.32.2-make-spell-optional.patch61
-rw-r--r--app-editors/gedit/gedit-3.32.2.ebuild (renamed from app-editors/gedit/gedit-3.32.0-r1.ebuild)11
3 files changed, 69 insertions, 5 deletions
diff --git a/app-editors/gedit/Manifest b/app-editors/gedit/Manifest
index 31ba866ade59..4cb53c80c57b 100644
--- a/app-editors/gedit/Manifest
+++ b/app-editors/gedit/Manifest
@@ -1,2 +1,2 @@
DIST gedit-3.30.2.tar.xz 3155628 BLAKE2B 96736adbce987af89b37a712448f42b2a2eeed72d52aa16377d961c9e929fa4e75205eac5987bfc067cc2fecb35aec720d85483c4e2e824a6e8248cc652d2fbe SHA512 58ae7a4c27aeabad670718e39e1860df112d0be00ea622cc8adc185cb5d0e16ac4af65cb3aa45423c7b1b94c88d04d081fe05f3647b054a3e3291abc73c41f6f
-DIST gedit-3.32.0.tar.xz 14793216 BLAKE2B b1d9af7882063a622fe27f8e5aa322e2a1724410c4419d538712fdda2cab10aa59014a82cc1a41b35966dceb1b75ce2613d9c5c98400743b31df76b0114e84e8 SHA512 f25ed05f5d3b7ab7711be32c6516479c8b515d6d5983e3bc3a00407740fb8ec42b1e9a3005473671fc144f4437b9e98355a3669210eefb5bf8288f171188f387
+DIST gedit-3.32.2.tar.xz 14789660 BLAKE2B 574a490e3beda9e8b4f8324409f3a1e3361b1fdd097c4bf8d05475be2a6bb66b230ab6d2047caa62c393458c29b6647c32293ce5c1428d030cb2345c19bf41c3 SHA512 a3ed4dea3d0f60fb2371d2b6bbf5f5db1f67c9a71d0d47836456e022903e86b8b127c88ece6a6d817b0c86ff82612c963a9e8ed60f9841af68474a1d129c886d
diff --git a/app-editors/gedit/files/3.32.2-make-spell-optional.patch b/app-editors/gedit/files/3.32.2-make-spell-optional.patch
new file mode 100644
index 000000000000..1d772590f605
--- /dev/null
+++ b/app-editors/gedit/files/3.32.2-make-spell-optional.patch
@@ -0,0 +1,61 @@
+From 72efa486222cde6094c217efc6085f49af1cca85 Mon Sep 17 00:00:00 2001
+From: Sobhan Mohammadpour <sobhan@gentoo.org>
+Date: Sun, 26 May 2019 14:19:17 -0400
+Subject: [PATCH] make spell optional
+
+---
+ meson.build | 4 +++-
+ meson_options.txt | 4 ++++
+ plugins/meson.build | 4 +++-
+ 3 files changed, 10 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 2f4d7e5..f67e320 100644
+--- a/meson.build
++++ b/meson.build
+@@ -86,7 +86,8 @@ libxml_dep = dependency('libxml-2.0', version: libxml_req)
+ libgd_dep = libgd_sp.get_variable('libgd_dep')
+
+ libsoup_dep = dependency('libsoup-2.4', version: libsoup_req, required: true)
+-gspell_dep = dependency('gspell-1', version: gspell_req, required: true)
++with_gspell = get_option('spell')
++gspell_dep = dependency('gspell-1', version: gspell_req, required: false)
+ x11_dep = dependency('x11', required: false)
+
+ introspection_dep = dependency('gobject-introspection-1.0', version: introspection_req, required: false)
+@@ -189,6 +190,7 @@ summary = [
+ ' Introspection: @0@'.format(generate_gir),
+ ' Plugins: @0@'.format(build_plugins),
+ ' Vala API: @0@'.format(generate_vapi),
++ ' Spell: @0@'.format(with_gspell),
+ ' Gvfs metadata: @0@'.format(enable_gvfs_metadata),
+ '',
+ 'Directories:',
+diff --git a/meson_options.txt b/meson_options.txt
+index 90803fa..e1f7349 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -16,3 +16,7 @@ option('documentation',
+ option('enable-gvfs-metadata',
+ type: 'combo', choices : ['yes', 'no', 'auto'], value : 'auto',
+ description: 'Enable using gvfs to store metadata')
++
++option('spell',
++ type:'boolean', value: true,
++ description: 'Build spell support')
+diff --git a/plugins/meson.build b/plugins/meson.build
+index af94ab7..abeeac5 100644
+--- a/plugins/meson.build
++++ b/plugins/meson.build
+@@ -21,5 +21,7 @@ subdir('quickhighlight')
+ subdir('quickopen')
+ subdir('snippets')
+ subdir('sort')
+-subdir('spell')
++if with_gspell
++ subdir('spell')
++endif
+ subdir('time')
+--
+2.21.0
+
diff --git a/app-editors/gedit/gedit-3.32.0-r1.ebuild b/app-editors/gedit/gedit-3.32.2.ebuild
index 02db350e3688..1efe7a9a4ebb 100644
--- a/app-editors/gedit/gedit-3.32.0-r1.ebuild
+++ b/app-editors/gedit/gedit-3.32.2.ebuild
@@ -15,10 +15,10 @@ HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
LICENSE="GPL-2+ CC-BY-SA-3.0"
SLOT="0"
-IUSE="+introspection +python gtk-doc vala"
-REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} )"
+IUSE="+introspection +python gtk-doc spell vala"
+REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} ) spell? ( python )"
-KEYWORDS="~amd64"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
# X libs are not needed for OSX (aqua)
COMMON_DEPEND="
@@ -40,7 +40,7 @@ COMMON_DEPEND="
dev-python/pycairo[${PYTHON_USEDEP}]
>=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
dev-libs/libpeas[python,${PYTHON_USEDEP}] )
- >=app-text/gspell-0.2.5:0=
+ spell? ( >=app-text/gspell-0.2.5:0= )
"
RDEPEND="${COMMON_DEPEND}
x11-themes/adwaita-icon-theme
@@ -54,6 +54,7 @@ DEPEND="${COMMON_DEPEND}
>=sys-devel/gettext-0.18
virtual/pkgconfig
"
+PATCHES=( "${FILESDIR}/${PV}-make-spell-optional.patch" )
pkg_setup() {
use python && python-single-r1_pkg_setup
@@ -69,7 +70,9 @@ src_configure() {
$(meson_use gtk-doc documentation)
$(meson_use introspection)
$(meson_use python plugins)
+ $(meson_use spell)
$(meson_use vala vapi)
+ -Denable-gvfs-metadata=yes
)
meson_src_configure
}