summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-28 21:44:00 -0400
committerMatt Turner <mattst88@gentoo.org>2022-07-28 22:23:43 -0400
commitba47196624fc723c67ca8ac583dda5eadf4d76ec (patch)
tree0b5da15afb806635f0e48f5bc99abf1b50fe9c8c /app-editors/gedit
parentsys-apps/gentoo-functions: add 0.16 (diff)
downloadgentoo-ba47196624fc723c67ca8ac583dda5eadf4d76ec.tar.gz
gentoo-ba47196624fc723c67ca8ac583dda5eadf4d76ec.tar.bz2
gentoo-ba47196624fc723c67ca8ac583dda5eadf4d76ec.zip
app-editors/gedit: Version bump to 42.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/Manifest1
-rw-r--r--app-editors/gedit/gedit-42.2.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/app-editors/gedit/Manifest b/app-editors/gedit/Manifest
index 3015167d1041..666d0e5ee00e 100644
--- a/app-editors/gedit/Manifest
+++ b/app-editors/gedit/Manifest
@@ -1 +1,2 @@
DIST gedit-42.1.tar.xz 6916780 BLAKE2B a4350a62811ee689f9a7f70a4b166aa82185a17ab6c6f0f6264404756a2e7f2b93e81b2cf88beaf4141527720437f9e6ee9f7584e65e63fe242975e346d26586 SHA512 b7b1dd4ab31412a2bdeb6298065d1e3f52a9c813e26e943aea606b30e3de9b7690cc8ba478e2d0e49fb51bed57dd3f7c441184964270629d51dc1f6d132045a6
+DIST gedit-42.2.tar.xz 6917596 BLAKE2B fd7b0a1c113e944b1b3f0c2bb55a061e76e7ee71ebbfe8d64c6d5b0c7e47b8dd54519bde1b7b095a1cab27a169427eecdf35d06422c1a984f51dab82e19c7cb0 SHA512 d50f021f33764e0cdd3ac51650db0e37dacb5b6edeadddfd8136e8120e83eb740db66ada25ae43eac810896714859d6f8876640a8976ddfd6e7e602c278dcc99
diff --git a/app-editors/gedit/gedit-42.2.ebuild b/app-editors/gedit/gedit-42.2.ebuild
new file mode 100644
index 000000000000..250e1be179a4
--- /dev/null
+++ b/app-editors/gedit/gedit-42.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit https://gitlab.gnome.org/GNOME/gedit"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="+python gtk-doc spell"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.64:2
+ >=x11-libs/gtk+-3.22.0:3[introspection]
+ >=x11-libs/gtksourceview-4.0.2:4[introspection,vala]
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=dev-libs/libxml2-2.5.0:2
+ >=dev-libs/gobject-introspection-1.54:=
+
+ spell? ( >=app-text/gspell-0.2.5:0= )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+ gnome-base/gsettings-desktop-schemas
+ gnome-base/gvfs
+"
+BDEPEND="
+ $(vala_depend)
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ dev-util/itstool
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use python)
+ $(meson_feature spell)
+ -Duser_documentation=true
+ -Denable-gvfs-metadata=yes
+
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use python; then
+ python_optimize
+ python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}