summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-13 22:43:18 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-13 22:48:25 -0400
commit9052434b27d12aa3e60c30bb4ec097dac6b5e4fe (patch)
tree5e07d4a64f39431c221de1b77ef9267c170c1c64 /app-editors/ghex
parentgui-libs/gtksourceview: Version bump to 5.4.2 (diff)
downloadgentoo-9052434b27d12aa3e60c30bb4ec097dac6b5e4fe.tar.gz
gentoo-9052434b27d12aa3e60c30bb4ec097dac6b5e4fe.tar.bz2
gentoo-9052434b27d12aa3e60c30bb4ec097dac6b5e4fe.zip
app-editors/ghex: Version bump to 42.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors/ghex')
-rw-r--r--app-editors/ghex/Manifest1
-rw-r--r--app-editors/ghex/ghex-42.3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-editors/ghex/Manifest b/app-editors/ghex/Manifest
index 3d89759e8ec0..11a1561e89a6 100644
--- a/app-editors/ghex/Manifest
+++ b/app-editors/ghex/Manifest
@@ -1 +1,2 @@
DIST ghex-42.2.tar.xz 1003120 BLAKE2B db44dbb7c2cb7447dea3dd48a1ad90ee75c6ce5b9c76178550be1f638f63a9748144e8aac7434d526c24c3eddd0c6f7c0178c6976d2a11e32e943127b7f09219 SHA512 d7c64013d894d1803e03b1afc025a3f39fa65d156aaf7885e692b2b10574f320fb329abd8059a9c084c701a655d7708b8f0dec09f8300c8491fc75a66b475bf7
+DIST ghex-42.3.tar.xz 1003928 BLAKE2B 26bb123fc5a56fc2ff891a057ac276a36bc500a2e23f29bd26a85d6888035e2b8af7aed7f7b679a898c0a98bf042bb4e05c66e55a8fac0eb63422ee03823dc74 SHA512 9eff44892d203a2a9aab7239d85f61a860458fd7a8b4d7410f94d4f596ca5e2ff269faa81e620e7fc08bebe40c819a4c0cafefb5278121a9f2c8885bfd17c59f
diff --git a/app-editors/ghex/ghex-42.3.ebuild b/app-editors/ghex/ghex-42.3.ebuild
new file mode 100644
index 000000000000..60b2aa480d88
--- /dev/null
+++ b/app-editors/ghex/ghex-42.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="GNOME hexadecimal editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+ FDL-1.1+"
+IUSE="gtk-doc test"
+RESTRICT="!test? ( test )"
+SLOT="4"
+
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ >=gui-libs/gtk-4.0.0:4
+ dev-libs/gobject-introspection
+ !app-editors/ghex:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( dev-util/gi-docgen )
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+ dev-util/gtk-update-icon-cache
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/gtk-doc/
+ -Dintrospection=enabled
+ $(meson_use gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}