summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <droman@ifae.es>2022-09-12 16:09:29 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-09-24 11:45:01 +0200
commitbb642470d585104bfda5d7355f942c46baca4321 (patch)
treea0bedcc498493e0948fd09d0808a2c6a8f75cbbe /app-editors/ghostwriter
parentkde-frameworks/knotifications: Fix build with USE -X (diff)
downloadgentoo-bb642470d585104bfda5d7355f942c46baca4321.tar.gz
gentoo-bb642470d585104bfda5d7355f942c46baca4321.tar.bz2
gentoo-bb642470d585104bfda5d7355f942c46baca4321.zip
app-editors/ghostwriter: add 2.1.6
Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/27222 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors/ghostwriter')
-rw-r--r--app-editors/ghostwriter/Manifest1
-rw-r--r--app-editors/ghostwriter/ghostwriter-2.1.6.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-editors/ghostwriter/Manifest b/app-editors/ghostwriter/Manifest
index 804a881fe130..4f33c997cc31 100644
--- a/app-editors/ghostwriter/Manifest
+++ b/app-editors/ghostwriter/Manifest
@@ -1,2 +1,3 @@
DIST ghostwriter-2.0.2.tar.gz 7802654 BLAKE2B a52a96ba6aecb8c6b8ff565bd9b3b7622d15ae68af5e393da4f1e1c8dae70a8053228e302e87e2530c907be825df5e7eebc7de14bb23e0e46f4b4308b9ae6e63 SHA512 1e51b86b8afae41c47e5e7ec96752d356dd9dca8a44d1aab6a541e1ce188cb40add52f96a52da7a689df47a2e7a9a1dc7211f480c3456f4a11c81f80e2779a7e
DIST ghostwriter-2.1.4.tar.gz 7725770 BLAKE2B aebc00d4b30790241715383e00348d89137276637e1cc728aa0fb093886d832c8b33477e0923c90acb9d12ff82bf87fffff26f8c27cb2088c6d12da18777eb7d SHA512 bb6039fea415ab9d4807d81947cd914b961bc6ee249f630ae58ffa764fdb46adfa87f1f41c5f6d6b7736ecc1d7561da5df6f142b25075093abb2341251da9596
+DIST ghostwriter-2.1.6.tar.gz 7757010 BLAKE2B a450093b1f072aeea7e6a6e27abbdb2c427387eb70b5ed2a5e49ea1f33fd9c4e4014742cc7905e644ab39838c488d9eddb79e0d3c87bde7ce6528cd810b02e15 SHA512 10ee557a07f468cc12391c2b5f77a6667aef76429b58bfdc03df32dd1cd8c44a61fe77da5318d5b23758ede40a5f8ab89cf4573a09708a6abc2d12ec5ceb71ad
diff --git a/app-editors/ghostwriter/ghostwriter-2.1.6.ebuild b/app-editors/ghostwriter/ghostwriter-2.1.6.ebuild
new file mode 100644
index 000000000000..5c1c71d26b2e
--- /dev/null
+++ b/app-editors/ghostwriter/ghostwriter-2.1.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils xdg
+
+DESCRIPTION="Cross-platform, aesthetic, distraction-free markdown editor"
+HOMEPAGE="https://wereturtle.github.io/ghostwriter/"
+SRC_URI="https://github.com/wereturtle/ghostwriter/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+BDEPEND="dev-qt/linguist-tools:5"
+
+RDEPEND="
+ app-text/hunspell:=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebchannel:5
+ dev-qt/qtwebengine:5[widgets]
+ dev-qt/qtwidgets:5
+ virtual/opengl
+"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( CREDITS.md README.md )
+
+src_configure() {
+ eqmake5 \
+ CONFIG+=$(usex debug debug release) \
+ PREFIX="${EPREFIX}"/usr
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}