summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-11-03 00:42:02 -0300
committerMatt Turner <mattst88@gentoo.org>2022-11-04 14:00:27 -0400
commitaded590c779225e5c04301262a4efdf5659ab917 (patch)
tree5e011c725d5c1e97c4ebe79ca424b3851539757d /app-editors/gnome-latex/gnome-latex-3.42.0.ebuild
parentdev-python/psycopg: Stabilize 3.1.3 arm64, #879591 (diff)
downloadgentoo-aded590c779225e5c04301262a4efdf5659ab917.tar.gz
gentoo-aded590c779225e5c04301262a4efdf5659ab917.tar.bz2
gentoo-aded590c779225e5c04301262a4efdf5659ab917.zip
app-editors/gnome-latex: Version bump to 3.42.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors/gnome-latex/gnome-latex-3.42.0.ebuild')
-rw-r--r--app-editors/gnome-latex/gnome-latex-3.42.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-editors/gnome-latex/gnome-latex-3.42.0.ebuild b/app-editors/gnome-latex/gnome-latex-3.42.0.ebuild
new file mode 100644
index 000000000000..aa72efbcb22b
--- /dev/null
+++ b/app-editors/gnome-latex/gnome-latex-3.42.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="https://gitlab.gnome.org/swilmet/gnome-latex"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="+introspection +latexmk rubber"
+
+DEPEND="
+ >=dev-libs/glib-2.70:2
+ >=x11-libs/gtk+-3.22:3
+ >=app-text/gspell-1.8:0=
+ >=gui-libs/amtk-5.6:=
+ >=x11-libs/gtksourceview-4.0:4
+ >=gui-libs/tepl-6.2:=
+ >=dev-libs/libgee-0.10:0.8=
+ gnome-base/gsettings-desktop-schemas
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+ gnome-base/dconf
+"
+RDEPEND="${DEPEND}
+ virtual/latex-base
+ x11-themes/hicolor-icon-theme
+ latexmk? ( dev-tex/latexmk )
+ rubber? ( dev-tex/rubber )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.14
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.6:0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --enable-dconf_migration \
+ --enable-vala=no
+}