summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-22 17:56:57 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-22 21:59:56 -0700
commitc492d2fa1381c45ffc6baee1a8a837d91e0e831f (patch)
tree62151f7bbfd0ac3def84bb3a5f1d3f45955b0165 /app-editors/gnome-text-editor
parentdev-ml/sexplib: bump to 0.15.0 (diff)
downloadgentoo-c492d2fa1381c45ffc6baee1a8a837d91e0e831f.tar.gz
gentoo-c492d2fa1381c45ffc6baee1a8a837d91e0e831f.tar.bz2
gentoo-c492d2fa1381c45ffc6baee1a8a837d91e0e831f.zip
app-editors/gnome-text-editor: Version bump to 42.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors/gnome-text-editor')
-rw-r--r--app-editors/gnome-text-editor/Manifest1
-rw-r--r--app-editors/gnome-text-editor/gnome-text-editor-42.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-editors/gnome-text-editor/Manifest b/app-editors/gnome-text-editor/Manifest
index 8296d7ba3a48..c0ae4db60881 100644
--- a/app-editors/gnome-text-editor/Manifest
+++ b/app-editors/gnome-text-editor/Manifest
@@ -1 +1,2 @@
DIST gnome-text-editor-42.0.tar.xz 1126224 BLAKE2B 7e02cea493696630284d7994f1d227a5589ad7aa7d7b98e5f67655ebcd69f7e2ded1195368e666ad26621b6b32168c7defde1cd3c2e278ca8741bf572979154e SHA512 4462ef0e0113863e752ce2c4d499386cbf9d72c67126fb60512eea39bd53bed6d56b2a62511e9af62024f9704ba722411ebbd5040aabcefce0b460925b91ad1f
+DIST gnome-text-editor-42.1.tar.xz 1131572 BLAKE2B 8d1b59131d8230af0dc9e3029798f1200b6a00f8991e912c34ce4808ca5517e14763825aa8ed7aecdac88e422e9d224d3c027282f6373c023c4ffe9f3e4896b6 SHA512 4616750d15d61b2bd2c708e414b564d0aa6c1202c765fbb895e60cdb46f8335fbefa70a24e8d99f208b186f2c8c244b752475cefdbe0184a67b60de116d5ac2f
diff --git a/app-editors/gnome-text-editor/gnome-text-editor-42.1.ebuild b/app-editors/gnome-text-editor/gnome-text-editor-42.1.ebuild
new file mode 100644
index 000000000000..d4026901f43b
--- /dev/null
+++ b/app-editors/gnome-text-editor/gnome-text-editor-42.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A simple text editor for the GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-text-editor"
+SRC_URI="mirror://gnome/sources/gnome-text-editor/42/gnome-text-editor-${PV/_/.}.tar.xz"
+S="${WORKDIR}/gnome-text-editor-${PV/_/.}"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="spell"
+
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-libs/glib-2.69:2
+ >=gui-libs/gtk-4.6:4
+ >=gui-libs/gtksourceview-5.4.1:5
+ gui-libs/libadwaita:1
+ dev-libs/libpcre
+ spell? (
+ >=app-text/enchant-2.2.0:2
+ dev-libs/icu:=
+ )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.21
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-appdata-fix-appstream-validation.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature spell enchant)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}