summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOskari Pirhonen <xxc3ncoredxx@gmail.com>2023-02-16 01:07:20 -0600
committerSam James <sam@gentoo.org>2023-02-18 04:32:39 +0000
commit8ef01b5deddc1b8633d99907f2941ee8a85d60f1 (patch)
tree81edd67c86b8b557faf6790a83358e9d8b054eaa /app-editors/gvim
parentvirtual/daemontools: drop to maintainer-needed (diff)
downloadgentoo-8ef01b5deddc1b8633d99907f2941ee8a85d60f1.tar.gz
gentoo-8ef01b5deddc1b8633d99907f2941ee8a85d60f1.tar.bz2
gentoo-8ef01b5deddc1b8633d99907f2941ee8a85d60f1.zip
app-editors/gvim: remove manual patch application
Signed-off-by: Oskari Pirhonen <xxc3ncoredxx@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/gvim')
-rw-r--r--app-editors/gvim/gvim-9.0.1000.ebuild14
-rw-r--r--app-editors/gvim/gvim-9.0.1157.ebuild14
-rw-r--r--app-editors/gvim/gvim-9999.ebuild14
3 files changed, 24 insertions, 18 deletions
diff --git a/app-editors/gvim/gvim-9.0.1000.ebuild b/app-editors/gvim/gvim-9.0.1000.ebuild
index 2de60ab53f5d..708d13e40470 100644
--- a/app-editors/gvim/gvim-9.0.1000.ebuild
+++ b/app-editors/gvim/gvim-9.0.1000.ebuild
@@ -80,6 +80,13 @@ BDEPEND="
"
PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
+if [[ ${PV} != 9999* ]]; then
+ # Gentoo patches to fix runtime issues, cross-compile errors, etc
+ PATCHES=(
+ "${WORKDIR}/vim-patches-vim-${VIM_PATCHES_VERSION}-patches"
+ )
+fi
+
# various failures (bugs #630042 and #682320)
RESTRICT="test"
@@ -93,10 +100,7 @@ pkg_setup() {
}
src_prepare() {
- if [[ ${PV} != 9999* ]]; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}/vim-patches-vim-${VIM_PATCHES_VERSION}-patches"
- fi
+ default
# Fixup a script to use awk instead of nawk
sed -i -e \
@@ -163,8 +167,6 @@ src_prepare() {
sed -i -e \
'/# define FEAT_CSCOPE/d' src/feature.h || die "couldn't disable cscope"
fi
-
- eapply_user
}
src_configure() {
diff --git a/app-editors/gvim/gvim-9.0.1157.ebuild b/app-editors/gvim/gvim-9.0.1157.ebuild
index 29c24d0ea9fb..01f283c88448 100644
--- a/app-editors/gvim/gvim-9.0.1157.ebuild
+++ b/app-editors/gvim/gvim-9.0.1157.ebuild
@@ -80,6 +80,13 @@ BDEPEND="
"
PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
+if [[ ${PV} != 9999* ]]; then
+ # Gentoo patches to fix runtime issues, cross-compile errors, etc
+ PATCHES=(
+ "${WORKDIR}/vim-patches-vim-${VIM_PATCHES_VERSION}-patches"
+ )
+fi
+
# various failures (bugs #630042 and #682320)
RESTRICT="test"
@@ -93,10 +100,7 @@ pkg_setup() {
}
src_prepare() {
- if [[ ${PV} != 9999* ]]; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}/vim-patches-vim-${VIM_PATCHES_VERSION}-patches"
- fi
+ default
# Fixup a script to use awk instead of nawk
sed -i -e \
@@ -163,8 +167,6 @@ src_prepare() {
sed -i -e \
'/# define FEAT_CSCOPE/d' src/feature.h || die "couldn't disable cscope"
fi
-
- eapply_user
}
src_configure() {
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index 29c24d0ea9fb..01f283c88448 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -80,6 +80,13 @@ BDEPEND="
"
PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
+if [[ ${PV} != 9999* ]]; then
+ # Gentoo patches to fix runtime issues, cross-compile errors, etc
+ PATCHES=(
+ "${WORKDIR}/vim-patches-vim-${VIM_PATCHES_VERSION}-patches"
+ )
+fi
+
# various failures (bugs #630042 and #682320)
RESTRICT="test"
@@ -93,10 +100,7 @@ pkg_setup() {
}
src_prepare() {
- if [[ ${PV} != 9999* ]]; then
- # Gentoo patches to fix runtime issues, cross-compile errors, etc
- eapply "${WORKDIR}/vim-patches-vim-${VIM_PATCHES_VERSION}-patches"
- fi
+ default
# Fixup a script to use awk instead of nawk
sed -i -e \
@@ -163,8 +167,6 @@ src_prepare() {
sed -i -e \
'/# define FEAT_CSCOPE/d' src/feature.h || die "couldn't disable cscope"
fi
-
- eapply_user
}
src_configure() {