summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-09 04:49:57 +0100
committerSam James <sam@gentoo.org>2021-10-09 04:57:07 +0100
commitbebd23328169e114c2c4c650de47a1f361ed6d6d (patch)
tree0845e97662d38cac532a19c4c9625db7b861229a /app-editors/gvim
parentapp-editors/vim: fix automagic libsodium dependency (diff)
downloadgentoo-bebd23328169e114c2c4c650de47a1f361ed6d6d.tar.gz
gentoo-bebd23328169e114c2c4c650de47a1f361ed6d6d.tar.bz2
gentoo-bebd23328169e114c2c4c650de47a1f361ed6d6d.zip
app-editors/gvim: fix automagic libsodium dependency
Bug: https://bugs.gentoo.org/816966 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/gvim')
-rw-r--r--app-editors/gvim/gvim-8.2.3428-r1.ebuild (renamed from app-editors/gvim/gvim-8.2.3428.ebuild)4
-rw-r--r--app-editors/gvim/gvim-9999.ebuild6
-rw-r--r--app-editors/gvim/metadata.xml1
3 files changed, 8 insertions, 3 deletions
diff --git a/app-editors/gvim/gvim-8.2.3428.ebuild b/app-editors/gvim/gvim-8.2.3428-r1.ebuild
index eac0fc37724a..0a202597784e 100644
--- a/app-editors/gvim/gvim-8.2.3428.ebuild
+++ b/app-editors/gvim/gvim-8.2.3428-r1.ebuild
@@ -25,7 +25,7 @@ HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
SLOT="0"
LICENSE="vim"
-IUSE="acl aqua cscope debug gtk gtk2 lua motif neXt netbeans nls perl python racket ruby selinux session sound tcl"
+IUSE="acl aqua crypt cscope debug gtk gtk2 lua motif neXt netbeans nls perl python racket ruby selinux session sound tcl"
REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -59,6 +59,7 @@ RDEPEND="
)
)
)
+ crypt? ( dev-libs/libsodium:= )
cscope? ( dev-util/cscope )
lua? (
${LUA_DEPS}
@@ -198,6 +199,7 @@ src_configure() {
--with-gnome=no
$(use_enable sound canberra)
$(use_enable acl)
+ $(use_enable crypt libsodium)
$(use_enable cscope)
$(use_enable netbeans)
$(use_enable nls)
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index ecd0b5e0dd0f..0a202597784e 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -17,7 +17,7 @@ if [[ ${PV} == 9999* ]]; then
else
SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> vim-${PV}.tar.gz
https://dev.gentoo.org/~zlogene/distfiles/app-editors/vim/vim-8.2.0360-gentoo-patches.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
fi
DESCRIPTION="GUI version of the Vim text editor"
@@ -25,7 +25,7 @@ HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
SLOT="0"
LICENSE="vim"
-IUSE="acl aqua cscope debug gtk gtk2 lua motif neXt netbeans nls perl python racket ruby selinux session sound tcl"
+IUSE="acl aqua crypt cscope debug gtk gtk2 lua motif neXt netbeans nls perl python racket ruby selinux session sound tcl"
REQUIRED_USE="
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -59,6 +59,7 @@ RDEPEND="
)
)
)
+ crypt? ( dev-libs/libsodium:= )
cscope? ( dev-util/cscope )
lua? (
${LUA_DEPS}
@@ -198,6 +199,7 @@ src_configure() {
--with-gnome=no
$(use_enable sound canberra)
$(use_enable acl)
+ $(use_enable crypt libsodium)
$(use_enable cscope)
$(use_enable netbeans)
$(use_enable nls)
diff --git a/app-editors/gvim/metadata.xml b/app-editors/gvim/metadata.xml
index eb9f0418416e..81f9a4724bf6 100644
--- a/app-editors/gvim/metadata.xml
+++ b/app-editors/gvim/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Vim Project</name>
</maintainer>
<use>
+ <flag name="crypt">Use <pkg>dev-libs/libsodium</pkg> for crypto support</flag>
<flag name="cscope">Enable cscope interface</flag>
<flag name="gtk2">Enable GTK+2 interface</flag>
<flag name="netbeans">Include netbeans external editor integration support</flag>