summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2022-05-19 08:58:39 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2022-05-19 09:01:42 +0200
commit770a0460a98e9245802321714ee2350fd230497d (patch)
tree6469392da0ef306887f05d347970e4da1ff2b927 /app-editors/hexedit/hexedit-1.6.ebuild
parentapp-text/bibletime: add 3.0.3 (diff)
downloadgentoo-770a0460a98e9245802321714ee2350fd230497d.tar.gz
gentoo-770a0460a98e9245802321714ee2350fd230497d.tar.bz2
gentoo-770a0460a98e9245802321714ee2350fd230497d.zip
app-editors/hexedit: add 1.6
Closes: https://bugs.gentoo.org/842711 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'app-editors/hexedit/hexedit-1.6.ebuild')
-rw-r--r--app-editors/hexedit/hexedit-1.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-editors/hexedit/hexedit-1.6.ebuild b/app-editors/hexedit/hexedit-1.6.ebuild
new file mode 100644
index 000000000000..7da44e6f5b51
--- /dev/null
+++ b/app-editors/hexedit/hexedit-1.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="View and edit files in hex or ASCII"
+HOMEPAGE="http://rigaux.org/hexedit.html"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+EGIT_REPO_URI="https://github.com/pixel/hexedit.git"
+else
+SRC_URI="https://github.com/pixel/hexedit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dobin hexedit
+ doman hexedit.1
+ dodoc Changes
+}