summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-05-05 21:14:19 +0300
committerIan Delaney <idella4@gentoo.org>2016-05-06 18:54:38 +0800
commitfbffc0e8d920f3492b682511ed24435388693c7e (patch)
tree01be11f065eac6ae13e74e9e39c58e4da0296ea4 /app-editors/kakoune/files
parentapp-misc/elasticsearch: Bump (diff)
downloadgentoo-fbffc0e8d920f3492b682511ed24435388693c7e.tar.gz
gentoo-fbffc0e8d920f3492b682511ed24435388693c7e.tar.bz2
gentoo-fbffc0e8d920f3492b682511ed24435388693c7e.zip
app-editors/kakoune: new ebuild
initial vns.; a snapshot 2016.05.05ebuild, and a live ebuild Closes: https://github.com/gentoo/gentoo/pull/1414 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'app-editors/kakoune/files')
-rw-r--r--app-editors/kakoune/files/kakoune-makefile.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-editors/kakoune/files/kakoune-makefile.patch b/app-editors/kakoune/files/kakoune-makefile.patch
new file mode 100644
index 000000000000..076c42f92ea8
--- /dev/null
+++ b/app-editors/kakoune/files/kakoune-makefile.patch
@@ -0,0 +1,38 @@
+diff --git a/src/Makefile b/src/Makefile
+index c79c270..9409a8c 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -3,10 +3,10 @@ pedantic ?= yes
+
+ ifeq ($(debug),yes)
+ CPPFLAGS += -DKAK_DEBUG
++ CXXFLAGS += -g
+ suffix := .debug
+ else
+ ifeq ($(debug),no)
+- CXXFLAGS += -O3
+ suffix := .opt
+ else
+ $(error debug should be either yes or no)
+@@ -26,8 +26,6 @@ mandocs := $(docs:.asciidoc=.gz)
+ PREFIX ?= /usr/local
+ DESTDIR ?= # root dir
+
+-NCURSESW_INCLUDE ?= /usr/include/ncursesw
+-
+ bindir := $(DESTDIR)$(PREFIX)/bin
+ sharedir := $(DESTDIR)$(PREFIX)/share/kak
+ docdir := $(DESTDIR)$(PREFIX)/share/doc/kak
+@@ -53,11 +51,10 @@ else ifneq (,$(findstring CYGWIN,$(os)))
+ LIBS += -lncursesw -lboost_regex -ldbghelp
+ else
+ LIBS += -lncursesw -lboost_regex
+- CPPFLAGS += -I$(NCURSESW_INCLUDE)
+ LDFLAGS += -rdynamic
+ endif
+
+-CXXFLAGS += -std=gnu++11 -g -Wall -Wno-reorder -Wno-sign-compare -Wno-address
++CXXFLAGS += -std=gnu++11 -Wall -Wno-reorder -Wno-sign-compare -Wno-address
+
+ kak : $(objects)
+ $(CXX) $(LDFLAGS) $(CXXFLAGS) $(objects) $(LIBS) -o $@