summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-12 10:36:54 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-12 10:36:54 +0100
commit4c1022bb9559cad2e38e22ad2013646ceb6c7238 (patch)
tree81e5d46bff01e11a3c7176f51ec4545be628b77a /app-editors/lpe
parentsys-auth/fprintd: Fix build with gcc-10 (diff)
downloadgentoo-4c1022bb9559cad2e38e22ad2013646ceb6c7238.tar.gz
gentoo-4c1022bb9559cad2e38e22ad2013646ceb6c7238.tar.bz2
gentoo-4c1022bb9559cad2e38e22ad2013646ceb6c7238.zip
app-editors/lpe: Port to EAPI 7
Closes: https://bugs.gentoo.org/707188 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-editors/lpe')
-rw-r--r--app-editors/lpe/files/lpe-1.2.6.13-fno-common.patch31
-rw-r--r--app-editors/lpe/files/lpe-1.2.6.13-make-382.patch5
-rw-r--r--app-editors/lpe/lpe-1.2.6.13.ebuild24
3 files changed, 49 insertions, 11 deletions
diff --git a/app-editors/lpe/files/lpe-1.2.6.13-fno-common.patch b/app-editors/lpe/files/lpe-1.2.6.13-fno-common.patch
new file mode 100644
index 000000000000..2cc68157ed53
--- /dev/null
+++ b/app-editors/lpe/files/lpe-1.2.6.13-fno-common.patch
@@ -0,0 +1,31 @@
+https://bugs.gentoo.org/707188
+--- a/src/cfg.c
++++ b/src/cfg.c
+@@ -22,6 +22,7 @@
+ #include <string.h>
+ #endif
+
++extern char *LPE_CONFIG_FILE;
+ int cfg_errno;
+
+ void
+--- a/src/lpe.c
++++ b/src/lpe.c
+@@ -25,6 +25,7 @@
+ #include "strfuncs.h"
+ #include "exports.h"
+
++char *LPE_CONFIG_FILE;
+ /* A flag indicating a desire to quit the editor. This is set whenever a
+ * command should cause an exit.
+ */
+--- a/src/options.h
++++ b/src/options.h
+@@ -38,6 +38,6 @@
+ /*
+ * Other things that are used in some places...
+ */
+-char *LPE_CONFIG_FILE;
++extern char *LPE_CONFIG_FILE;
+
+ #endif /* LPE_OPTIONS_H */
diff --git a/app-editors/lpe/files/lpe-1.2.6.13-make-382.patch b/app-editors/lpe/files/lpe-1.2.6.13-make-382.patch
index f8d96ef087e9..2e93042570aa 100644
--- a/app-editors/lpe/files/lpe-1.2.6.13-make-382.patch
+++ b/app-editors/lpe/files/lpe-1.2.6.13-make-382.patch
@@ -1,7 +1,6 @@
http://bugs.gentoo.org/335324
-
---- intl/Makefile.in
-+++ intl/Makefile.in
+--- a/intl/Makefile.in
++++ b/intl/Makefile.in
@@ -202,12 +202,12 @@
# The dependency for intlh.inst is different in gettext and all other
# packages. Because we cannot you GNU make features we have to solve
diff --git a/app-editors/lpe/lpe-1.2.6.13.ebuild b/app-editors/lpe/lpe-1.2.6.13.ebuild
index 463f48e14e24..4a9bb25d8011 100644
--- a/app-editors/lpe/lpe-1.2.6.13.ebuild
+++ b/app-editors/lpe/lpe-1.2.6.13.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils ltprune multilib toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="a lightweight programmers editor"
HOMEPAGE="https://packages.qa.debian.org/l/lpe.html"
@@ -13,14 +14,21 @@ SLOT="0"
KEYWORDS="amd64 ppc sparc x86 ~x86-linux"
IUSE="nls"
-RDEPEND=">=sys-libs/slang-2.2.4
- >=sys-libs/ncurses-5.7-r7:0="
-DEPEND="${RDEPEND}
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/slang"
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
nls? ( sys-devel/gettext )"
+PATCHES=(
+ "${FILESDIR}"/${P}-make-382.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-make-382.patch
+ default
# You should add PKG_CHECK_MODULES(NCURSES, ncurses) to configure.in and
# replace -lncurses in src/Makefile.am with $(NCURSES_LIBS)
@@ -45,5 +53,5 @@ src_install() {
exdir="${ED}/usr/share/doc/${PF}/examples" \
install
- prune_libtool_files --all
+ find "${ED}" -name '*.la' -delete || die
}