summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-01 23:06:10 +0100
committerSam James <sam@gentoo.org>2021-04-01 23:08:40 +0100
commit65ed7850a0f6ddd7a55b26665bef21998f0509b7 (patch)
tree894d94a73245b84021a9a407e643f02ec69e75eb /app-editors/lpe
parentapp-accessibility/speech-tools: modernise 2.5.0, drop useless multilib inherit (diff)
downloadgentoo-65ed7850a0f6ddd7a55b26665bef21998f0509b7.tar.gz
gentoo-65ed7850a0f6ddd7a55b26665bef21998f0509b7.tar.bz2
gentoo-65ed7850a0f6ddd7a55b26665bef21998f0509b7.zip
app-editors/lpe: add 1.2.8_p20210401
Add missing virtual/libintl dep for musl, take snapshot for upstream slibtool + gcc 10 (our!) fix. Closes: https://bugs.gentoo.org/778581 Closes: https://bugs.gentoo.org/713778 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/lpe')
-rw-r--r--app-editors/lpe/Manifest1
-rw-r--r--app-editors/lpe/lpe-1.2.8_p20210401.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-editors/lpe/Manifest b/app-editors/lpe/Manifest
index 36553d794ec2..99347eb254e1 100644
--- a/app-editors/lpe/Manifest
+++ b/app-editors/lpe/Manifest
@@ -1 +1,2 @@
+DIST lpe-1.2.8_p20210401.tar.gz 840016 BLAKE2B 81fa0b1c3f9a7164eb219692a2e7bc092d0ee09c9de15f6fd2a4f66cc486be5b744eaa2fb0569a9f44f45d6a19159c55286be76d9ae0f4947f5b7c749e84a8fb SHA512 0b40f2f3fc1241e07291dfdbfcf2466cf5dedc1c91bf36c4f36c8af792ce718be2ad66884b049e25d7b9f9e796d60ce25ca42b37610d26894cd1dc6b74e51157
DIST lpe_1.2.6.13-0.1.tar.gz 600523 BLAKE2B 8866aff63276d5e39ed48b4d9e8b9a23d541c13e196815c29586df83f8c6b5895a8dde8fb16b0929bffc49416907d74d48fdbc5ce736a855f2d2daad6472fb96 SHA512 f02769baca396285fe8f98c934f6274185d2bf8b08f3b007cbfa4e6aadb455abfb7cab13d53a3d1fa71ea0c29c4222784dcbc9a7508501c7d1839671503758ed
diff --git a/app-editors/lpe/lpe-1.2.8_p20210401.ebuild b/app-editors/lpe/lpe-1.2.8_p20210401.ebuild
new file mode 100644
index 000000000000..549d8c087e37
--- /dev/null
+++ b/app-editors/lpe/lpe-1.2.8_p20210401.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+COMMIT="203c88eae66c6a3bffd050286af6d9aacf85816e"
+DESCRIPTION="A lightweight programmers editor"
+HOMEPAGE="https://packages.qa.debian.org/l/lpe.html"
+SRC_URI="https://github.com/AdamMajer/lpe/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-linux"
+IUSE="nls"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/slang
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? (
+ sys-devel/gettext
+ virtual/libintl
+ )
+"
+
+src_prepare() {
+ default
+
+ # You should add PKG_CHECK_MODULES(NCURSES, ncurses) to configure.in and
+ # replace -lncurses in src/Makefile.am with $(NCURSES_LIBS)
+ # That is, if you need eautoreconf
+ sed -i \
+ -e "s:-lncurses:$($(tc-getPKG_CONFIG) --libs-only-l ncurses):" \
+ src/Makefile.in || die
+
+ # Refresh outdated libtool (elibtoolize insufficient)
+ # Fixes undefined references on macOS/Darwin
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake \
+ libdir="${ED}/usr/$(get_libdir)" \
+ prefix="${ED}/usr" \
+ datadir="${ED}/usr/share" \
+ mandir="${ED}/usr/share/man" \
+ infodir="${ED}/usr/share/info" \
+ docdir="${ED}/usr/share/doc/${PF}" \
+ exdir="${ED}/usr/share/doc/${PF}/examples" \
+ install
+
+ find "${ED}" -name '*.la' -delete || die
+}