summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-23 04:53:06 +0100
committerSam James <sam@gentoo.org>2021-08-23 05:06:09 +0100
commit89fb3f9e3e14edb4c33eb8858810d7f3c3102253 (patch)
tree170dbfd0d947d8bf6d37fb036fb1b10fcf6db267 /app-editors/mg/mg-20210314-r1.ebuild
parentgames-arcade/pachi: fix group of binary (diff)
downloadgentoo-89fb3f9e3e14edb4c33eb8858810d7f3c3102253.tar.gz
gentoo-89fb3f9e3e14edb4c33eb8858810d7f3c3102253.tar.bz2
gentoo-89fb3f9e3e14edb4c33eb8858810d7f3c3102253.zip
app-editors/mg: subscribe to ncurses subslot
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/mg/mg-20210314-r1.ebuild')
-rw-r--r--app-editors/mg/mg-20210314-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-editors/mg/mg-20210314-r1.ebuild b/app-editors/mg/mg-20210314-r1.ebuild
new file mode 100644
index 000000000000..59dc39a0a994
--- /dev/null
+++ b/app-editors/mg/mg-20210314-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
+HOMEPAGE="https://homepage.boetes.org/software/mg/"
+SRC_URI="https://github.com/hboetes/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ppc ~ppc64 sparc x86"
+IUSE="livecd"
+
+RDEPEND="sys-libs/ncurses:0=
+ !elibc_FreeBSD? ( >=dev-libs/libbsd-0.7.0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # fix path to tutorial in man page
+ sed -i -e "s:doc/mg/:doc/${PF}/:" mg.1 || die
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ dobin mg
+ doman mg.1
+ dodoc README tutorial
+ # don't compress the tutorial, otherwise mg cannot open it
+ docompress -x /usr/share/doc/${PF}/tutorial
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s mg "${EROOT}"/usr/bin/emacs
+ fi
+}