summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/mlview
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/mlview')
-rw-r--r--app-editors/mlview/Manifest1
-rw-r--r--app-editors/mlview/files/mlview-0.9.0-desktop.patch20
-rw-r--r--app-editors/mlview/files/mlview-0.9.0-gcc44.patch82
-rw-r--r--app-editors/mlview/files/mlview-0.9.0-gcc45.patch15
-rw-r--r--app-editors/mlview/files/mlview-0.9.0-r1-10_port_to_gtksourceview2.patch218
-rw-r--r--app-editors/mlview/files/mlview-0.9.0-r1-autoreconf.patch25
-rw-r--r--app-editors/mlview/metadata.xml13
-rw-r--r--app-editors/mlview/mlview-0.9.0-r1.ebuild63
8 files changed, 437 insertions, 0 deletions
diff --git a/app-editors/mlview/Manifest b/app-editors/mlview/Manifest
new file mode 100644
index 000000000000..94d91e67e6f2
--- /dev/null
+++ b/app-editors/mlview/Manifest
@@ -0,0 +1 @@
+DIST mlview-0.9.0.tar.bz2 754148 SHA256 568ce3fefe83eb163b4fbd7d62954ec3cad3000e966cd9f7461c2c9a3edb4dca SHA512 646f375afa27d1e050f17ded2154af9667e51e345e3a66b4354fa1babe49a45f940114ee6c1106e04cab678ba68618aea0182872dab1c9628e2cabf3561521c7 WHIRLPOOL dc289552f057e977ae713b27a580fa8b552a275995cb9cf373989abf12dd18188945ce96c2080b8581a2addaeac2831b6a26721dc8203d42d20341d1ce60aacd
diff --git a/app-editors/mlview/files/mlview-0.9.0-desktop.patch b/app-editors/mlview/files/mlview-0.9.0-desktop.patch
new file mode 100644
index 000000000000..3906e6f30c4a
--- /dev/null
+++ b/app-editors/mlview/files/mlview-0.9.0-desktop.patch
@@ -0,0 +1,20 @@
+--- mlview.desktop.in
++++ mlview.desktop.in
+@@ -1,13 +1,10 @@
+ [Desktop Entry]
+-Version=0.9.4
+-Encoding=UTF-8
+ Type=Application
+ Name=MlView XML Editor
+ GenericName=MlView Generic XML Editor
+-Categories=Application;Development;
++Categories=Development;
+ Comment=A generic simple XML editor for GNOME
+-Icon=mlview-app-icon.xpm
+-TryExec=mlv
+-Exec=@MLVIEW_EXE@ %F
++Icon=mlview-app-icon
++TryExec=mlview
++Exec=mlview %F
+ Terminal=false
+-
diff --git a/app-editors/mlview/files/mlview-0.9.0-gcc44.patch b/app-editors/mlview/files/mlview-0.9.0-gcc44.patch
new file mode 100644
index 000000000000..b82398f726d7
--- /dev/null
+++ b/app-editors/mlview/files/mlview-0.9.0-gcc44.patch
@@ -0,0 +1,82 @@
+http://bugs.gentoo.org/311573
+
+--- src/mlview-tree-view.h
++++ src/mlview-tree-view.h
+@@ -178,7 +178,7 @@
+
+ enum MlViewStatus build_app_edit_menu () ;
+
+- GtkDialog * TreeView::get_expand_tree_dialog () ;
++ GtkDialog * get_expand_tree_dialog () ;
+
+ void clear_completion_popup_submenus () ;
+
+--- src/mlview-source-view.h
++++ src/mlview-source-view.h
+@@ -53,7 +53,7 @@
+
+ enum MlViewStatus set_default_options () ;
+
+- MlViewXMLDocument* SourceView::get_document () ;
++ MlViewXMLDocument* get_document () ;
+
+ GtkUIManager * get_ui_manager () ;
+
+--- src/mlview-validator.cc
++++ src/mlview-validator.cc
+@@ -25,6 +25,7 @@
+
+ #include "mlview-validator.h"
+ #include "mlview-safe-ptr-utils.h"
++#include <memory>
+
+ #define MESSAGE_LINE_LENGTH 55
+ namespace mlview
+--- src/mlview-plugin.h
++++ src/mlview-plugin.h
+@@ -46,12 +46,12 @@
+
+ //forbid assignation/copy
+ Plugin& operator= (Plugin const&) ;
+- Plugin::Plugin (Plugin const&) ;
++ Plugin (Plugin const&) ;
+
+ public:
+ Plugin (const PluginDescriptor &a_descr) ;
+
+- Plugin::Plugin (const UString &a_url) ;
++ Plugin (const UString &a_url) ;
+
+ virtual ~Plugin () ;
+
+--- src/mlview-editor.cc
++++ src/mlview-editor.cc
+@@ -157,7 +157,7 @@
+ contextual_menu (NULL)
+ {}
+
+- static void EditorPriv::schemas_window_destroy_cb
++ static void schemas_window_destroy_cb
+ (GtkWidget *a_widget, struct DocumentWindowData *a_win) ;
+
+ static void validation_window_destroy_cb
+@@ -406,17 +406,13 @@
+ gtk_dialog_run (GTK_DIALOG (dialog));
+
+
+- switch (button) {
+- case GTK_RESPONSE_OK:
++ if (button == GTK_RESPONSE_OK) {
+ sel_menu_item = gtk_menu_get_active(GTK_MENU(menu));
+
+ result = (ViewDescriptor *)g_object_get_data
+ (G_OBJECT(sel_menu_item), "mlview_view_desc");
+- break;
+-
+- default:
++ } else {
+ result = NULL ;
+- break;
+ }
+ gtk_widget_destroy (dialog);
+ return result;
diff --git a/app-editors/mlview/files/mlview-0.9.0-gcc45.patch b/app-editors/mlview/files/mlview-0.9.0-gcc45.patch
new file mode 100644
index 000000000000..55b922bcac04
--- /dev/null
+++ b/app-editors/mlview/files/mlview-0.9.0-gcc45.patch
@@ -0,0 +1,15 @@
+Fix building with gcc 4.5
+
+http://bugs.gentoo.org/show_bug.cgi?id=320377
+
+--- src/mlview-ustring.cc
++++ src/mlview-ustring.cc
+@@ -59,7 +59,7 @@
+ UString::~UString ()
+ {}
+
+-UString::UString&
++UString&
+ UString::operator= (const char *a_cstr)
+ {
+ if (!a_cstr)
diff --git a/app-editors/mlview/files/mlview-0.9.0-r1-10_port_to_gtksourceview2.patch b/app-editors/mlview/files/mlview-0.9.0-r1-10_port_to_gtksourceview2.patch
new file mode 100644
index 000000000000..0ce22957a478
--- /dev/null
+++ b/app-editors/mlview/files/mlview-0.9.0-r1-10_port_to_gtksourceview2.patch
@@ -0,0 +1,218 @@
+Downloaded from http://patch-tracker.debian.org/patch/series/view/mlview/0.9.0-2.2/10_port_to_gtksourceview2.patch
+
+diff -Nur -x '*.orig' -x '*~' mlview-0.9.0/configure.in mlview-0.9.0.new/configure.in
+--- mlview-0.9.0/configure.in 2005-08-07 09:42:07.000000000 +0200
++++ mlview-0.9.0.new/configure.in 2009-08-18 02:45:29.000000000 +0200
+@@ -29,7 +29,7 @@
+ LIBGNOME2_VERSION=2.4.1
+ GCONF2_VERSION=2.6.2
+ SEWFOX_VERSION=0.0.1
+-GTKSOURCEVIEW_VERSION=1.0
++GTKSOURCEVIEW_VERSION=2.0
+ VTE_VERSION=0.11.12
+ DBUS_VERSION=0.22
+ GTKMM2_VERSION=2.4.0
+@@ -306,7 +306,7 @@
+ dnl **********************
+ dnl libgtksourceview
+ dnl **********************
+-PKG_CHECK_MODULES(GTKSOURCEVIEW, gtksourceview-1.0 >= $GTKSOURCEVIEW_VERSION)
++PKG_CHECK_MODULES(GTKSOURCEVIEW, gtksourceview-2.0 >= $GTKSOURCEVIEW_VERSION)
+
+ dnl **********************
+ dnl vte
+diff -Nur -x '*.orig' -x '*~' mlview-0.9.0/src/mlview-source-view.cc mlview-0.9.0.new/src/mlview-source-view.cc
+--- mlview-0.9.0/src/mlview-source-view.cc 2005-08-07 09:42:28.000000000 +0200
++++ mlview-0.9.0.new/src/mlview-source-view.cc 2009-08-18 02:44:12.000000000 +0200
+@@ -25,9 +25,10 @@
+
+ #include <string.h>
+ #include <gtk/gtk.h>
++#include "config.h"
+ #include <gtksourceview/gtksourceview.h>
+ #include <gtksourceview/gtksourcelanguage.h>
+-#include <gtksourceview/gtksourcelanguagesmanager.h>
++#include <gtksourceview/gtksourcelanguagemanager.h>
+ #include <gtksourceview/gtksourcebuffer.h>
+ #include "mlview-safe-ptr-utils.h"
+ #include "mlview-source-view.h"
+@@ -36,6 +37,7 @@
+ #include "mlview-prefs.h"
+ #include "mlview-prefs-category-sourceview.h"
+
++
+ namespace mlview
+ {
+ struct SourceViewPriv
+@@ -48,7 +50,7 @@
+ SafePtr<GtkSourceView, GtkSourceViewRef, GtkSourceViewUnref> native_sv_ptr ;
+ SafePtr<Gtk::Widget, GtkWidgetMMRef, GtkWidgetMMUnref> native_sv_wrapper_ptr ;
+ /* The language manager, used by native_sv */
+- GtkSourceLanguagesManager *languages_manager ;
++ GtkSourceLanguageManager *languages_manager ;
+
+ GtkUIManager *ui_manager ;
+
+@@ -165,8 +167,8 @@
+ gtk_source_view_set_show_line_numbers (source_view,
+ m_prefs->show_line_numbers ());
+
+- gtk_source_view_set_tabs_width (source_view,
+- m_prefs->get_tabs_width ());
++ gtk_source_view_set_tab_width (source_view,
++ m_prefs->get_tabs_width ());
+
+ gtk_source_view_set_auto_indent (source_view,
+ m_prefs->auto_indent ());
+@@ -175,11 +177,11 @@
+ (source_view,
+ m_prefs->replace_tabs_with_spaces ());
+
+- gtk_source_view_set_show_margin (source_view,
+- m_prefs->show_margin ());
++ gtk_source_view_set_show_right_margin (source_view,
++ m_prefs->show_margin ());
+
+- gtk_source_view_set_margin (source_view,
+- m_prefs->get_margin_position ());
++ gtk_source_view_set_right_margin_position (source_view,
++ m_prefs->get_margin_position ());
+
+ const char* fontname = const_cast<char*> (
+ m_prefs->get_font_name ().c_str ());
+@@ -240,8 +242,8 @@
+ {
+ GtkSourceView *source_view = (GtkSourceView*)native_sv_ptr;
+
+- gtk_source_view_set_tabs_width (source_view,
+- m_prefs->get_tabs_width ());
++ gtk_source_view_set_tab_width (source_view,
++ m_prefs->get_tabs_width ());
+ }
+
+ void
+@@ -268,8 +270,8 @@
+ {
+ GtkSourceView *source_view = (GtkSourceView*)native_sv_ptr;
+
+- gtk_source_view_set_show_margin (source_view,
+- m_prefs->show_margin ());
++ gtk_source_view_set_show_right_margin (source_view,
++ m_prefs->show_margin ());
+ }
+
+ void
+@@ -277,8 +279,8 @@
+ {
+ GtkSourceView *source_view = (GtkSourceView*)native_sv_ptr;
+
+- gtk_source_view_set_margin (source_view,
+- m_prefs->get_margin_position ());
++ gtk_source_view_set_right_margin_position (source_view,
++ m_prefs->get_margin_position ());
+ }
+
+ void
+@@ -469,14 +471,13 @@
+ return false;
+ }
+
+-GtkSourceLanguagesManager *
++GtkSourceLanguageManager *
+ SourceView::get_languages_manager ()
+ {
+ THROW_IF_FAIL (m_priv) ;
+
+ if (!m_priv->languages_manager) {
+- m_priv->languages_manager =
+- gtk_source_languages_manager_new () ;
++ m_priv->languages_manager = gtk_source_language_manager_new () ;
+ THROW_IF_FAIL (m_priv->languages_manager) ;
+ }
+ return m_priv->languages_manager ;
+@@ -492,7 +493,7 @@
+ (gtk_text_view_get_buffer (GTK_TEXT_VIEW (m_priv->native_sv_ptr.get ()))) ;
+ THROW_IF_FAIL (source_buffer) ;
+
+- gtk_source_buffer_set_highlight (source_buffer, TRUE) ;
++ gtk_source_buffer_set_highlight_syntax (source_buffer, TRUE) ;
+ gtk_source_buffer_set_language (source_buffer, a_language) ;
+
+ return MLVIEW_OK ;
+@@ -501,22 +502,22 @@
+ enum MlViewStatus
+ SourceView::set_language_from_mime_type (const UString &a_mime_type)
+ {
+- GtkSourceLanguagesManager *lm = NULL ;
++ GtkSourceLanguageManager *lm = NULL ;
+ GtkSourceLanguage *language = NULL ;
+
+ THROW_IF_FAIL (m_priv) ;
+ lm = get_languages_manager () ;
+ THROW_IF_FAIL (lm) ;
+- language = gtk_source_languages_manager_get_language_from_mime_type
+- (lm, a_mime_type.c_str ()) ;
++ language = gtk_source_language_manager_guess_language
++ (lm, NULL, a_mime_type.c_str ()) ;
+ LOG_TO_ERROR_STREAM ("language associated to '"
+ << a_mime_type
+ <<"'mime type: "
+ << language) ;
+ if (!language) {
+ language =
+- gtk_source_languages_manager_get_language_from_mime_type
+- (lm,"text/xml") ;
++ gtk_source_language_manager_guess_language
++ (lm, NULL, "text/xml") ;
+ THROW_IF_FAIL (language) ;
+ LOG_TO_ERROR_STREAM ("falling back to the language associated to"
+ "mime type 'text/xml'") ;
+@@ -1305,7 +1306,7 @@
+ m_priv->show_line_numbers) ;
+
+ m_priv->tabs_width = 4 ;
+- gtk_source_view_set_tabs_width
++ gtk_source_view_set_tab_width
+ (m_priv->native_sv_ptr,
+ m_priv->tabs_width) ;
+
+@@ -1314,11 +1315,11 @@
+ m_priv->set_autoindent) ;
+
+ m_priv->set_show_margin = FALSE ;
+- gtk_source_view_set_show_margin (m_priv->native_sv_ptr,
+- m_priv->set_show_margin) ;
++ gtk_source_view_set_show_right_margin (m_priv->native_sv_ptr,
++ m_priv->set_show_margin) ;
+ m_priv->margin = 2 ;
+- gtk_source_view_set_margin (m_priv->native_sv_ptr,
+- m_priv->margin) ;
++ gtk_source_view_set_right_margin_position (m_priv->native_sv_ptr,
++ m_priv->margin) ;
+
+ set_default_language () ;
+
+diff -Nur -x '*.orig' -x '*~' mlview-0.9.0/src/mlview-source-view.h mlview-0.9.0.new/src/mlview-source-view.h
+--- mlview-0.9.0/src/mlview-source-view.h 2005-08-07 09:42:28.000000000 +0200
++++ mlview-0.9.0.new/src/mlview-source-view.h 2009-08-18 02:39:22.000000000 +0200
+@@ -25,9 +25,10 @@
+ #ifndef __MLVIEW_SOURCE_VIEW_H
+ #define __MLVIEW_SOURCE_VIEW_H
+
++#include "config.h"
+ #include <gtksourceview/gtksourceview.h>
+ #include <gtksourceview/gtksourcelanguage.h>
+-#include <gtksourceview/gtksourcelanguagesmanager.h>
++#include <gtksourceview/gtksourcelanguagemanager.h>
+ #include <gtksourceview/gtksourcebuffer.h>
+ #include "mlview-view-adapter.h"
+ #include "mlview-xml-document.h"
+@@ -112,7 +113,7 @@
+
+ enum MlViewStatus build_edit_menu_body (const UString &a_menu_root_path) ;
+
+- GtkSourceLanguagesManager * get_languages_manager () ;
++ GtkSourceLanguageManager * get_languages_manager () ;
+
+ enum MlViewStatus set_language (GtkSourceLanguage *a_language) ;
+
diff --git a/app-editors/mlview/files/mlview-0.9.0-r1-autoreconf.patch b/app-editors/mlview/files/mlview-0.9.0-r1-autoreconf.patch
new file mode 100644
index 000000000000..205a746c69d5
--- /dev/null
+++ b/app-editors/mlview/files/mlview-0.9.0-r1-autoreconf.patch
@@ -0,0 +1,25 @@
+--- mlview-0.9.0/configure.in
++++ mlview-0.9.0/configure.in
+@@ -77,11 +77,10 @@
+ MLVIEW_EXE=$prefix/bin/mlv
+ AC_SUBST(MLVIEW_VERSION_NUMBER)
+ AC_SUBST(MLVIEW_VERSION)
+-AC_SUBST(AC_PACKAGE_VERSION)
++AC_SUBST([AC_PACKAGE_VERSION])
+ AC_SUBST(LIBMLVIEW_VERSION_NUMBER)
+ AC_SUBST(LIBMLVIEW_VERSION_INFO)
+ AC_SUBST(LIBMLVIEW_VERSION)
+-AC_SUBST(AC_PACKAGE_VERSION)
+ AC_SUBST(MLVIEW_EXE)
+
+ dnl *********************
+--- mlview-0.9.0/pixmaps/Makefile.am
++++ mlview-0.9.0/pixmaps/Makefile.am
+@@ -4,7 +4,6 @@
+ xml-root.png \
+ xml-root-open.png \
+ xml-comment-node.png \
+- xml-text-node.png \
+ xml-pi-node.png \
+ xml-entity-ref-node.png \
+ mlview-xsd-schema.png \
diff --git a/app-editors/mlview/metadata.xml b/app-editors/mlview/metadata.xml
new file mode 100644
index 000000000000..23ee8a338f21
--- /dev/null
+++ b/app-editors/mlview/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <longdescription>
+ The MlView project is an on going effort to develop an xml editor
+ for GNOME environment. It is written in C and uses the gnome
+ libraries (libxml2, gtk+, libgnome*, etc).
+ </longdescription>
+</pkgmetadata>
diff --git a/app-editors/mlview/mlview-0.9.0-r1.ebuild b/app-editors/mlview/mlview-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..0e20ca1e158d
--- /dev/null
+++ b/app-editors/mlview/mlview-0.9.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="XML editor for the GNOME environment"
+HOMEPAGE="http://www.nongnu.org/mlview/mlview-internals.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.6.11:2
+ >=dev-libs/libxslt-1.1.8
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.6:2
+ >=dev-cpp/gtkmm-2.4:2.4
+ >=gnome-base/libglade-2.4:2.0
+ >=dev-cpp/libglademm-2.6:2.4
+ >=gnome-base/libgnome-2.8.1
+ >=gnome-base/gnome-vfs-2.6:2
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-base/gconf-2.6.2:2
+ x11-libs/gtksourceview:2.0
+ >=x11-libs/vte-0.11.12:0
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext
+"
+
+src_prepare() {
+ DOCS="AUTHORS BRANCHES ChangeLog NEWS README"
+
+ # Fix tests
+ echo "ui/mlview-exec-command.glade" >> po/POTFILES.in || die
+ echo "ui/mlview-plugins-window.glade" >> po/POTFILES.in || die
+
+ epatch "${FILESDIR}"/${P}-desktop.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+ epatch "${FILESDIR}"/${PF}-10_port_to_gtksourceview2.patch
+ epatch "${FILESDIR}"/${PF}-autoreconf.patch
+
+ mkdir m4 || die
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug)
+}