summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/moe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/moe')
-rw-r--r--app-editors/moe/Manifest2
-rw-r--r--app-editors/moe/files/moe-1.6-tinfo.patch11
-rw-r--r--app-editors/moe/metadata.xml12
-rw-r--r--app-editors/moe/moe-1.6.ebuild37
-rw-r--r--app-editors/moe/moe-1.7.ebuild37
5 files changed, 99 insertions, 0 deletions
diff --git a/app-editors/moe/Manifest b/app-editors/moe/Manifest
new file mode 100644
index 000000000000..018733f57453
--- /dev/null
+++ b/app-editors/moe/Manifest
@@ -0,0 +1,2 @@
+DIST moe-1.6.tar.lz 75108 SHA256 8cafd9c97b40ff002b4cb66f63eb149f5fd9b9b964c5b6306458d0a68f89dcb1 SHA512 0aa717c865d41f73adccddbb158ae67b611a64f24258bcce5a68fea8175d28d6db55a0fb356fb294bfe3106c0973607b1fcc76ceee17d360e30eb80650ec043b WHIRLPOOL b7e55d187185f9eccea731619f4a6c4816125b2514eec68a202d00c33efb687945f025ef45ad5c49af67719486283b35a5f4639f476f86be7c5f9d58580f31ae
+DIST moe-1.7.tar.lz 79644 SHA256 33ba66f948353c105232e9c8b2da8dc7b6ddc8cdff4beb3e3f55d78bc3acf1bb SHA512 e961291c55e5b2af09e3b5cb0d07b557b0af1f6143339390e5b06f4bdebace888f7c3866ec936bd20f25b23cc96fdfdb7bd3da6690e684ec24513b106ae53b49 WHIRLPOOL e909d66efc4a5cf7ed7d968e29ed7ed92b995fa0bdca38c4348396a1dae4b8e06968b012762f6bef3fbf0ec1dd736024ff466f649a47b9da67e67d97ae0e634c
diff --git a/app-editors/moe/files/moe-1.6-tinfo.patch b/app-editors/moe/files/moe-1.6-tinfo.patch
new file mode 100644
index 000000000000..6b91460e8e53
--- /dev/null
+++ b/app-editors/moe/files/moe-1.6-tinfo.patch
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2014-11-03 00:33:57.152593136 +0300
++++ Makefile.in 2014-11-03 00:34:21.121592519 +0300
+@@ -4,7 +4,7 @@
+ INSTALL_PROGRAM = $(INSTALL) -m 755
+ INSTALL_DATA = $(INSTALL) -m 644
+ INSTALL_DIR = $(INSTALL) -d -m 755
+-LIBS = -lncurses
++LIBS = $(shell ${PKG_CONFIG} --libs ncurses)
+ SHELL = /bin/sh
+
+ edobjs = basic_buffer.o block.o buffer.o buffer_handle.o \
diff --git a/app-editors/moe/metadata.xml b/app-editors/moe/metadata.xml
new file mode 100644
index 000000000000..1b9fb5b7d4b0
--- /dev/null
+++ b/app-editors/moe/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zlogene@gentoo.org</email>
+ <name>Mikle Kolyada</name>
+ </maintainer>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-editors/moe/moe-1.6.ebuild b/app-editors/moe/moe-1.6.ebuild
new file mode 100644
index 000000000000..b4ebcc801378
--- /dev/null
+++ b/app-editors/moe/moe-1.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs unpacker
+
+DESCRIPTION="A powerful and user-friendly console text editor"
+HOMEPAGE="http://www.gnu.org/software/moe/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ sys-libs/ncurses
+"
+DEPEND="
+ $(unpacker_src_uri_depends)
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ tc-export CXX PKG_CONFIG
+ sed -i \
+ -e "/^CXXFLAGS=/d" \
+ -e "/^LDFLAGS=/d" \
+ -e "/^CXX=/d" \
+ configure || die "sed on configure failed"
+
+ epatch_user
+
+ epatch "${FILESDIR}/${P}-tinfo.patch"
+}
diff --git a/app-editors/moe/moe-1.7.ebuild b/app-editors/moe/moe-1.7.ebuild
new file mode 100644
index 000000000000..cbe5d767fd66
--- /dev/null
+++ b/app-editors/moe/moe-1.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs unpacker
+
+DESCRIPTION="A powerful and user-friendly console text editor"
+HOMEPAGE="http://www.gnu.org/software/moe/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ sys-libs/ncurses
+"
+DEPEND="
+ $(unpacker_src_uri_depends)
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ tc-export CXX PKG_CONFIG
+ sed -i \
+ -e "/^CXXFLAGS=/d" \
+ -e "/^LDFLAGS=/d" \
+ -e "/^CXX=/d" \
+ configure || die "sed on configure failed"
+
+ epatch_user
+
+ epatch "${FILESDIR}/${PN}-1.6-tinfo.patch"
+}