summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-06-02 10:12:02 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-02 10:48:49 +0200
commit8fa7dc6c58110775f20d28ff4f3c9fdf9865865f (patch)
treef66507d7dd1070f443750a451c9a345859f6d407 /app-editors/mousepad/mousepad-0.4.1.ebuild
parentapp-emacs/slime: Bump version to 2.21 (diff)
downloadgentoo-8fa7dc6c58110775f20d28ff4f3c9fdf9865865f.tar.gz
gentoo-8fa7dc6c58110775f20d28ff4f3c9fdf9865865f.tar.bz2
gentoo-8fa7dc6c58110775f20d28ff4f3c9fdf9865865f.zip
app-editors/mousepad: Bump to 0.4.1
Diffstat (limited to 'app-editors/mousepad/mousepad-0.4.1.ebuild')
-rw-r--r--app-editors/mousepad/mousepad-0.4.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-editors/mousepad/mousepad-0.4.1.ebuild b/app-editors/mousepad/mousepad-0.4.1.ebuild
new file mode 100644
index 000000000000..b1fbf67bac64
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.4.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="https://git.xfce.org/apps/mousepad/about/"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus gtk3"
+
+RDEPEND=">=dev-libs/glib-2.30:2=
+ dbus? ( >=dev-libs/dbus-glib-0.100:0= )
+ !gtk3? ( >=x11-libs/gtk+-2.24:2=
+ x11-libs/gtksourceview:2.0= )
+ gtk3? ( >=x11-libs/gtk+-3.20:3=
+ x11-libs/gtksourceview:3.0= )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable dbus)
+ $(use_enable gtk3)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+ xdg_desktop_database_update
+}