summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-28 17:15:18 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-28 17:43:12 +0200
commitdf7128fe1cf31726c4b40027666286c4b9f628c5 (patch)
tree9665fdd156fcde0790f42f2030e3749ac0a7d8f5 /app-editors/mousepad/mousepad-0.4.2.ebuild
parentxfce-base/xfce4-settings: Bump to 4.13.8 (diff)
downloadgentoo-df7128fe1cf31726c4b40027666286c4b9f628c5.tar.gz
gentoo-df7128fe1cf31726c4b40027666286c4b9f628c5.tar.bz2
gentoo-df7128fe1cf31726c4b40027666286c4b9f628c5.zip
app-editors/mousepad: Bump to 0.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-editors/mousepad/mousepad-0.4.2.ebuild')
-rw-r--r--app-editors/mousepad/mousepad-0.4.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-editors/mousepad/mousepad-0.4.2.ebuild b/app-editors/mousepad/mousepad-0.4.2.ebuild
new file mode 100644
index 000000000000..03b03b84cfe2
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.4.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="https://git.xfce.org/apps/mousepad/about/"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus +gtk3"
+# D-Bus code fails to build against GTK+2
+# https://bugzilla.xfce.org/show_bug.cgi?id=15755
+REQUIRED_USE="dbus? ( gtk3 )"
+
+RDEPEND=">=dev-libs/glib-2.42:2=
+ >=xfce-base/xfconf-4.12:=
+ !gtk3? ( >=x11-libs/gtk+-2.24:2=
+ x11-libs/gtksourceview:2.0= )
+ gtk3? ( >=x11-libs/gtk+-3.20:3=
+ x11-libs/gtksourceview:3.0= )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ dbus? ( dev-util/gdbus-codegen )"
+
+src_configure() {
+ local myconf=(
+ $(use_enable dbus)
+ $(use_enable gtk3)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}