summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-23 03:01:17 +0100
committerSam James <sam@gentoo.org>2022-09-23 03:08:50 +0100
commit93385f1c2f76c653c8e00d874ed5c5814120c926 (patch)
treef25f802c07745216645e67d6c73ab3b2383df812 /app-editors/nano
parentx11-drivers/nvidia-drivers: fix clang15 patch for x86 (diff)
downloadgentoo-93385f1c2f76c653c8e00d874ed5c5814120c926.tar.gz
gentoo-93385f1c2f76c653c8e00d874ed5c5814120c926.tar.bz2
gentoo-93385f1c2f76c653c8e00d874ed5c5814120c926.zip
app-editors/nano: drop 6.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/Manifest1
-rw-r--r--app-editors/nano/nano-6.2.ebuild93
2 files changed, 0 insertions, 94 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index c5b73d5ebd4a..9df8f4a66755 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -1,3 +1,2 @@
-DIST nano-6.2.tar.gz 3146876 BLAKE2B be6dbc1f53890764184a701e97e792762600c892933830bfcb5c2c4eab19d659583fe797d7197c9045ea8912215aa5885a05f02c66194df17253d6788e0ba599 SHA512 5a59906664a88a03f215d8dba8f7e481fbaffc7bdf93c89ca997df7a8aba2cbb4d45ac84d11f03a796488b82b01ca75161a5ab49fd9115661575451b6ab018c4
DIST nano-6.3.tar.xz 1581772 BLAKE2B 92ef2acac0dacebc0bf8364bfee928a8394d8e4323e622ad6ba9d35bebd18d3976ab0ca747f7c9b5597874775b44ba4b5560e7392606aa68736158c2bda62b92 SHA512 42279bee54f4d83a0dc06e93c2f385798c304a41e995461b018f5724010213761455563cb53e2411e12bc43c7245e289f4254c359717ca1b89a34d5af8b8c3f3
DIST nano-6.4.tar.xz 1593804 BLAKE2B b59ff7a741ce4c8b31afdbbfaf1d704cccbceddcd7f1421f30a6dd40495ec456ca891aeb9777c070c6cce4e9c594f83798ff0cdacdfe06e81b0aa0b700033da3 SHA512 cff2d9d90f1a23ab8905320e651f8bbc9d38046153a4f64bbc21927687d9628135915468b00b28f88a0eb7d395d1bcb0b9b7abcf367e5a46a5f3da01d8d6e72b
diff --git a/app-editors/nano/nano-6.2.ebuild b/app-editors/nano/nano-6.2.ebuild
deleted file mode 100644
index c76f1abb21ba..000000000000
--- a/app-editors/nano/nano-6.2.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://git.savannah.gnu.org/git/nano.git"
- inherit git-r3 autotools
-else
- MY_P="${PN}-${PV/_}"
- SRC_URI="https://www.nano-editor.org/dist/v${PV:0:1}/${MY_P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="GNU GPL'd Pico clone with more functionality"
-HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="debug justify magic minimal ncurses nls +spell +split-usr static unicode"
-
-LIB_DEPEND="
- >=sys-libs/ncurses-5.9-r1:=[unicode(+)?]
- sys-libs/ncurses:=[static-libs(+)]
- magic? ( sys-apps/file[static-libs(+)] )
- nls? ( virtual/libintl )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="${RDEPEND}
- static? ( ${LIB_DEPEND} )"
-BDEPEND="
- nls? ( sys-devel/gettext )
- virtual/pkgconfig
-"
-
-REQUIRED_USE="
- magic? ( !minimal )
-"
-
-src_prepare() {
- default
- if [[ ${PV} == "9999" ]] ; then
- eautoreconf
- fi
-}
-
-src_configure() {
- use static && append-ldflags -static
- local myconf=(
- --bindir="${EPREFIX}"/bin
- --htmldir=/trash
- $(use_enable !minimal color)
- $(use_enable !minimal multibuffer)
- $(use_enable !minimal nanorc)
- $(use_enable magic libmagic)
- $(use_enable spell speller)
- $(use_enable justify)
- $(use_enable debug)
- $(use_enable nls)
- $(use_enable unicode utf8)
- $(use_enable minimal tiny)
- )
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- # don't use "${ED}" here or things break (#654534)
- rm -r "${D}"/trash || die
-
- dodoc doc/sample.nanorc
- docinto html
- dodoc doc/faq.html
- insinto /etc
- newins doc/sample.nanorc nanorc
- if ! use minimal ; then
- # Enable colorization by default.
- sed -i \
- -e '/^# include /s:# *::' \
- "${ED}"/etc/nanorc || die
-
- # Since nano-5.0 these are no longer being "enabled" by default
- # (bug #736848)
- local rcdir="/usr/share/nano"
- mv "${ED}"${rcdir}/extra/* "${ED}"/${rcdir}/ || die
- rmdir "${ED}"${rcdir}/extra || die
-
- insinto "${rcdir}"
- doins "${FILESDIR}/gentoo.nanorc"
- fi
-
- use split-usr && dosym ../../bin/nano /usr/bin/nano
-}