summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-17 03:26:34 +0000
committerSam James <sam@gentoo.org>2021-03-17 03:29:43 +0000
commitccef6e371fb377c5d7af84be65519893eef9edf1 (patch)
treeeb4d49656023f963ea033dfd965afabb2dc839e5 /app-editors/ne
parentapp-editors/ne: correctly detect ncurses libs in 3.1.1 (diff)
downloadgentoo-ccef6e371fb377c5d7af84be65519893eef9edf1.tar.gz
gentoo-ccef6e371fb377c5d7af84be65519893eef9edf1.tar.bz2
gentoo-ccef6e371fb377c5d7af84be65519893eef9edf1.zip
app-editors/ne: add 3.3.0
Closes: https://bugs.gentoo.org/776799 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/ne')
-rw-r--r--app-editors/ne/Manifest1
-rw-r--r--app-editors/ne/ne-3.3.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-editors/ne/Manifest b/app-editors/ne/Manifest
index e47314c3bf58..ea7378b4b8ce 100644
--- a/app-editors/ne/Manifest
+++ b/app-editors/ne/Manifest
@@ -1 +1,2 @@
DIST ne-3.1.1.tar.gz 1219488 BLAKE2B 6d778c1b2e9e18154322a6b327cc4a2711619c353eb82073ad00f3e40b3b8e61f7ee7ce6fee3f0e02b38d001dc26365f44b63f70ddd6089f186a52bdf4c69a17 SHA512 e572ca2a0cd39a59adaea911c80e083872103d90a586117efcabbc3881cf1a48d0c3d06f20eebcd9254177afafef15fd581778cd251b1b25b64ad68a5f8afc37
+DIST ne-3.3.0.tar.gz 1173159 BLAKE2B a4be3fd37a0a79b440290846184bc50551cfb9b73dc50c0376110f3603233879b396f67a87e2f9defe9c0cbc42c963e66bc43ab5396f8ccb27e5b6182c429006 SHA512 73a1bbc5a9f62354834288e25b8f4bf2b0d2ff6faf3408108b217305e2c9d8fed768b5a3c3fd21df7b3bf75a3f9c71ea899a8b3f528b560a8e5e66accd442919
diff --git a/app-editors/ne/ne-3.3.0.ebuild b/app-editors/ne/ne-3.3.0.ebuild
new file mode 100644
index 000000000000..87aaff065bf8
--- /dev/null
+++ b/app-editors/ne/ne-3.3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="The nice editor, easy to use for the beginner and powerful for the wizard"
+HOMEPAGE="https://ne.di.unimi.it/"
+SRC_URI="https://ne.di.unimi.it/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="sys-libs/ncurses:="
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+"
+
+HTML_DOCS=( doc/html/. )
+
+src_prepare() {
+ default
+
+ sed -i -e 's/-O3//' src/makefile || die
+}
+
+src_configure() {
+ # bug #776799
+ sed -i -e "s/-lcurses/$($(tc-getPKG_CONFIG) --libs ncurses)/" src/makefile || die
+}
+
+src_compile() {
+ append-cflags -std=c11
+ emake -C src CC="$(tc-getCC)" \
+ NE_GLOBAL_DIR="/usr/share/${PN}" \
+ OPTS="${CFLAGS}" \
+ "${PN}"
+}
+
+src_install() {
+ dobin "src/${PN}"
+
+ insinto "/usr/share/${PN}/syntax"
+ doins syntax/*.jsf
+
+ doman "doc/${PN}.1"
+ dodoc CHANGES README.md NEWS doc/*.{txt,pdf,texinfo} doc/default.*
+}