summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-29 23:53:08 +0000
committerSam James <sam@gentoo.org>2020-09-30 00:03:40 +0000
commitf60946ba6398fac3388cb690d6c687b03d7d8d4d (patch)
tree9fff75e65ff10b8d60accbd81bf5bcec521dad64 /app-editors/neovim/neovim-9999.ebuild
parentwww-client/firefox: bump to v81.0 (diff)
downloadgentoo-f60946ba6398fac3388cb690d6c687b03d7d8d4d.tar.gz
gentoo-f60946ba6398fac3388cb690d6c687b03d7d8d4d.tar.bz2
gentoo-f60946ba6398fac3388cb690d6c687b03d7d8d4d.zip
app-editors/neovim: bump to 0.4.4
* Bump to 0.4.4 * Pave the way for tests, but we can't yet because dev-lua/busted lacks luajit support (needed for tests). * Make LTO optional. Bug: https://bugs.gentoo.org/584694 Closes: https://bugs.gentoo.org/744184 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/neovim/neovim-9999.ebuild')
-rw-r--r--app-editors/neovim/neovim-9999.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 6944c0791a40..ae758e6e27bd 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -13,12 +13,16 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/neovim/neovim.git"
else
SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="+luajit +nvimpager +tui"
+IUSE="+lto +luajit +nvimpager +tui"
+# Upstream say the test library needs LuaJIT
+# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
+#REQUIRED_USE="test? ( luajit )"
+#RESTRICT="!test? ( test )"
BDEPEND="
dev-util/gperf
@@ -26,11 +30,12 @@ BDEPEND="
virtual/libintl
virtual/pkgconfig
"
-
+# Once dev-lua/busted has luajit support, we can add tests.
+# bug #584694
DEPEND="
dev-libs/libutf8proc:=
dev-libs/libuv:0=
- >=dev-libs/libvterm-0.1
+ >=dev-libs/libvterm-0.1.2
dev-libs/msgpack:0=
dev-lua/lpeg[luajit=]
dev-lua/luv[luajit=]
@@ -46,14 +51,11 @@ DEPEND="
>=dev-libs/unibilium-2.0.0:0=
)
"
-
RDEPEND="
${DEPEND}
app-eselect/eselect-vi
"
-CMAKE_BUILD_TYPE=Release
-
src_prepare() {
# use our system vim dir
sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
@@ -63,7 +65,13 @@ src_prepare() {
}
src_configure() {
+ # Upstream default to LTO on non-debug builds
+ # Let's expose it as a USE flag because upstream
+ # have preferences for how we should use LTO
+ # if we want it on (not just -flto)
+ # ... but allow turning it off.
local mycmakeargs=(
+ -DENABLE_LTO=$(usex lto)
-DFEAT_TUI=$(usex tui)
-DPREFER_LUA=$(usex luajit no yes)
)