summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2015-12-23 23:33:02 +0100
committerUlrich Müller <ulm@gentoo.org>2015-12-23 23:33:02 +0100
commit358960f9b06b100d33f02545039e6408c856b7b9 (patch)
tree144c9354aa3b32a8676c368fbff9c7216d13b2c1 /app-editors/qemacs/files
parentprofiles/arch/powerpc: Unmask net-firewall/iptables[nftables] on ppc, bug #56... (diff)
downloadgentoo-358960f9b06b100d33f02545039e6408c856b7b9.tar.gz
gentoo-358960f9b06b100d33f02545039e6408c856b7b9.tar.bz2
gentoo-358960f9b06b100d33f02545039e6408c856b7b9.zip
app-editors/qemacs: New snapshot.
This fixes building with GCC 5.3. Bug: 569494 Package-Manager: portage-2.2.26
Diffstat (limited to 'app-editors/qemacs/files')
-rw-r--r--app-editors/qemacs/files/qemacs-0.4.1_pre20150916-Makefile.patch38
-rw-r--r--app-editors/qemacs/files/qemacs-0.4.1_pre20150916-nostrip.patch38
2 files changed, 76 insertions, 0 deletions
diff --git a/app-editors/qemacs/files/qemacs-0.4.1_pre20150916-Makefile.patch b/app-editors/qemacs/files/qemacs-0.4.1_pre20150916-Makefile.patch
new file mode 100644
index 000000000000..53c71f21580d
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.4.1_pre20150916-Makefile.patch
@@ -0,0 +1,38 @@
+Removes forced march setting and align-functions on x86, as they would
+override user's CFLAGS.
+
+--- qemacs-orig/Makefile
++++ qemacs/Makefile
+@@ -29,32 +29,6 @@
+ cmd :=
+ endif
+
+-ifeq ($(CC),gcc)
+- CFLAGS += -Wall -g -O2 -funsigned-char
+- # do not warn about zero-length formats.
+- CFLAGS += -Wno-format-zero-length
+- LDFLAGS := -g
+-endif
+-
+-#include local compiler configuration file
+--include $(DEPTH)/cflags.mk
+-
+-ifdef TARGET_GPROF
+- CFLAGS += -p
+- LDFLAGS += -p
+-endif
+-
+-TLDFLAGS := $(LDFLAGS)
+-
+-ifdef TARGET_ARCH_X86
+- #CFLAGS+=-fomit-frame-pointer
+- ifeq ($(GCC_MAJOR),2)
+- CFLAGS+=-m386 -malign-functions=0
+- else
+- CFLAGS+=-march=i386 -falign-functions=0
+- endif
+-endif
+-
+ DEFINES=-DHAVE_QE_CONFIG_H
+
+ ########################################################
diff --git a/app-editors/qemacs/files/qemacs-0.4.1_pre20150916-nostrip.patch b/app-editors/qemacs/files/qemacs-0.4.1_pre20150916-nostrip.patch
new file mode 100644
index 000000000000..2ee40c6d2fdb
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.4.1_pre20150916-nostrip.patch
@@ -0,0 +1,38 @@
+Suppress stripping.
+
+--- qemacs-orig/Makefile
++++ qemacs/Makefile
+@@ -168,7 +168,6 @@
+ qe$(EXE): qe_g$(EXE) Makefile
+ @rm -f $@
+ cp $< $@
+- -$(STRIP) $@
+ @ls -l $@
+ @echo `size $@` `wc -c $@` qe $(OPTIONS) \
+ | cut -d ' ' -f 7-10,13,15-40 >> STATS
+@@ -183,7 +182,6 @@
+ tqe$(EXE): tqe_g$(EXE) Makefile
+ @rm -f $@
+ cp $< $@
+- -$(STRIP) $@
+ @ls -l $@
+ @echo `size $@` `wc -c $@` tqe $(OPTIONS) \
+ | cut -d ' ' -f 7-10,13,15-40 >> STATS
+@@ -386,7 +384,7 @@
+ $(INSTALL) -m 755 -d $(DESTDIR)$(prefix)/bin
+ $(INSTALL) -m 755 -d $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 755 -d $(DESTDIR)$(datadir)/qe
+- $(INSTALL) -m 755 -s qe$(EXE) $(DESTDIR)$(prefix)/bin/qemacs$(EXE)
++ $(INSTALL) -m 755 qe$(EXE) $(DESTDIR)$(prefix)/bin/qemacs$(EXE)
+ ln -sf qemacs $(DESTDIR)$(prefix)/bin/qe$(EXE)
+ ifdef CONFIG_FFMPEG
+ ln -sf qemacs$(EXE) $(DESTDIR)$(prefix)/bin/ffplay$(EXE)
+@@ -394,7 +392,7 @@
+ $(INSTALL) -m 644 kmaps ligatures $(DESTDIR)$(datadir)/qe
+ $(INSTALL) -m 644 qe.1 $(DESTDIR)$(mandir)/man1
+ ifdef CONFIG_HTML
+- $(INSTALL) -m 755 -s html2png$(EXE) $(DESTDIR)$(prefix)/bin
++ $(INSTALL) -m 755 html2png$(EXE) $(DESTDIR)$(prefix)/bin
+ endif
+
+ uninstall: