summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/qemacs/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/qemacs/files')
-rw-r--r--app-editors/qemacs/files/qemacs-0.3.2_pre20070226-tty_utf8.patch43
-rw-r--r--app-editors/qemacs/files/qemacs-0.4.0_pre20080605-Makefile.patch35
-rw-r--r--app-editors/qemacs/files/qemacs-0.4.0_pre20080605-make_backup.patch68
-rw-r--r--app-editors/qemacs/files/qemacs-0.4.0_pre20090420-nostrip.patch36
4 files changed, 182 insertions, 0 deletions
diff --git a/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-tty_utf8.patch b/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-tty_utf8.patch
new file mode 100644
index 000000000000..1f51ada5c2b7
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.3.2_pre20070226-tty_utf8.patch
@@ -0,0 +1,43 @@
+utf8 input in tty.c
+http://lists.gnu.org/archive/html/qemacs-devel/2004-03/msg00000.html
+http://bugs.gentoo.org/62829
+
+--- qemacs-orig/tty.c 2007-02-08 00:27:33.000000000 +0100
++++ qemacs/tty.c 2007-02-26 15:07:41.000000000 +0100
+@@ -78,7 +78,6 @@
+ /* input handling */
+ enum InputState input_state;
+ int input_param;
+- int utf8_state;
+ int utf8_index;
+ unsigned char buf[10];
+ char *term_name;
+@@ -374,15 +373,19 @@
+
+ /* charset handling */
+ if (s->charset == &charset_utf8) {
+- if (ts->utf8_state == 0) {
+- const char *p;
+- p = (const char *)ts->buf;
+- ch = utf8_decode(&p);
+- } else {
+- ts->utf8_state = utf8_length[ts->buf[0]] - 1;
+- ts->utf8_index = 0;
+- return;
+- }
++ /* Make sure utf8 input works correctly 20040314 <damm@opensource.se> */
++ ts->utf8_index++;
++
++ if (utf8_length[ts->buf[0]] == ts->utf8_index) {;
++ const char *p;
++ p = (const char *)ts->buf;
++ ch = utf8_decode(&p);
++ ts->utf8_index = 0;
++ }
++ else {
++ return;
++ }
++
+ } else {
+ ch = ts->buf[0];
+ }
diff --git a/app-editors/qemacs/files/qemacs-0.4.0_pre20080605-Makefile.patch b/app-editors/qemacs/files/qemacs-0.4.0_pre20080605-Makefile.patch
new file mode 100644
index 000000000000..73c3f68b13a3
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.4.0_pre20080605-Makefile.patch
@@ -0,0 +1,35 @@
+--- Makefile.orig 2009-03-07 21:27:48.000000000 +0100
++++ Makefile 2009-03-07 21:28:43.000000000 +0100
+@@ -19,32 +19,6 @@
+
+ include config.mak
+
+-ifeq ($(CC),gcc)
+- CFLAGS := -Wall -g -O2 -funsigned-char
+- # do not warn about zero-length formats.
+- CFLAGS += -Wno-format-zero-length
+- LDFLAGS := -g
+-endif
+-
+-#include local compiler configuration file
+--include cflags.mk
+-
+-ifdef TARGET_GPROF
+- CFLAGS += -p
+- LDFLAGS += -p
+-endif
+-
+-TLDFLAGS := $(LDFLAGS)
+-
+-ifdef TARGET_ARCH_X86
+- #CFLAGS+=-fomit-frame-pointer
+- ifeq ($(GCC_MAJOR),2)
+- CFLAGS+=-m386 -malign-functions=0
+- else
+- CFLAGS+=-march=i386 -falign-functions=0
+- endif
+-endif
+-
+ DEFINES=-DHAVE_QE_CONFIG_H
+
+ ########################################################
diff --git a/app-editors/qemacs/files/qemacs-0.4.0_pre20080605-make_backup.patch b/app-editors/qemacs/files/qemacs-0.4.0_pre20080605-make_backup.patch
new file mode 100644
index 000000000000..cdfe4c439db8
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.4.0_pre20080605-make_backup.patch
@@ -0,0 +1,68 @@
+Add make-backup-files command for backup toggling, from upstream mailing list:
+http://lists.gnu.org/archive/html/qemacs-devel/2004-11/msg00007.html
+http://bugs.gentoo.org/75052
+
+--- buffer.c.orig 2009-03-07 21:14:02.000000000 +0100
++++ buffer.c 2009-03-07 21:15:40.000000000 +0100
+@@ -1657,12 +1657,14 @@
+ if (stat(filename, &st) == 0)
+ mode = st.st_mode & 0777;
+
+- /* backup old file if present */
+- if (strlen(filename) < MAX_FILENAME_SIZE - 1) {
++ /* backup old file if present and make-backup-files is on */
++ if(mbf == 1) {
++ if (strlen(filename) < MAX_FILENAME_SIZE - 1) {
+ if (snprintf(buf1, sizeof(buf1), "%s~", filename) < ssizeof(buf1)) {
+ // should check error code
+ rename(filename, buf1);
+ }
++ }
+ }
+
+ /* CG: should pass mode to buffer_save */
+--- qe.c.orig 2009-03-07 21:14:09.000000000 +0100
++++ qe.c 2009-03-07 21:17:01.000000000 +0100
+@@ -71,6 +71,7 @@
+ static int screen_height = 0;
+ static int no_init_file;
+ static const char *user_option;
++mbf = 1;
+
+ /* mode handling */
+
+@@ -5316,6 +5317,14 @@
+ do_refresh(qs->first_window);
+ }
+
++static void make_backup_files(EditState *s) {
++ if(mbf == 1) {
++ mbf = 0;
++ } else {
++ mbf = 1;
++ }
++}
++
+ /* compute default path for find/save buffer */
+ static void get_default_path(EditState *s, char *buf, int buf_size)
+ {
+--- qeconfig.h.orig 2009-03-07 21:14:19.000000000 +0100
++++ qeconfig.h 2009-03-07 21:17:37.000000000 +0100
+@@ -192,6 +192,7 @@
+ "downcase-region", do_changecase_region, ESi, -1, "*v")
+ CMD3( KEY_CTRLX(KEY_CTRL('u')), KEY_NONE,
+ "upcase-region", do_changecase_region, ESi, 1, "*v")
++ CMD0( KEY_NONE, KEY_NONE, "make-backup-files", make_backup_files)
+
+ /*---------------- Command handling ----------------*/
+
+--- qe.h.orig 2009-03-07 21:14:26.000000000 +0100
++++ qe.h 2009-03-07 21:17:53.000000000 +0100
+@@ -1765,6 +1765,7 @@
+ /* image.c */
+ void fill_border(EditState *s, int x, int y, int w, int h, int color);
+ int qe_bitmap_format_to_pix_fmt(int format);
++int mbf;
+
+ /* shell.c */
+ EditBuffer *new_shell_buffer(EditBuffer *b0, const char *name,
diff --git a/app-editors/qemacs/files/qemacs-0.4.0_pre20090420-nostrip.patch b/app-editors/qemacs/files/qemacs-0.4.0_pre20090420-nostrip.patch
new file mode 100644
index 000000000000..120b09c2129d
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.4.0_pre20090420-nostrip.patch
@@ -0,0 +1,36 @@
+--- qemacs-orig/Makefile
++++ qemacs/Makefile
+@@ -151,7 +151,6 @@
+ qe$(EXE): qe_g$(EXE) Makefile
+ rm -f $@
+ cp $< $@
+- -$(STRIP) $@
+ @ls -l $@
+ echo `size $@` `wc -c $@` qe $(OPTIONS) \
+ | cut -d ' ' -f 7-10,13,15-40 >> STATS
+@@ -165,7 +164,6 @@
+ tqe$(EXE): tqe_g$(EXE) Makefile
+ rm -f $@
+ cp $< $@
+- -$(STRIP) $@
+ @ls -l $@
+ echo `size $@` `wc -c $@` tqe $(OPTIONS) \
+ | cut -d ' ' -f 7-10,13,15-40 >> STATS
+@@ -329,7 +327,7 @@
+ $(INSTALL) -m 755 -d $(DESTDIR)$(prefix)/bin
+ $(INSTALL) -m 755 -d $(DESTDIR)$(prefix)/man/man1
+ $(INSTALL) -m 755 -d $(DESTDIR)$(prefix)/share/qe
+- $(INSTALL) -m 755 -s qe$(EXE) $(DESTDIR)$(prefix)/bin/qemacs$(EXE)
++ $(INSTALL) -m 755 qe$(EXE) $(DESTDIR)$(prefix)/bin/qemacs$(EXE)
+ ln -sf qemacs $(DESTDIR)$(prefix)/bin/qe$(EXE)
+ ifdef CONFIG_FFMPEG
+ ln -sf qemacs$(EXE) $(DESTDIR)$(prefix)/bin/ffplay$(EXE)
+@@ -337,7 +335,7 @@
+ $(INSTALL) -m 644 kmaps ligatures $(DESTDIR)$(prefix)/share/qe
+ $(INSTALL) -m 644 qe.1 $(DESTDIR)$(prefix)/man/man1
+ ifdef CONFIG_HTML
+- $(INSTALL) -m 755 -s html2png$(EXE) $(DESTDIR)$(prefix)/bin
++ $(INSTALL) -m 755 html2png$(EXE) $(DESTDIR)$(prefix)/bin
+ endif
+
+ uninstall: