summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Kustov <ktrace@yandex.ru>2022-04-18 21:47:40 +0300
committerJoonas Niilola <juippis@gentoo.org>2022-05-02 15:08:36 +0300
commit33e5acc534fecffb02f564b62947063370f7b358 (patch)
tree88b396a7b5ce8b5dd2337744d33599aa9337957b /app-editors/qhexedit2
parentdev-embedded/ponyprog: bump version to 3.1.3 (diff)
downloadgentoo-33e5acc534fecffb02f564b62947063370f7b358.tar.gz
gentoo-33e5acc534fecffb02f564b62947063370f7b358.tar.bz2
gentoo-33e5acc534fecffb02f564b62947063370f7b358.zip
app-editors/qhexedit2: bump to 0.8.9
- bump version - switch to vanile Simsys/qhexedit Signed-off-by: Victor Kustov <ktrace@yandex.ru> Package-Manager: Portage-3.0.30, Repoman-3.0.3 Closes: https://github.com/gentoo/gentoo/pull/25095 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors/qhexedit2')
-rw-r--r--app-editors/qhexedit2/Manifest1
-rw-r--r--app-editors/qhexedit2/files/qhexedit2-0.8.9.patch36
-rw-r--r--app-editors/qhexedit2/qhexedit2-0.8.9_p20210525.ebuild79
3 files changed, 116 insertions, 0 deletions
diff --git a/app-editors/qhexedit2/Manifest b/app-editors/qhexedit2/Manifest
index 31427cf34c3b..cd73ea49b28c 100644
--- a/app-editors/qhexedit2/Manifest
+++ b/app-editors/qhexedit2/Manifest
@@ -1 +1,2 @@
DIST qhexedit2-0.8.6_p20190316.tar.gz 355512 BLAKE2B a7edc8d05a7788f3a3f2202762ca3dc436cafbde1b1216ff1bb342055600a2e9d53c27fe324380331b8182904545c698106129238065cd2416d244fdfa176446 SHA512 4ef288c8a220c308d38c41fee83fe962e213cdfa448445ef73c3d2fe1952b68f2096732e78d2aa0a87eddd3cf2f47bed3e77807e12d2b7616c1447b3bf1b0e7d
+DIST qhexedit2-0.8.9_p20210525.tar.gz 342178 BLAKE2B baffe5b5e1130476162f23a91420cc86675a162c39539c9f07685cecc82571817625202814006221f96b56e94c0325fd7a6d8f2294041b426054f809c9967bad SHA512 d8a5159433a1212085371473cc7a89c4888c6af6b1416a34e3ea9d1ef9ae19411af32bea2e2fb256a024d6f2d05c733d285314cfc17f37dae065d7407a9c0d2c
diff --git a/app-editors/qhexedit2/files/qhexedit2-0.8.9.patch b/app-editors/qhexedit2/files/qhexedit2-0.8.9.patch
new file mode 100644
index 000000000000..cabbd77ac843
--- /dev/null
+++ b/app-editors/qhexedit2/files/qhexedit2-0.8.9.patch
@@ -0,0 +1,36 @@
+diff --git a/setup.py b/setup.py
+index 1a0d912..646c359 100644
+--- a/setup.py
++++ b/setup.py
+@@ -98,7 +98,7 @@ if cfg.qt_framework:
+ lib + ".framework", "Headers")]
+ else:
+ if PyQt_Version == 'PyQt5':
+- for qt_inc_dir in ('/usr/include/qt', '/usr/include/x86_64-linux-gnu/qt5'):
++ for qt_inc_dir in ('/usr/include/qt', '/usr/include/qt5'):
+ include_dirs.append(qt_inc_dir)
+ include_dirs += [os.path.join(qt_inc_dir, lib) for lib in qt_libs]
+ libraries = ["Qt5" + lib[2:] for lib in qt_libs]
+diff --git a/src/qhexedit.pro b/src/qhexedit.pro
+index 2a94016..55d7bc2 100644
+--- a/src/qhexedit.pro
++++ b/src/qhexedit.pro
+@@ -23,5 +23,7 @@ Release:TARGET = qhexedit
+ Debug:TARGET = qhexeditd
+
+
+-unix:DESTDIR = /usr/lib
+ win32:DESTDIR = ../lib
++
++target.path = /usr/lib64
++INSTALLS += target
+diff --git a/src/qhexedit.sip b/src/qhexedit.sip
+index 082621e..a7ef4e7 100644
+--- a/src/qhexedit.sip
++++ b/src/qhexedit.sip
+@@ -1,4 +1,4 @@
+-%Module(name=qhexedit, version=1)
++%Module(name=qhexedit)
+
+ %Import QtCore/QtCoremod.sip
+ %Import QtGui/QtGuimod.sip
diff --git a/app-editors/qhexedit2/qhexedit2-0.8.9_p20210525.ebuild b/app-editors/qhexedit2/qhexedit2-0.8.9_p20210525.ebuild
new file mode 100644
index 000000000000..0818ddefb0cb
--- /dev/null
+++ b/app-editors/qhexedit2/qhexedit2-0.8.9_p20210525.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+#DISTUTILS_OPTIONAL=1
+#DISTUTILS_USE_PEP517=p
+
+inherit distutils-r1 qmake-utils
+
+EGIT_COMMIT="541139125be034b90b6811a84faa1413e357fd94"
+DESCRIPTION="Hex editor library, Qt application written in C++ with Python bindings"
+HOMEPAGE="https://github.com/Simsys/qhexedit2/"
+SRC_URI="https://github.com/Simsys/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="doc +gui python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.8.9.patch" )
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ python? (
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+src_configure() {
+ eqmake5 src/qhexedit.pro
+ if use gui; then
+ cd example || die "can't cd example"
+ eqmake5 qhexedit.pro
+ fi
+}
+
+src_compile() {
+ default
+ use python && distutils-r1_src_compile
+ use gui && emake -C example
+}
+
+python_compile() {
+ use python && distutils-r1_python_compile build_ext
+}
+
+src_test() {
+ cd test || die "can't cd test"
+ mkdir logs || die "can't create logs dir"
+ eqmake5 chunks.pro
+ emake
+ ./chunks || die "test run failed"
+ grep -q "^NOK" logs/Summary.log && die "test failed"
+}
+
+src_install() {
+ doheader src/*.h
+ dolib.so libqhexedit.so*
+ use python && distutils-r1_src_install
+ if use gui; then
+ dobin example/qhexedit
+ insinto /usr/share/${PN}/
+ doins example/translations/*.qm
+ fi
+ if use doc; then
+ dodoc -r doc/html
+ dodoc doc/release.txt
+ fi
+}