summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-07-15 10:15:18 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-07-15 11:06:36 +0300
commit4d4c45e341348864d77e2a817610cad637ed4ce5 (patch)
tree9035d5af950d354acef1c8132108af7ce99cb5d0 /app-editors/retext/retext-7.1.0.ebuild
parentapp-editors/retext: Update live ebuild (diff)
downloadgentoo-4d4c45e341348864d77e2a817610cad637ed4ce5.tar.gz
gentoo-4d4c45e341348864d77e2a817610cad637ed4ce5.tar.bz2
gentoo-4d4c45e341348864d77e2a817610cad637ed4ce5.zip
app-editors/retext: use D_U_S, optfeature
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors/retext/retext-7.1.0.ebuild')
-rw-r--r--app-editors/retext/retext-7.1.0.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/app-editors/retext/retext-7.1.0.ebuild b/app-editors/retext/retext-7.1.0.ebuild
index f06ff35ad247..482db4845ce4 100644
--- a/app-editors/retext/retext-7.1.0.ebuild
+++ b/app-editors/retext/retext-7.1.0.ebuild
@@ -7,7 +7,7 @@ EAPI=7
# https://bitbucket.org/pypy/compatibility/wiki/Home#!gui-library-bindings
PYTHON_COMPAT=( python3_{7,8,9} )
-inherit distutils-r1 virtualx xdg-utils
+inherit distutils-r1 eutils virtualx xdg-utils
DISTUTILS_USE_SETUPTOOLS=rdepend
MY_PN="ReText"
@@ -28,7 +28,6 @@ fi
LICENSE="GPL-2+"
SLOT="0"
-IUSE="+spell"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -40,14 +39,8 @@ RDEPEND="
dev-python/python-markdown-math[${PYTHON_USEDEP}]
dev-python/PyQt5[gui,network,printsupport,widgets,${PYTHON_USEDEP}]
dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
"
+DEPEND="${RDEPEND}"
src_test() {
virtx distutils-r1_src_test
@@ -61,6 +54,8 @@ pkg_postinst() {
xdg_desktop_database_update
xdg_icon_cache_update
+ optfeature "dictionary support" dev-python/pyenchant
+
einfo "Starting with retext-7.0.4 the markdown-math plugin is installed."
einfo "Note that you can use different math delimiters, e.g. \(...\) for inline math."
einfo "For more details take a look at:"