summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-03 09:26:59 +0100
committerSam James <sam@gentoo.org>2022-06-03 09:26:59 +0100
commit75a0c76e46b055884379160d1adf1e087ef0ad26 (patch)
tree37f97a58a0db49dc7a67da66cb072d1623d202aa /app-editors/retext/retext-9999.ebuild
parentmedia-gfx/inkscape: add missing dev-python/cssselect dep (diff)
downloadgentoo-75a0c76e46b055884379160d1adf1e087ef0ad26.tar.gz
gentoo-75a0c76e46b055884379160d1adf1e087ef0ad26.tar.bz2
gentoo-75a0c76e46b055884379160d1adf1e087ef0ad26.zip
app-editors/retext: add 7.2.3
Closes: https://bugs.gentoo.org/848999 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/retext/retext-9999.ebuild')
-rw-r--r--app-editors/retext/retext-9999.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/app-editors/retext/retext-9999.ebuild b/app-editors/retext/retext-9999.ebuild
index ac4f08fb2467..214372f2d90a 100644
--- a/app-editors/retext/retext-9999.ebuild
+++ b/app-editors/retext/retext-9999.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# Please don't add pypy support before testing if it's actually supported. The
# old compat matrix is no longer accessible as of 2021-02-13 but stated back
# in 2020-07-05 that PyQt5 was explicitly not supported.
PYTHON_COMPAT=( python3_{8,9,10} )
-inherit distutils-r1 optfeature virtualx xdg-utils
+inherit distutils-r1 optfeature qmake-utils virtualx xdg
MY_PN="ReText"
MY_P="${MY_PN}-${PV/_/~}"
@@ -40,19 +40,28 @@ RDEPEND="
dev-python/PyQt5[dbus,gui,printsupport,widgets,${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
-BDEPEND="test? ( dev-python/PyQt5[testlib,${PYTHON_USEDEP}] )"
+BDEPEND="
+ dev-qt/linguist-tools
+ test? ( dev-python/PyQt5[testlib,${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests unittest
+
+pkg_setup() {
+ # Needed for lrelease
+ export PATH="$(qt5_get_bindir):${PATH}"
+}
src_test() {
virtx distutils-r1_src_test
}
python_test() {
- esetup.py test
+ eunittest || die
}
pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
+ xdg_pkg_postinst
optfeature "dictionary support" dev-python/pyenchant
# See https://bugs.gentoo.org/772197.
@@ -63,8 +72,3 @@ pkg_postinst() {
einfo "For more details take a look at:"
einfo "https://github.com/mitya57/python-markdown-math#math-delimiters"
}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}