summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-20 22:16:00 +0000
committerSam James <sam@gentoo.org>2022-11-20 22:18:29 +0000
commitb0d37e9ee70ba7c49e212443aa55c6123949aa65 (patch)
tree98fb6649dd2140e9fe99753c7cda1cf39a76ffad /app-editors/teco
parentnet-analyzer/nessus-agent-bin: add 10.3.0, drop 10.2.0 (diff)
downloadgentoo-b0d37e9ee70ba7c49e212443aa55c6123949aa65.tar.gz
gentoo-b0d37e9ee70ba7c49e212443aa55c6123949aa65.tar.bz2
gentoo-b0d37e9ee70ba7c49e212443aa55c6123949aa65.zip
[QA] Revert "app-editors/teco: Disable overzealous CFLAGS"
This reverts commit 4e63e475293ba270157d0ddc6e9e2adc40ec9b3b. This isn't an acceptable fix for Clang 16 / GCC 14 issues, not least because these usually indicate likely runtime failure. While K&R style declarations can be excused for old code, implicit function declarations simply don't work in any C version. See the documentation at https://wiki.gentoo.org/wiki/Modern_C_porting for more information on how to fix. Bug: https://bugs.gentoo.org/879041 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/teco')
-rw-r--r--app-editors/teco/teco-36_p19940820.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-editors/teco/teco-36_p19940820.ebuild b/app-editors/teco/teco-36_p19940820.ebuild
index b3e32b905ec3..d37ed3f84e1f 100644
--- a/app-editors/teco/teco-36_p19940820.ebuild
+++ b/app-editors/teco/teco-36_p19940820.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -37,7 +37,7 @@ src_prepare() {
}
src_compile() {
- append-flags -ansi -Wno-implicit-function-declaration -Wno-implicit-int
+ append-flags -ansi
append-cppflags -D_POSIX_SOURCE
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}