summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2021-04-03 12:20:45 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-04-13 10:16:03 +0300
commit4440adba07f9f93560e288f0dff4a0490fa62fea (patch)
treeeb247d31c89339e1065a73c05ca05ad2c17409de /app-editors/ted/ted-2.23-r1.ebuild
parentapp-editors/ted: bump to EAPI 7 (diff)
downloadgentoo-4440adba07f9f93560e288f0dff4a0490fa62fea.tar.gz
gentoo-4440adba07f9f93560e288f0dff4a0490fa62fea.tar.bz2
gentoo-4440adba07f9f93560e288f0dff4a0490fa62fea.zip
app-editors/ted: use Motif toolkit by default
Use Motif instead of Gtk-2, which is alternatively supported as a GUI. Bugday 2021-04-03 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/20241 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors/ted/ted-2.23-r1.ebuild')
-rw-r--r--app-editors/ted/ted-2.23-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-editors/ted/ted-2.23-r1.ebuild b/app-editors/ted/ted-2.23-r1.ebuild
index d223c7a9fcd0..b3584d9589e4 100644
--- a/app-editors/ted/ted-2.23-r1.ebuild
+++ b/app-editors/ted/ted-2.23-r1.ebuild
@@ -23,9 +23,9 @@ RDEPEND="
sys-libs/zlib
virtual/jpeg
virtual/libiconv
- x11-libs/gtk+:2
x11-libs/libXft
x11-libs/libXpm
+ x11-libs/motif
"
DEPEND="${RDEPEND}"
BDEPEND="
@@ -38,6 +38,7 @@ PATCHES=(
"${FILESDIR}"/${P}-0002-fix-unrecognized-option-with-GTK.patch
"${FILESDIR}"/${P}-0003-avoid-compressing-man-page.patch
"${FILESDIR}"/${P}-freetype261.patch
+ "${FILESDIR}"/${P}-use-Motif-toolkit-instead-of-GTK-by-default.patch
)
src_prepare() {
@@ -66,10 +67,14 @@ src_configure() {
tc-export AR CC RANLIB
local dir
- for dir in appFrame appUtil bitmap docBuf ind Ted tedPackage; do
+ for dir in appUtil textEncoding utilPs bitmap docFont docBase docBuf ind drawMeta docRtf docEdit docLayout docHtml; do
cd "${S}"/${dir}
econf --cache-file=../config.cache
done
+ for dir in appFrame; do
+ cd "${S}"/${dir}
+ econf --cache-file=../config.cache --with-MOTIF
+ done
}
src_compile() {