summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-07-23 21:09:44 +0530
committerJoonas Niilola <juippis@gentoo.org>2023-08-14 09:13:25 +0300
commit23b895cb15a8abc0cb5263d3ff18e8ca10d9c25b (patch)
treea92e6939ed0b1c1ae46acc64bcbab819bb0d7aaa /app-editors/texworks/files
parentsci-libs/libcifpp: remove unused patch(es) (diff)
downloadgentoo-23b895cb15a8abc0cb5263d3ff18e8ca10d9c25b.tar.gz
gentoo-23b895cb15a8abc0cb5263d3ff18e8ca10d9c25b.tar.bz2
gentoo-23b895cb15a8abc0cb5263d3ff18e8ca10d9c25b.zip
app-editors/texworks: Fix call to undeclared function vasprintf
Closes: https://bugs.gentoo.org/882461 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32003 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-editors/texworks/files')
-rw-r--r--app-editors/texworks/files/texworks-0.6.7-vasprintf-clang16-fix.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/app-editors/texworks/files/texworks-0.6.7-vasprintf-clang16-fix.patch b/app-editors/texworks/files/texworks-0.6.7-vasprintf-clang16-fix.patch
new file mode 100644
index 000000000000..ce8e9e2daca0
--- /dev/null
+++ b/app-editors/texworks/files/texworks-0.6.7-vasprintf-clang16-fix.patch
@@ -0,0 +1,12 @@
+Bug: https://bugs.gentoo.org/882461
+Reverting commit ccf692bb38c43a38f8e9f755dd48451c6f6ad430
+--- a/modules/synctex/CMakeLists.txt
++++ b/modules/synctex/CMakeLists.txt
+@@ -26,6 +26,4 @@ endif()
+
+ # SyncTeX uses vasprintf which is not in POSIX; thus gcc prints a warning unless
+ # _GNU_SOURCE is defined. Other compilers seem to be fine.
+-if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
+- target_compile_definitions(SyncTeX PRIVATE _GNU_SOURCE)
+-endif()
++target_compile_definitions(SyncTeX PRIVATE _GNU_SOURCE)