summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-10-21 19:40:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-10-21 23:04:17 +0200
commit4ceb19e276bcdd7669911281457c0c025a7f6858 (patch)
tree66b4b457dc1e2183d2f6155da14e57986142dc12 /app-editors/texworks/files
parentapp-office/texmaker: add 5.1.4, EAPI-8 bump (diff)
downloadgentoo-4ceb19e276bcdd7669911281457c0c025a7f6858.tar.gz
gentoo-4ceb19e276bcdd7669911281457c0c025a7f6858.tar.bz2
gentoo-4ceb19e276bcdd7669911281457c0c025a7f6858.zip
app-editors/texworks: add 0.6.8, EAPI-8 bump, python3_12, drop virtualx
- add missing dev-qt/qttest:5 dependency - dev-qt/qtscript:5 was replaced by dev-qt/qtdeclarative:5 - fix upstream's "optional" (really not) Qt5Script in build system Bug: https://bugs.gentoo.org/915780 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-editors/texworks/files')
-rw-r--r--app-editors/texworks/files/texworks-0.6.8-optional-qtscript.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-editors/texworks/files/texworks-0.6.8-optional-qtscript.patch b/app-editors/texworks/files/texworks-0.6.8-optional-qtscript.patch
new file mode 100644
index 000000000000..460c4f4f7e2d
--- /dev/null
+++ b/app-editors/texworks/files/texworks-0.6.8-optional-qtscript.patch
@@ -0,0 +1,25 @@
+It doesn't work like that.
+
+--- a/CMakeLists.txt 2023-02-18 11:42:11.000000000 +0100
++++ b/CMakeLists.txt 2023-10-21 20:00:29.144638825 +0200
+@@ -281,9 +281,11 @@
+ set(QT_VERSION_PATCH "${Qt6_VERSION_PATCH}")
+ else ()
+ # Check for Qt5
+- find_package(Qt5 REQUIRED COMPONENTS Core Widgets Gui UiTools Concurrent Xml LinguistTools Qml OPTIONAL_COMPONENTS Script ScriptTools)
++ find_package(Qt5 REQUIRED COMPONENTS Core Widgets Gui UiTools Concurrent Xml LinguistTools Qml)
+ set(QT_LIBRARIES Qt5::Core Qt5::Widgets Qt5::Gui Qt5::UiTools Qt5::Concurrent Qt5::Xml Qt5::Qml)
+
++ find_package(Qt5Script)
++ find_package(Qt5ScriptTools)
+ if (Qt5Script_FOUND AND Qt5ScriptTools_FOUND)
+ list(APPEND QT_LIBRARIES Qt5::ScriptTools Qt5::Script)
+ set(WITH_QTSCRIPT ON)
+@@ -311,7 +313,6 @@
+ set(QT_VERSION_MAJOR "${Qt5_VERSION_MAJOR}")
+ set(QT_VERSION_MINOR "${Qt5_VERSION_MINOR}")
+ set(QT_VERSION_PATCH "${Qt5_VERSION_PATCH}")
+- set(WITH_QTSCRIPT ON)
+ endif ()
+
+ # Expose the major version number of Qt to the preprocessor. This is necessary