summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-21 23:27:09 +0000
committerMarek Szuba <marecki@gentoo.org>2020-12-21 23:27:09 +0000
commit570aa4c79552ceaa3ee20e02b4e4bd7855bc4d83 (patch)
tree0cd2343e1c927e15f03b062c495dbdf69c54fcf2 /app-editors/texworks/files
parentdev-games/openscenegraph: migrate to lua-single.eclass (diff)
downloadgentoo-570aa4c79552ceaa3ee20e02b4e4bd7855bc4d83.tar.gz
gentoo-570aa4c79552ceaa3ee20e02b4e4bd7855bc4d83.tar.bz2
gentoo-570aa4c79552ceaa3ee20e02b4e4bd7855bc4d83.zip
app-editors/texworks: migrate to lua-single.eclass
The usual CMake find_package(Lua) version dance. Lua compatibility as per the bundled FindLua.cmake. Closes: https://bugs.gentoo.org/752534 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-editors/texworks/files')
-rw-r--r--app-editors/texworks/files/texworks-0.6.5-cmake_lua_version.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/app-editors/texworks/files/texworks-0.6.5-cmake_lua_version.patch b/app-editors/texworks/files/texworks-0.6.5-cmake_lua_version.patch
new file mode 100644
index 000000000000..630443d5f119
--- /dev/null
+++ b/app-editors/texworks/files/texworks-0.6.5-cmake_lua_version.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -297,7 +297,7 @@
+ # -------------------------------
+
+ IF ( WITH_LUA )
+- FIND_PACKAGE(Lua)
++ FIND_PACKAGE(Lua ${LUA_VERSION} EXACT REQUIRED)
+ ENDIF()
+
+ IF ( WITH_PYTHON )