summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-29 13:56:33 +0100
committerSam James <sam@gentoo.org>2021-10-29 14:02:38 +0100
commit9b32eb9c94042b14c041905bf8d4bc4d9a82a22c (patch)
treeedf5fdf3a92146bd1daaac19e92d0d783d6d6501 /app-editors/vim-core/vim-core-9999.ebuild
parentapp-editors/vim-core: slightly modernise ebuild (diff)
downloadgentoo-9b32eb9c94042b14c041905bf8d4bc4d9a82a22c.tar.gz
gentoo-9b32eb9c94042b14c041905bf8d4bc4d9a82a22c.tar.bz2
gentoo-9b32eb9c94042b14c041905bf8d4bc4d9a82a22c.zip
app-editors/vim-core: add 8.2.3567
Bug: https://bugs.gentoo.org/820692 Bug: https://bugs.gentoo.org/819528 Bug: https://bugs.gentoo.org/818562 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/vim-core/vim-core-9999.ebuild')
-rw-r--r--app-editors/vim-core/vim-core-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-editors/vim-core/vim-core-9999.ebuild b/app-editors/vim-core/vim-core-9999.ebuild
index 1dfe65d75bdb..7e80dc2f16f9 100644
--- a/app-editors/vim-core/vim-core-9999.ebuild
+++ b/app-editors/vim-core/vim-core-9999.ebuild
@@ -61,7 +61,7 @@ src_prepare() {
# Use exuberant ctags which installs as /usr/bin/exuberant-ctags.
# Hopefully this pattern won't break for a while at least.
- # This fixes bug 29398 (27 Sep 2003 agriffis)
+ # This fixes bug #29398 (27 Sep 2003 agriffis)
sed -i 's/\<ctags\("\| [-*.]\)/exuberant-&/g' \
"${S}"/runtime/doc/syntax.txt \
"${S}"/runtime/doc/tagsrch.txt \
@@ -71,7 +71,7 @@ src_prepare() {
# Don't be fooled by /usr/include/libc.h. When found, vim thinks
# this is NeXT, but it's actually just a file in dev-libs/9libs
- # This fixes bug 43885 (20 Mar 2004 agriffis)
+ # This fixes bug #43885 (20 Mar 2004 agriffis)
sed -i 's/ libc\.h / /' "${S}"/src/configure.ac || die 'sed failed'
# gcc on sparc32 has this, uhm, interesting problem with detecting EOF
@@ -102,16 +102,16 @@ src_prepare() {
src_configure() {
local myconf
- # Fix bug 37354: Disallow -funroll-all-loops on amd64
+ # Fix bug #37354: Disallow -funroll-all-loops on amd64
# Bug 57859 suggests that we want to do this for all archs
filter-flags -funroll-all-loops
- # Fix bug 76331: -O3 causes problems, use -O2 instead. We'll do this for
+ # Fix bug #76331: -O3 causes problems, use -O2 instead. We'll do this for
# everyone since previous flag filtering bugs have turned out to affect
# multiple archs...
replace-flags -O3 -O2
- # Fix bug 18245: Prevent "make" from the following chain:
+ # Fix bug #18245: Prevent "make" from the following chain:
# (1) Notice configure.ac is newer than auto/configure
# (2) Rebuild auto/configure
# (3) Notice auto/configure is newer than auto/config.mk
@@ -127,7 +127,7 @@ src_configure() {
# things are for ppc64, see bug 86433.
for file in /dev/pty/s* /dev/console /dev/hvc/* /dev/hvc*; do
if [[ -e "${file}" ]]; then
- addwrite $file
+ addwrite ${file}
fi
done