summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-04 03:24:18 +0000
committerSam James <sam@gentoo.org>2022-11-04 03:25:07 +0000
commit9f5d3532993ce5e69c1726d6cc077237801f338d (patch)
tree9c628fb811b4186dffd37f090f2057d4fe3260a5 /app-editors/vim-core
parentapp-editors/vim: fix configure w/ clang 16 (diff)
downloadgentoo-9f5d3532993ce5e69c1726d6cc077237801f338d.tar.gz
gentoo-9f5d3532993ce5e69c1726d6cc077237801f338d.tar.bz2
gentoo-9f5d3532993ce5e69c1726d6cc077237801f338d.zip
app-editors/vim-core: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/vim-core')
-rw-r--r--app-editors/vim-core/files/vim-0.0.0828-configure-clang16.patch28
-rw-r--r--app-editors/vim-core/vim-core-9.0.0828-r1.ebuild (renamed from app-editors/vim-core/vim-core-9.0.0828.ebuild)4
2 files changed, 32 insertions, 0 deletions
diff --git a/app-editors/vim-core/files/vim-0.0.0828-configure-clang16.patch b/app-editors/vim-core/files/vim-0.0.0828-configure-clang16.patch
new file mode 100644
index 000000000000..e202a9dd3caa
--- /dev/null
+++ b/app-editors/vim-core/files/vim-0.0.0828-configure-clang16.patch
@@ -0,0 +1,28 @@
+https://github.com/vim/vim/pull/11496
+
+From 360b569f86b851c37e32b7cfaec079823188ff27 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Fri, 4 Nov 2022 03:18:23 +0000
+Subject: [PATCH] configure.ac: Fix -Wimplicit-int
+
+Clang 16 makes -Wimplicit-int an error by default. Fixes errors like:
+```
+error: type specifier missing, defaults to 'int'; ISO C99 and later do not support implicit int [-Werror,-Wimplicit-int]
+```
+
+We already use proper declarations with every other test anyway, so
+let's be consistent.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/src/configure.ac
++++ b/src/configure.ac
+@@ -3654,7 +3654,7 @@ dnl check if struct sigcontext is defined (used for SGI only)
+ AC_MSG_CHECKING(for struct sigcontext)
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([
+ #include <signal.h>
+-test_sig()
++int test_sig()
+ {
+ struct sigcontext *scont;
+ scont = (struct sigcontext *)0;
+
diff --git a/app-editors/vim-core/vim-core-9.0.0828.ebuild b/app-editors/vim-core/vim-core-9.0.0828-r1.ebuild
index 9412ba51653d..e078361724fc 100644
--- a/app-editors/vim-core/vim-core-9.0.0828.ebuild
+++ b/app-editors/vim-core/vim-core-9.0.0828-r1.ebuild
@@ -30,6 +30,10 @@ IUSE="nls acl minimal"
DEPEND=">=sys-libs/ncurses-5.2-r2:0"
BDEPEND="sys-devel/autoconf"
+PATCHES=(
+ "${FILESDIR}"/vim-0.0.0828-configure-clang16.patch
+)
+
pkg_setup() {
# people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL