summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/vim-qt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/vim-qt')
-rw-r--r--app-editors/vim-qt/Manifest2
-rw-r--r--app-editors/vim-qt/files/vim-qt.desktop9
-rw-r--r--app-editors/vim-qt/metadata.xml13
-rw-r--r--app-editors/vim-qt/vim-qt-20140827-r2.ebuild119
-rw-r--r--app-editors/vim-qt/vim-qt-20150102.ebuild120
5 files changed, 263 insertions, 0 deletions
diff --git a/app-editors/vim-qt/Manifest b/app-editors/vim-qt/Manifest
new file mode 100644
index 000000000000..ba264146fb7e
--- /dev/null
+++ b/app-editors/vim-qt/Manifest
@@ -0,0 +1,2 @@
+DIST vim-qt-20140827.tar.gz 12251966 SHA256 61eba646bf25fd3caa40943ecd91e5e7a813e11ca71d899e9e844e3f69e97a60 SHA512 0ab352a64f138e68059311908b2e4b0cbbec55c2fa889ff64f863670c3d1ee0022d26877175090d5c256eb1cdfaf7d23d385044a68e2eb8b50b1cdab2a20827f WHIRLPOOL ea397f465902796761c44e6521ab6b2660498d1e3ce4821d3265517ba1c72984b93e580549be921e156771f2ccbb86fce1c830035ad00513eb9e42c1f1ff6abd
+DIST vim-qt-20150102.tar.gz 12285083 SHA256 1a3553f491e7990d4256c3c70f2d9d1804c2de5c6ac2c12845b173ff3d531157 SHA512 37434ff6cbac3dd97e3c5cb328a857afa8a8ddc4cea7b3879a06b4dd418e5b7516a68dc5c2b0c9c8b6332d316fc593b120400eab04c444c0065f3b74ae2d682d WHIRLPOOL 60d9838532b25ad8c31638e51ccf82769382dccb420c070068537ad7c15314dbc2b5fd177ed9d57674b3f593937f3c539bdd7a98e305eab40059a29ae4bf2b09
diff --git a/app-editors/vim-qt/files/vim-qt.desktop b/app-editors/vim-qt/files/vim-qt.desktop
new file mode 100644
index 000000000000..207bf332ed14
--- /dev/null
+++ b/app-editors/vim-qt/files/vim-qt.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=vim-Qt
+Comment=A highly configurable text editor
+Exec=qvim -f %F
+Icon=vim-qt
+Terminal=false
+Type=Application
+MimeType=text/plain;
+Categories=Qt;TextEditor;Development;
diff --git a/app-editors/vim-qt/metadata.xml b/app-editors/vim-qt/metadata.xml
new file mode 100644
index 000000000000..502c73de07f6
--- /dev/null
+++ b/app-editors/vim-qt/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <use>
+ <flag name="luajit">Use <pkg>dev-lang/luajit</pkg> instead of <pkg>dev-lang/lua</pkg></flag>
+ <flag name="racket">Enable support for Scheme using <pkg>dev-lang/racket</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">equalsraf/vim-qt</remote-id>
+ <remote-id type="bitbucket">equalsraf/vim-qt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-editors/vim-qt/vim-qt-20140827-r2.ebuild b/app-editors/vim-qt/vim-qt-20140827-r2.ebuild
new file mode 100644
index 000000000000..12d724ce82f0
--- /dev/null
+++ b/app-editors/vim-qt/vim-qt-20140827-r2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="threads"
+inherit eutils fdo-mime flag-o-matic prefix python-single-r1
+
+DESCRIPTION="Qt GUI version of the Vim text editor"
+HOMEPAGE="https://bitbucket.org/equalsraf/vim-qt/wiki/Home"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI=(
+ "https://bitbucket.org/equalsraf/${PN}.git"
+ "https://github.com/equalsraf/${PN}.git"
+ "git://gitorious.org/${PN}/${PN}.git"
+ )
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/equalsraf/${PN}/archive/package-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-package-${PV}"
+fi
+
+LICENSE="vim"
+SLOT="0"
+IUSE="acl cscope debug lua luajit nls perl python racket ruby"
+
+REQUIRED_USE="luajit? ( lua )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND=">=app-eselect/eselect-vi-1.1.8
+ >=app-editors/vim-core-7.4.417[acl?]
+ sys-libs/ncurses
+ >=dev-qt/qtcore-4.7.0:4
+ >=dev-qt/qtgui-4.7.0:4
+ acl? ( kernel_linux? ( sys-apps/acl ) )
+ cscope? ( dev-util/cscope )
+ lua? ( luajit? ( dev-lang/luajit )
+ !luajit? ( dev-lang/lua[deprecated] ) )
+ nls? ( virtual/libintl )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ racket? ( dev-scheme/racket )
+ ruby? ( || ( dev-lang/ruby:2.0 dev-lang/ruby:1.9 ) )"
+DEPEND="${RDEPEND}
+ dev-util/ctags
+ sys-devel/autoconf
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ export LC_COLLATE="C" # prevent locale brokenness
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Read vimrc from /etc/vim/
+ echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' >> "${S}"/src/feature.h
+}
+
+src_configure() {
+ use debug && append-flags "-DDEBUG"
+
+ local myconf="--with-features=huge --disable-gpm --enable-multibyte"
+ myconf+=" $(use_enable acl)"
+ myconf+=" $(use_enable cscope)"
+ myconf+=" $(use_enable nls)"
+ myconf+=" $(use_enable lua luainterp)"
+ myconf+=" $(use_with luajit)"
+ myconf+=" $(use_enable perl perlinterp)"
+ myconf+=" $(use_enable racket mzschemeinterp)"
+ myconf+=" $(use_enable ruby rubyinterp)"
+
+ if ! use cscope ; then
+ sed -i -e '/# define FEAT_CSCOPE/d' src/feature.h || die 'sed failed'
+ fi
+
+ # keep prefix env contained within the EPREFIX
+ use prefix && myconf+=" --without-local-dir"
+
+ if use python ; then
+ if [[ ${EPYTHON} == python3* ]] ; then
+ myconf+=" --enable-python3interp"
+ export vi_cv_path_python3="${PYTHON}"
+ else
+ myconf+=" --enable-pythoninterp"
+ export vi_cv_path_python="${PYTHON}"
+ fi
+ else
+ myconf+=" --disable-pythoninterp --disable-python3interp"
+ fi
+
+ econf ${myconf} --enable-gui=qt --with-vim-name=qvim --with-modified-by=Gentoo-${PVR}
+}
+
+src_install() {
+ dobin src/qvim
+ dosym qvim /usr/bin/qvimdiff
+
+ dodir /usr/share/man/man1
+ echo ".so vim.1" > "${ED}"/usr/share/man/man1/qvim.1
+ echo ".so vimdiff.1" > "${ED}"/usr/share/man/man1/qvimdiff.1
+
+ # track https://bitbucket.org/equalsraf/vim-qt/issue/93/include-desktop-file-in-source
+ # for inclusion of desktop file
+ newmenu "${FILESDIR}"/vim-qt.desktop vim-qt.desktop
+ doicon -s 64 src/qt/icons/vim-qt.png
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}
diff --git a/app-editors/vim-qt/vim-qt-20150102.ebuild b/app-editors/vim-qt/vim-qt-20150102.ebuild
new file mode 100644
index 000000000000..e2d31b22a076
--- /dev/null
+++ b/app-editors/vim-qt/vim-qt-20150102.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="threads"
+
+inherit eutils fdo-mime flag-o-matic prefix python-single-r1
+
+DESCRIPTION="Qt GUI version of the Vim text editor"
+HOMEPAGE="https://bitbucket.org/equalsraf/vim-qt/wiki/Home"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI=(
+ "https://bitbucket.org/equalsraf/${PN}.git"
+ "https://github.com/equalsraf/${PN}.git"
+ )
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/equalsraf/${PN}/archive/package-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${PN}-package-${PV}
+fi
+
+LICENSE="vim"
+SLOT="0"
+IUSE="acl cscope debug lua luajit nls perl python racket ruby"
+
+REQUIRED_USE="luajit? ( lua )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ >=app-editors/vim-core-7.4.560[acl?]
+ >=app-eselect/eselect-vi-1.1.8
+ >=dev-qt/qtcore-4.7.0:4
+ >=dev-qt/qtgui-4.7.0:4
+ sys-libs/ncurses
+ acl? ( kernel_linux? ( sys-apps/acl ) )
+ cscope? ( dev-util/cscope )
+ lua? ( luajit? ( dev-lang/luajit )
+ !luajit? ( dev-lang/lua[deprecated] ) )
+ nls? ( virtual/libintl )
+ perl? ( dev-lang/perl )
+ python? ( ${PYTHON_DEPS} )
+ racket? ( dev-scheme/racket )
+ ruby? ( || ( dev-lang/ruby:2.0 dev-lang/ruby:1.9 ) )"
+DEPEND="${RDEPEND}
+ dev-util/ctags
+ sys-devel/autoconf
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ export LC_COLLATE="C" # prevent locale brokenness
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Read vimrc from /etc/vim/
+ echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' >> "${S}"/src/feature.h
+}
+
+src_configure() {
+ use debug && append-flags "-DDEBUG"
+
+ local myconf="--with-features=huge --disable-gpm --enable-multibyte"
+ myconf+=" $(use_enable acl)"
+ myconf+=" $(use_enable cscope)"
+ myconf+=" $(use_enable nls)"
+ myconf+=" $(use_enable lua luainterp)"
+ myconf+=" $(use_with luajit)"
+ myconf+=" $(use_enable perl perlinterp)"
+ myconf+=" $(use_enable racket mzschemeinterp)"
+ myconf+=" $(use_enable ruby rubyinterp)"
+
+ if ! use cscope ; then
+ sed -i -e '/# define FEAT_CSCOPE/d' src/feature.h || die 'sed failed'
+ fi
+
+ # keep prefix env contained within the EPREFIX
+ use prefix && myconf+=" --without-local-dir"
+
+ if use python ; then
+ if [[ ${EPYTHON} == python3* ]] ; then
+ myconf+=" --enable-python3interp"
+ export vi_cv_path_python3="${PYTHON}"
+ else
+ myconf+=" --enable-pythoninterp"
+ export vi_cv_path_python="${PYTHON}"
+ fi
+ else
+ myconf+=" --disable-pythoninterp --disable-python3interp"
+ fi
+
+ econf ${myconf} --enable-gui=qt --with-vim-name=qvim --with-modified-by=Gentoo-${PVR}
+}
+
+src_install() {
+ dobin src/qvim
+ dosym qvim /usr/bin/qvimdiff
+
+ dodir /usr/share/man/man1
+ echo ".so vim.1" > "${ED}"/usr/share/man/man1/qvim.1
+ echo ".so vimdiff.1" > "${ED}"/usr/share/man/man1/qvimdiff.1
+
+ # track https://bitbucket.org/equalsraf/vim-qt/issue/93/include-desktop-file-in-source
+ # for inclusion of desktop file
+ newmenu "${FILESDIR}"/vim-qt.desktop vim-qt.desktop
+ doicon -s 64 src/qt/icons/vim-qt.png
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+}