summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-03-15 20:32:27 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-03-15 20:33:54 +0200
commiteb545ac50ef3ba874828b922567b37cfdc696815 (patch)
tree306e81d6e55dd25c923aee51d58e1d4ff47999fe /app-editors/vscodium
parentdev-python/django-cacheops: add 7.0 (diff)
downloadgentoo-eb545ac50ef3ba874828b922567b37cfdc696815.tar.gz
gentoo-eb545ac50ef3ba874828b922567b37cfdc696815.tar.bz2
gentoo-eb545ac50ef3ba874828b922567b37cfdc696815.zip
app-editors/vscodium: add 1.76.2.23074
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors/vscodium')
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.76.2.23074.ebuild119
2 files changed, 122 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index 3522b6fc9b93..f4d81ec54985 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -4,3 +4,6 @@ DIST vscodium-1.75.1.23040-arm64.tar.gz 114920913 BLAKE2B 9758ce3c71621eeb9d4975
DIST vscodium-1.76.1.23069-amd64.tar.gz 120798858 BLAKE2B d499b75a5c24e9aa68a5fc358bcb98fb67a67b2383cfebe0b9ae4170876fd675cde66d855f581f6cd5b4c745a03a15e345af7532510d640b4ac65b0af2413906 SHA512 a2e37eba3ec70e35f344c2cb552cd75c5d5e67ec9159ac48709d631e5324d19e9cab08f69ffc8ae1fa782aad515be6af661464dfa72ea1f18da752d1d0b48127
DIST vscodium-1.76.1.23069-arm.tar.gz 102842431 BLAKE2B 9ede508310c87948a67c8f07f4f15f4b2e2466c3f659c1a291cb20a76a784964d7174a1003b10523779c75eb0850e2e272aa7e3a02497937136f32c138b8ebd1 SHA512 f5b99f1bd9338c69c69b9643a5c5e6ade5a3df237ac042a9fc7fdbba402244516e54ab636235a1867c6594a52a33b4af32622e70511491caac7d014b42c8e51d
DIST vscodium-1.76.1.23069-arm64.tar.gz 113874748 BLAKE2B 8dd6d97571dd084ffa40662ce6f3788cb7f09bdc8fefdce15d2987f3819ffdf42762e4b2106b71c3fc4e02943be9c62ab12355a8e30ad405848cdc7b115780cf SHA512 92ba83d125f8d28ccbf06f3dd7219c08ab1d40630ae32f0620aee731340d957cf79b7e5c4068745d77d1d425e9ff64ec0cc859016882edc93cd553fd59fc9983
+DIST vscodium-1.76.2.23074-amd64.tar.gz 120804173 BLAKE2B 9f730a8cc1130c076d12317cd0038e38b9a7529d3a1947cbf24958ccc2d5ff4ef0a85d4561645777888ca9514c7403bd86c858ac858c8568bfe6597c588adc7b SHA512 3abcdb1c0f189920b32accc892c2e88695b87448f052896f15472874576ae432a829cdf641df6680c27c3e1846c149cecbdc846473f166f98003c81d599486a1
+DIST vscodium-1.76.2.23074-arm.tar.gz 102835702 BLAKE2B 6ca9ff6353b7396d8d2d906a2415cf0f14e9f0a94bcc5607479c38436963e76ac55ebca8a8983bc36003834f4237006f03f7c49fc49e5da82755322cd9457b5e SHA512 1b05dc5741c5381060492f90583bfa56120562489b814dac9f607589deef15c43dba3681a66167c5506adbfc802fe893155d77b5454040ae31c05f9b88a27e2e
+DIST vscodium-1.76.2.23074-arm64.tar.gz 113874910 BLAKE2B bb517ac6b7d41a392fec6722b895c0035ee146497f6b7ca9a52118081a9d0647a48e3e10fe48cab7a2094db70e664af2a7282587a466216e91156f23f7c1119f SHA512 80f8ed673bbe52838da20a0d5077aac060e8ba334609e8a5088fb30c88bf9813b7b91316b9eb5662587a4c4ea038ac0645ea4104150f78ce3df3a43e1ad845bb
diff --git a/app-editors/vscodium/vscodium-1.76.2.23074.ebuild b/app-editors/vscodium/vscodium-1.76.2.23074.ebuild
new file mode 100644
index 000000000000..5c5cdb4f3682
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.76.2.23074.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ amd64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-x64-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-armhf-${PV}.tar.gz -> ${P}-arm.tar.gz )
+ arm64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-arm64-${PV}.tar.gz -> ${P}-arm64.tar.gz )
+"
+
+RESTRICT="strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscode/bin/code-tunnel
+ /opt/vscodium/chrome_crashpad_handler
+ /opt/vscodium/chrome-sandbox
+ /opt/vscodium/codium
+ /opt/vscodium/libEGL.so
+ /opt/vscodium/libffmpeg.so
+ /opt/vscodium/libGLESv2.so
+ /opt/vscodium/libvk_swiftshader.so
+ /opt/vscodium/libvulkan.so*
+ /opt/vscodium/resources/app/extensions/*
+ /opt/vscodium/resources/app/node_modules.asar.unpacked/*
+ /opt/vscodium/swiftshader/libEGL.so
+ /opt/vscodium/swiftshader/libGLESv2.so
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ # Disable update server
+ sed -i "/updateUrl/d" "${S}"/resources/app/product.json || die
+
+ # Install
+ pax-mark m codium
+ insinto "/opt/${PN}"
+ doins -r *
+ fperms +x /opt/${PN}/{,bin/}codium
+ fperms +x /opt/${PN}/chrome_crashpad_handler
+ fperms 4711 /opt/${PN}/chrome-sandbox
+ fperms 755 /opt/${PN}/resources/app/extensions/git/dist/{askpass,git-editor,ssh-askpass}{,-empty}.sh
+ fperms -R +x /opt/${PN}/resources/app/out/vs/base/node
+ fperms +x /opt/${PN}/resources/app/node_modules.asar.unpacked/@vscode/ripgrep/bin/rg
+ fperms +x /opt/${PN}/resources/app/node_modules.asar.unpacked/node-pty/build/Release/spawn-helper
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/codium"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ domenu "${FILESDIR}/vscodium-wayland.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+ optfeature "keyring support inside vscode" "gnome-base/gnome-keyring"
+}