summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-02-17 21:07:25 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-02-17 21:08:11 +0200
commitfe47ee3d702ee99e8a34ccacf14da00d9aa6d0f7 (patch)
treea52d9ba8bed9db76f57ac85b104192f6137f5c5d /app-editors/vscodium
parentapp-editors/vscode: drop 1.74.3 (diff)
downloadgentoo-fe47ee3d702ee99e8a34ccacf14da00d9aa6d0f7.tar.gz
gentoo-fe47ee3d702ee99e8a34ccacf14da00d9aa6d0f7.tar.bz2
gentoo-fe47ee3d702ee99e8a34ccacf14da00d9aa6d0f7.zip
app-editors/vscodium: add 1.75.1.23040
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors/vscodium')
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.75.1.23040.ebuild119
2 files changed, 122 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index bb9784ffba9b..7480065241d6 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -4,3 +4,6 @@ DIST vscodium-1.74.3.23010-arm64.tar.gz 114464176 BLAKE2B a6682c4c26fa2bb628aced
DIST vscodium-1.75.0.23033-amd64.tar.gz 121848371 BLAKE2B 412e945fd98f3ca6fd690593d09d64ec32e2a1450c117f41b99a276f6992f38de8e315af2273e659023a9acd8101a594c5e50bb7c29c7b9d688c902fca875b50 SHA512 58a3e58c9350359538841349271794e738f4734e84af7ec83a44b11fa09517dcaa6c373bb20ae271c4646f8766f405d12e7011d0398750facd9c4aa47402976c
DIST vscodium-1.75.0.23033-arm.tar.gz 103889757 BLAKE2B ad910df8a5b245c725dcdb3d2bf4fdb602de2703a629563f6b71bad3e8ebc09a5ecf6ab1272261b7abb6aa35ea7a15ea9a8c1ee5ca52bee8deaf5b13221edf15 SHA512 9dd9b4bdc6e98c53c39ee5bde3f2001d3345de0398e848b26cca0e54cf8edd3712e4489cf3f11e7f67b9742c8dd3e9bafbf09ae5c4704a090147cfcae542e89d
DIST vscodium-1.75.0.23033-arm64.tar.gz 114924184 BLAKE2B 47d979df3eadee60e5ea6dcbf15b58518ded7086516cb9c1444ef22c3b05eef3d3b7b733a8be889fd0a08fa5e9fc4a0e5171a573b95defc951f526b95e624b0b SHA512 506ccf023fe0f1c9c18c23ab3e77b64ba64e769226e43c577764b1ca85c940c53bdef69095bb3b2d09886a02506847a5884543191e2aead12884ffcadb7b22ae
+DIST vscodium-1.75.1.23040-amd64.tar.gz 121851555 BLAKE2B 827942e3a6b903e943fbd7200c8ae1e10e2ee3e8a05592a5dbe6677171935499bdb497aa1d76b175c0a8a4dc699ee2559c8768d83b2133ab3e337313bcbe70ec SHA512 9192915d87d55b5835dee70d10e03f6ad110075b1b32809f78cd18a7d9fefb36b3440e14c0c17dd826995a04789517c21e08e0d72a0418923f1dadf2d5ce6d22
+DIST vscodium-1.75.1.23040-arm.tar.gz 103879786 BLAKE2B 2f9d0cbdc474a248a7dbd3339a9af87f88ad477a14934a2c4ca3ae5235607a79dbf9d797b669df7a8127dbfb3081bc1612b4d899d69e95faa8a7a011a1030b21 SHA512 373c7097582d4540ac1479bbb9da53b6b13288dc5ce61fd11d952f7eb289d456bf57f8c2e16d1a3532738d082857e9abebbded1142ad36f6c6ac67e25cd1a6e7
+DIST vscodium-1.75.1.23040-arm64.tar.gz 114920913 BLAKE2B 9758ce3c71621eeb9d4975d7e1c57cb079f15b6794c320df682e2748d7fd5cc4ec5dd2dbe94e16e2c6f6e7617e333dfb08d0a80dfcd9c78b01ec9c38e800491c SHA512 3baf3abd004c67c197204e92de50fc6d056926686dd921368d63c90d216c83ae15529f3f25ddc6c20deb812823f9181ddbae3b80936ff2a441a1d51e42678a03
diff --git a/app-editors/vscodium/vscodium-1.75.1.23040.ebuild b/app-editors/vscodium/vscodium-1.75.1.23040.ebuild
new file mode 100644
index 000000000000..0eddbfcc0ab9
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.75.1.23040.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ amd64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-x64-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-armhf-${PV}.tar.gz -> ${P}-arm.tar.gz )
+ arm64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-arm64-${PV}.tar.gz -> ${P}-arm64.tar.gz )
+"
+
+RESTRICT="strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscode/bin/code-tunnel
+ /opt/vscodium/chrome_crashpad_handler
+ /opt/vscodium/chrome-sandbox
+ /opt/vscodium/codium
+ /opt/vscodium/libEGL.so
+ /opt/vscodium/libffmpeg.so
+ /opt/vscodium/libGLESv2.so
+ /opt/vscodium/libvk_swiftshader.so
+ /opt/vscodium/libvulkan.so*
+ /opt/vscodium/resources/app/extensions/*
+ /opt/vscodium/resources/app/node_modules.asar.unpacked/*
+ /opt/vscodium/swiftshader/libEGL.so
+ /opt/vscodium/swiftshader/libGLESv2.so
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ # Disable update server
+ sed -i "/updateUrl/d" "${S}"/resources/app/product.json || die
+
+ # Install
+ pax-mark m codium
+ insinto "/opt/${PN}"
+ doins -r *
+ fperms +x /opt/${PN}/{,bin/}codium
+ fperms +x /opt/${PN}/chrome_crashpad_handler
+ fperms 4711 /opt/${PN}/chrome-sandbox
+ fperms 755 /opt/${PN}/resources/app/extensions/git/dist/{askpass,git-editor}{,-empty}.sh
+ fperms -R +x /opt/${PN}/resources/app/out/vs/base/node
+ fperms +x /opt/${PN}/resources/app/node_modules.asar.unpacked/@vscode/ripgrep/bin/rg
+ fperms +x /opt/${PN}/resources/app/node_modules.asar.unpacked/node-pty/build/Release/spawn-helper
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/codium"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ domenu "${FILESDIR}/vscodium-wayland.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+ optfeature "keyring support inside vscode" "gnome-base/gnome-keyring"
+}