summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-editors/wily
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-editors/wily')
-rw-r--r--app-editors/wily/Manifest1
-rw-r--r--app-editors/wily/metadata.xml7
-rw-r--r--app-editors/wily/wily-1.0-r1.ebuild37
3 files changed, 45 insertions, 0 deletions
diff --git a/app-editors/wily/Manifest b/app-editors/wily/Manifest
new file mode 100644
index 000000000000..29736ca12034
--- /dev/null
+++ b/app-editors/wily/Manifest
@@ -0,0 +1 @@
+DIST wily-9libs.tar.gz 125247 SHA256 997e1f217047d7a4e048f55bdc3e9c040c61c0598212dda1c3d1fcca5dc9dc34 SHA512 3c06ef1d9c6e77a00037570f8b8bdbcdfc7648f691675db679ba83ac0ce092762a4020b0483acd325aa57810e9a386800a94c5e6e2b5002a963b4751a4d30a5b WHIRLPOOL ddc22e6d65ca41ae452f8a9d3a62390ee77876b31c755589b1bc33606451a170eecd87566d463146bfbc014ba5585632bb0dedd314feca4cd5b50f185f17fd4d
diff --git a/app-editors/wily/metadata.xml b/app-editors/wily/metadata.xml
new file mode 100644
index 000000000000..d9cd2cad66c2
--- /dev/null
+++ b/app-editors/wily/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-editors/wily/wily-1.0-r1.ebuild b/app-editors/wily/wily-1.0-r1.ebuild
new file mode 100644
index 000000000000..02ba6baad28e
--- /dev/null
+++ b/app-editors/wily/wily-1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+MY_P="${P/1.0/9libs}"
+
+DESCRIPTION="An emulation of ACME, Plan9's hybrid window system, shell and editor for programmers"
+HOMEPAGE="http://www.netlib.org/research/9libs/"
+SRC_URI="ftp://www.netlib.org/research/9libs/${MY_P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="dev-libs/9libs
+ >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXt-1.0.0
+ >=x11-libs/libICE-1.0.0
+ >=x11-libs/libSM-1.0.0"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ export CC="$(tc-getCC)"
+ econf --includedir="/usr/include/9libs" || die "configure failed."
+ emake || die "make failed."
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed."
+ dodoc README
+ insinto /usr/share/${PN}
+ doins "${S}"/misc/*
+}