summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-05-03 14:51:34 +0200
committerSebastian Pipping <sping@gentoo.org>2021-05-03 14:51:34 +0200
commitb814af80a2efe47e32ca892ed039aeb8c1bcd553 (patch)
tree8f39c1153d2649c4fa42e26fac5855cc12378758 /app-editors/xmlcopyeditor
parentnet-misc/openssh: remove unused patch (diff)
downloadgentoo-b814af80a2efe47e32ca892ed039aeb8c1bcd553.tar.gz
gentoo-b814af80a2efe47e32ca892ed039aeb8c1bcd553.tar.bz2
gentoo-b814af80a2efe47e32ca892ed039aeb8c1bcd553.zip
app-editors/xmlcopyeditor: 1.3.0.0
Closes: https://bugs.gentoo.org/733764 Closes: https://bugs.gentoo.org/769638 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.18, Repoman-3.0.3
Diffstat (limited to 'app-editors/xmlcopyeditor')
-rw-r--r--app-editors/xmlcopyeditor/Manifest1
-rw-r--r--app-editors/xmlcopyeditor/files/xmlcopyeditor-1.3.0.0-no-automagic-enchant.patch21
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.3.0.0.ebuild48
3 files changed, 70 insertions, 0 deletions
diff --git a/app-editors/xmlcopyeditor/Manifest b/app-editors/xmlcopyeditor/Manifest
index 56816307e4f8..528164aaae89 100644
--- a/app-editors/xmlcopyeditor/Manifest
+++ b/app-editors/xmlcopyeditor/Manifest
@@ -1 +1,2 @@
DIST xmlcopyeditor-1.2.1.3.tar.gz 4266907 BLAKE2B 52e8c27a37edbcc0da46b52443f5b6754252a62f1abb7746e724270dd5cd9a2db4de60e68d495008ef55a18e9c25149825c9b26c5fd6e20d8e3937931de64e74 SHA512 1adda58bc262cd22898ba22eed3cad9f4a51f199e779172af2d51c5d7bf6dac072b9015b90906236de83d7acebe29d0aae6ae73998ec9d9b3c58b02f081e0b4d
+DIST xmlcopyeditor-1.3.0.0.tar.gz 4981894 BLAKE2B decaf8d08bcf6392624160f512e02c0e1b8924df1147d2fb19b744357077f9b23a99781c0f47c5800feffa600aea7b1fadb65282b5da438521be079aeb917de4 SHA512 5feebc56124601c1a8b7a3079b8f766c6282c256e39a2e34cdf64156ba910195a1b64fecea41d0a4022f00dcd3cd4f46f433fff3766acb6239ca70d7675b14c0
diff --git a/app-editors/xmlcopyeditor/files/xmlcopyeditor-1.3.0.0-no-automagic-enchant.patch b/app-editors/xmlcopyeditor/files/xmlcopyeditor-1.3.0.0-no-automagic-enchant.patch
new file mode 100644
index 000000000000..e07b90c5eafe
--- /dev/null
+++ b/app-editors/xmlcopyeditor/files/xmlcopyeditor-1.3.0.0-no-automagic-enchant.patch
@@ -0,0 +1,21 @@
+diff --git a/configure.ac b/configure.ac
+index 30bdf60..034bb26 100755
+--- a/configure.ac
++++ b/configure.ac
+@@ -105,13 +105,9 @@ AC_LANG(C++)
+ AC_CHECK_HEADER(expat.h, ,
+ AC_MSG_ERROR([Expat headers not found]))
+
+-# Check enchant is available
+-PKG_CHECK_MODULES(ENCHANT, [enchant], [CXXFLAGS="$CXXFLAGS -DUSE_ENCHANT"],
+- # otherwise Check ASPELL is available
+- [AC_CHECK_HEADER(aspell.h, [ASPELL_LIBS="-laspell"],
+- AC_MSG_ERROR([Aspell headers not found]))]
+-)
+-
++# Check Aspell is available
++AC_CHECK_HEADER(aspell.h, [ASPELL_LIBS="-laspell"],
++ AC_MSG_ERROR([Aspell headers not found]))
+ AC_SUBST(ASPELL_LIBS)
+
+ AC_MSG_CHECKING([the GTK version to use])
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.3.0.0.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.3.0.0.ebuild
new file mode 100644
index 000000000000..a4f5153d85c8
--- /dev/null
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.3.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0-gtk3"
+inherit autotools wxwidgets xdg
+
+DESCRIPTION="XML Copy Editor is a fast, free, validating XML editor"
+HOMEPAGE="http://xml-copy-editor.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xml-copy-editor/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 -ppc ~x86 ~amd64-linux ~x86-linux" # -ppc due SSE2 requirement
+IUSE="aqua nls"
+
+RDEPEND="
+ app-text/aspell
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/xerces-c[cpu_flags_x86_sse2,icu]
+ dev-libs/libpcre
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+DEPEND="${RDEPEND}
+ dev-libs/boost"
+BDEPEND="dev-util/intltool
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${PN}
+
+PATCHES=( "${FILESDIR}"/${P}-no-automagic-enchant.patch )
+
+src_prepare() {
+ default
+
+ # bug #440744
+ sed -i -e 's/ -Wall -g -fexceptions//g' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ setup-wxwidgets unicode
+ econf \
+ --with-gtk=3.0 \
+ --with-wx-config="${WX_CONFIG}" \
+ $(use_enable nls)
+}