summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-02-14 16:57:13 +0100
committerUlrich Müller <ulm@gentoo.org>2022-02-14 16:58:59 +0100
commit8fd517336456fd66caa4c7951aa070a2bf83d474 (patch)
tree419ebf0eece0fe082e0fa5d2ac676e9aece7bc41 /app-editors/zile
parentdev-scheme/racket: patch ncurses for expeditor support (diff)
downloadgentoo-8fd517336456fd66caa4c7951aa070a2bf83d474.tar.gz
gentoo-8fd517336456fd66caa4c7951aa070a2bf83d474.tar.bz2
gentoo-8fd517336456fd66caa4c7951aa070a2bf83d474.zip
app-editors/zile: Version bump to 2.6.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/zile')
-rw-r--r--app-editors/zile/Manifest1
-rw-r--r--app-editors/zile/zile-2.6.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-editors/zile/Manifest b/app-editors/zile/Manifest
index ec186e19f4ea..be2b2966c69b 100644
--- a/app-editors/zile/Manifest
+++ b/app-editors/zile/Manifest
@@ -1,2 +1,3 @@
DIST zile-2.3.24.tar.gz 953962 BLAKE2B 242f0f9532a536d5ba36664031cf86eba753239c0f6dcd47c086496628a730bdd0a9112dc1ffd26965068f6d66d35d3ad3c92fc2753e129adf9a5923321e2cdf SHA512 8361f42436ae9ca150f09d830096b7a3fb0089d58bffe5ad7538b5ec5cd4e0e50085213e938db1a95e2922db845d1d2f36841a65fe1b9b72f60cd930dd8f09b9
DIST zile-2.4.15.tar.gz 1490611 BLAKE2B 3744ab2459edf9b0dc9ca976c5f37625d06e0766e3a1fbb59112fe375af6f6cc5e8c068dcb127b338091f3130d32190ad4bc3a79eac7f9a4f87b46723d5a4a82 SHA512 e2a04c280ae0c0038e6ef18abec0be55063a472f77a511bf31459712be24659edcaa2d1c861d7c00bdab87a1881af03d14eb561047c386cbff5f90b13b1a2575
+DIST zile-2.6.2.tar.gz 1152751 BLAKE2B db51b534c8d76e1def91bbfe49cab501ff1bccd6fbeddd5622d8fca3695305c53e480eed1978e880621e09955e2b98519cfa02cf259006a08d1a8722122148ea SHA512 16d5cece403fc215d53b35c31fe6f743d53d7a01cdc7d101cabe6760173539c9c31e092b29c374f28a723708027f6de626fcfee302962848091f85078fa81761
diff --git a/app-editors/zile/zile-2.6.2.ebuild b/app-editors/zile/zile-2.6.2.ebuild
new file mode 100644
index 000000000000..dc7e5f762427
--- /dev/null
+++ b/app-editors/zile/zile-2.6.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION=0.52
+
+inherit toolchain-funcs vala
+
+DESCRIPTION="Zile is a small Emacs clone"
+HOMEPAGE="https://www.gnu.org/software/zile/"
+SRC_URI="mirror://gnu/zile/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libgee:0.8=
+ sys-libs/ncurses:0="
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="dev-lang/perl
+ sys-apps/help2man
+ virtual/pkgconfig
+ $(vala_depend)"
+
+# AUTHORS, FAQ, and NEWS are installed by the build system
+DOCS="README THANKS"
+
+QA_AM_MAINTAINER_MODE=".*help2man.*" #450278
+
+src_prepare() {
+ default
+ rm *_vala.stamp || die
+ vala_src_prepare
+}
+
+src_configure() {
+ econf CURSES_LIB="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
+}
+
+src_test() {
+ if tput cup 0 0 >/dev/null || tput cuu1 >/dev/null; then
+ # We have a sane terminal that can move the cursor
+ emake check
+ else
+ ewarn "Terminal type \"${TERM}\" is too stupid to run zile"
+ ewarn "Running the tests with unset TERM instead"
+ ( unset TERM; emake check )
+ fi
+}