summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-04-26 16:49:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-04-26 16:49:02 +0300
commit02798a49f33b2def59a14159cee18a72ae936217 (patch)
treedd1f7be99e4f06d3d6fd6090adf1e9044b256fe7 /app-editors
parentapp-text/poppler: Stabilize 23.03.0 ppc, #894400 (diff)
downloadgentoo-02798a49f33b2def59a14159cee18a72ae936217.tar.gz
gentoo-02798a49f33b2def59a14159cee18a72ae936217.tar.bz2
gentoo-02798a49f33b2def59a14159cee18a72ae936217.zip
app-editors/vscodium: add 1.77.3.23102
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.77.3.23102.ebuild119
2 files changed, 122 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index 73bb7881bc53..8d718112ce4d 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -7,3 +7,6 @@ DIST vscodium-1.77.0.23093-arm64.tar.gz 111842188 BLAKE2B 38a671476162a63124268c
DIST vscodium-1.77.1.23095-amd64.tar.gz 110994738 BLAKE2B 239e10f4523833909739852e776ecf3dc17f630e91b7d3a37c0789790c6c31d0b6b51e665b0bda80b233940ee6d63cea82611893550af680a5c5e9552288bf7b SHA512 59a8449e46cde8b973d3bbbf50c2d82c5abf8734575f4b9c9f61879cb862e298eab7639b06e52367083a3cdfc55394fc3d5cbe4505bb923b0688404e4351a08e
DIST vscodium-1.77.1.23095-arm.tar.gz 100602248 BLAKE2B 6d87450074fbe85ccb20905b253d6b844c14d42c291166db95a4930a2e630958a078569cc7629a3af6893eea63323b1c841e4d733628c6b9a9073255412719c0 SHA512 f5146cacc51f7a68282d5c378568b7912d3ccaacf2909fa58db35b41db91b52c9af68cca9ea58e05725b0bd45f13cb6eeeb70a14af7ca04cba4348494d5e703f
DIST vscodium-1.77.1.23095-arm64.tar.gz 111826114 BLAKE2B c13aa8de9f5b02bc220f441bde2b8b4471073efc3d668056a73488bb2b1cd51742ac1c9294e5502cadf3310a2527218ae85b87a1dc75f870edb243c5997a62e9 SHA512 6d6fe3b7f23190e305b088f0a7699fb2b847778b2181f23aa115c29c45b00de7d67fcc8cbf554da3c481baac7f7539a85c040b97ba0e39a42cfab1331bff180a
+DIST vscodium-1.77.3.23102-amd64.tar.gz 110983055 BLAKE2B f8faa40cc6c9377e73dc06b1127b647de0f7ca06d5e8d1d25e376b130116e188fb90f59a55ce3f317a84db4e98552ec5fbdfb9c5a6ec87ea7041968994025b76 SHA512 da02f2fb7e3bb9b33d714091a7be6f7ffce0a28a74a1feee1e81010d1ab586caf70d3ec80d05bffcc892af5da69a352ec01fd2a9fbc12077d3501745022730bd
+DIST vscodium-1.77.3.23102-arm.tar.gz 100620275 BLAKE2B be0807175b1b9b5d6c8e9d44121c38f6d1ed806aacf69e33c23e220d716bd545739e07d57898e0f5c73cf0a86f74d6b7021b064c6ed120e892ab4ba9f64689fc SHA512 d03600321a287a8b6ae1f739309011efc2480d414e7446547f9dc168db7077c521b2f8e58249f464bd31f2a0111cc869042283871620059a797888d5eb935a27
+DIST vscodium-1.77.3.23102-arm64.tar.gz 111829469 BLAKE2B 1bd2e4f68db9c641a9313c88955568a28198a4629dae0b476ccd0927cb08fedc9e917dae57c8ac2ace5c1ba7b7cbcb3baccc70d25b9b9532a1652a5419b0aaa7 SHA512 f60838f98430fee6f814951e4ab5c2893f29f4ad21e7b7b9651929366fd438c4a34300e89d5059584820d07201e20467d9d64fd5c4bc5b4b61da393f19d06356
diff --git a/app-editors/vscodium/vscodium-1.77.3.23102.ebuild b/app-editors/vscodium/vscodium-1.77.3.23102.ebuild
new file mode 100644
index 000000000000..5c5cdb4f3682
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.77.3.23102.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ amd64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-x64-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-armhf-${PV}.tar.gz -> ${P}-arm.tar.gz )
+ arm64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-arm64-${PV}.tar.gz -> ${P}-arm64.tar.gz )
+"
+
+RESTRICT="strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscode/bin/code-tunnel
+ /opt/vscodium/chrome_crashpad_handler
+ /opt/vscodium/chrome-sandbox
+ /opt/vscodium/codium
+ /opt/vscodium/libEGL.so
+ /opt/vscodium/libffmpeg.so
+ /opt/vscodium/libGLESv2.so
+ /opt/vscodium/libvk_swiftshader.so
+ /opt/vscodium/libvulkan.so*
+ /opt/vscodium/resources/app/extensions/*
+ /opt/vscodium/resources/app/node_modules.asar.unpacked/*
+ /opt/vscodium/swiftshader/libEGL.so
+ /opt/vscodium/swiftshader/libGLESv2.so
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ # Disable update server
+ sed -i "/updateUrl/d" "${S}"/resources/app/product.json || die
+
+ # Install
+ pax-mark m codium
+ insinto "/opt/${PN}"
+ doins -r *
+ fperms +x /opt/${PN}/{,bin/}codium
+ fperms +x /opt/${PN}/chrome_crashpad_handler
+ fperms 4711 /opt/${PN}/chrome-sandbox
+ fperms 755 /opt/${PN}/resources/app/extensions/git/dist/{askpass,git-editor,ssh-askpass}{,-empty}.sh
+ fperms -R +x /opt/${PN}/resources/app/out/vs/base/node
+ fperms +x /opt/${PN}/resources/app/node_modules.asar.unpacked/@vscode/ripgrep/bin/rg
+ fperms +x /opt/${PN}/resources/app/node_modules.asar.unpacked/node-pty/build/Release/spawn-helper
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/codium"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ domenu "${FILESDIR}/vscodium-wayland.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+ optfeature "keyring support inside vscode" "gnome-base/gnome-keyring"
+}