summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-06-03 19:11:38 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-06-03 19:11:38 +0300
commit06c29b426cfed4ae13aa0591891b5f6ef5fd424c (patch)
tree30f93b9fb26b7adc8ce2f7eb8c68105ea9a82687 /app-editors
parentmedia-gfx/libimagequant: Stabilize 4.2.0 arm64, #907768 (diff)
downloadgentoo-06c29b426cfed4ae13aa0591891b5f6ef5fd424c.tar.gz
gentoo-06c29b426cfed4ae13aa0591891b5f6ef5fd424c.tar.bz2
gentoo-06c29b426cfed4ae13aa0591891b5f6ef5fd424c.zip
app-editors/vscodium: add 1.78.2.23132
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.78.2.23132.ebuild115
2 files changed, 118 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index 24e6f68d220e..5320aa63b7a3 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -1,3 +1,6 @@
DIST vscodium-1.77.3.23102-amd64.tar.gz 110983055 BLAKE2B f8faa40cc6c9377e73dc06b1127b647de0f7ca06d5e8d1d25e376b130116e188fb90f59a55ce3f317a84db4e98552ec5fbdfb9c5a6ec87ea7041968994025b76 SHA512 da02f2fb7e3bb9b33d714091a7be6f7ffce0a28a74a1feee1e81010d1ab586caf70d3ec80d05bffcc892af5da69a352ec01fd2a9fbc12077d3501745022730bd
DIST vscodium-1.77.3.23102-arm.tar.gz 100620275 BLAKE2B be0807175b1b9b5d6c8e9d44121c38f6d1ed806aacf69e33c23e220d716bd545739e07d57898e0f5c73cf0a86f74d6b7021b064c6ed120e892ab4ba9f64689fc SHA512 d03600321a287a8b6ae1f739309011efc2480d414e7446547f9dc168db7077c521b2f8e58249f464bd31f2a0111cc869042283871620059a797888d5eb935a27
DIST vscodium-1.77.3.23102-arm64.tar.gz 111829469 BLAKE2B 1bd2e4f68db9c641a9313c88955568a28198a4629dae0b476ccd0927cb08fedc9e917dae57c8ac2ace5c1ba7b7cbcb3baccc70d25b9b9532a1652a5419b0aaa7 SHA512 f60838f98430fee6f814951e4ab5c2893f29f4ad21e7b7b9651929366fd438c4a34300e89d5059584820d07201e20467d9d64fd5c4bc5b4b61da393f19d06356
+DIST vscodium-1.78.2.23132-amd64.tar.gz 119476104 BLAKE2B f1a007c72a377dd8f9c1d1cf9c3c38bbb32d28c94305e0445fa4a94f62bd3a32e5122d881f485ebf63958e8183cbc01df96efe1e98078d065b3e4205b1bf8025 SHA512 b4432b6a47be23af8b36359867de6b84b207c2d65817ba30cda33a3b983174bf9c5a06e44a628fbd4764ad054b441fae77a757b099ab808ca7090efad5a189ea
+DIST vscodium-1.78.2.23132-arm.tar.gz 108208589 BLAKE2B 4f3ca84b8fe87907c21f0befa59969e9cb243f52ffc82ac323ae1a978e538cce31256dead42ce87cef0cbcefd09b106e6db7cc400d404468427c11fb15f8f728 SHA512 921255f6ff635f64753ec0d230bcc26f5ee69fe7160528fd077a6b8f4f6237a7e87bbe6a42b0a2463bfdc8fe466499ca15350e388477ebeaded7ab8335305c54
+DIST vscodium-1.78.2.23132-arm64.tar.gz 119733620 BLAKE2B 95b6cdfa97a02fa18e5a053b5333bcd347b2f2ed4b4a3630c060606a3a79b44e0e12c90c7d98ca86c207963f8711556f58cbab81ff45fcc6c21c0ed3f3b46824 SHA512 aeaea958574b4ce760e9dffd400c0dd3c52eabc228b55d8e6539d3ca611741e81de8e0c86cbe3d72678c5459f70ebd682a9d69fc5857e3c433366c111094d5d9
diff --git a/app-editors/vscodium/vscodium-1.78.2.23132.ebuild b/app-editors/vscodium/vscodium-1.78.2.23132.ebuild
new file mode 100644
index 000000000000..58b0e406b47e
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.78.2.23132.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ amd64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-x64-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-armhf-${PV}.tar.gz -> ${P}-arm.tar.gz )
+ arm64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-arm64-${PV}.tar.gz -> ${P}-arm64.tar.gz )
+"
+
+RESTRICT="strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscode/bin/code-tunnel
+ /opt/vscodium/chrome_crashpad_handler
+ /opt/vscodium/chrome-sandbox
+ /opt/vscodium/codium
+ /opt/vscodium/libEGL.so
+ /opt/vscodium/libffmpeg.so
+ /opt/vscodium/libGLESv2.so
+ /opt/vscodium/libvk_swiftshader.so
+ /opt/vscodium/libvulkan.so*
+ /opt/vscodium/resources/app/extensions/*
+ /opt/vscodium/resources/app/node_modules.asar.unpacked/*
+ /opt/vscodium/swiftshader/libEGL.so
+ /opt/vscodium/swiftshader/libGLESv2.so
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ # Disable update server
+ sed -i "/updateUrl/d" "${S}"/resources/app/product.json || die
+
+ # Install
+ pax-mark m codium
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym -r "/opt/${PN}/bin/codium" "usr/bin/codium"
+ dosym -r "/opt/${PN}/bin/codium-tunnel" "usr/bin/codium-tunnel"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ domenu "${FILESDIR}/vscodium-wayland.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+ optfeature "keyring support inside vscode" "gnome-base/gnome-keyring"
+}