summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMykyta Holubakha <hilobakho@gmail.com>2016-08-27 23:40:08 +0300
committerGöktürk Yüksek <gokturk@gentoo.org>2016-08-31 23:20:23 -0400
commit109b6322000fb7f86247ed2b6c9f6e30d99ccfe9 (patch)
tree452458d1fe9b985356b53e37ba1856860ab61498 /app-editors
parentapp-editors/kakoune: version bump to 0_pre20160826 (diff)
downloadgentoo-109b6322000fb7f86247ed2b6c9f6e30d99ccfe9.tar.gz
gentoo-109b6322000fb7f86247ed2b6c9f6e30d99ccfe9.tar.bz2
gentoo-109b6322000fb7f86247ed2b6c9f6e30d99ccfe9.zip
app-editors/kakoune-9999: add GCC version check
correct usage of pkg-config
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/kakoune/kakoune-9999.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/app-editors/kakoune/kakoune-9999.ebuild b/app-editors/kakoune/kakoune-9999.ebuild
index aec9313a2bee..cee92150dfc9 100644
--- a/app-editors/kakoune/kakoune-9999.ebuild
+++ b/app-editors/kakoune/kakoune-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-inherit flag-o-matic toolchain-funcs git-r3
+inherit flag-o-matic toolchain-funcs git-r3 versionator
DESCRIPTION="Selection-oriented code editor inspired by vim"
HOMEPAGE="https://github.com/mawww/kakoune"
@@ -17,7 +17,7 @@ IUSE="debug"
RDEPEND="
sys-libs/ncurses:=[unicode]
- dev-libs/boost
+ dev-libs/boost:=
"
DEPEND="
app-text/asciidoc
@@ -27,9 +27,17 @@ DEPEND="
PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if tc-is-gcc && ! version_is_at_least 5.0 $(gcc-version); then
+ die "Clang or GCC >=5.0 is required to build this version"
+ fi
+ fi
+}
+
src_configure() {
- append-cppflags $(pkg-config --cflags ncursesw)
- append-libs $(pkg-config --libs ncursesw)
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags ncursesw)
+ append-libs $($(tc-getPKG_CONFIG) --libs ncursesw)
export CXX=$(tc-getCXX)
export debug=$(usex debug)
S="${WORKDIR}/${P}/src"