summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-08 18:52:07 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-08 18:56:34 +0900
commit191af3b26934841e5e52ef175beda2804cf73872 (patch)
tree3a5b37e0622ce784eafa6d1fdc10ee969d69643f /app-editors
parentapp-editors/ee: update HOMEPAGE and SRC_URI (diff)
downloadgentoo-191af3b26934841e5e52ef175beda2804cf73872.tar.gz
gentoo-191af3b26934841e5e52ef175beda2804cf73872.tar.bz2
gentoo-191af3b26934841e5e52ef175beda2804cf73872.zip
app-editors/ee: update to EAPI 6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ee/ee-1.5.2.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/app-editors/ee/ee-1.5.2.ebuild b/app-editors/ee/ee-1.5.2.ebuild
index 1af312e81393..250c1e87c8a5 100644
--- a/app-editors/ee/ee-1.5.2.ebuild
+++ b/app-editors/ee/ee-1.5.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI="6"
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="An easy to use text editor. A subset of aee"
#HOMEPAGE="http://mahon.cwx.net/ http://www.users.uswest.net/~hmahon/"
@@ -18,9 +18,10 @@ IUSE=""
RDEPEND="!app-editors/ersatz-emacs"
S="${WORKDIR}/easyedit-${PV}"
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-init-location.patch
+PATCHES=( "${FILESDIR}"/${PN}-init-location.patch )
+DOCS=( Changes README.${PN} ${PN}.i18n.guide ${PN}.msg )
+src_prepare() {
sed -i \
-e "s/make -/\$(MAKE) -/g" \
-e "/^buildee/s/$/ localmake/" \
@@ -31,6 +32,8 @@ src_prepare() {
-e "/CFLAGS =/s/\" >/ \\\\\$(LDFLAGS)\" >/" \
-e "/other_cflag/s/ *-s//" \
create.make
+
+ default
}
src_compile() {
@@ -38,8 +41,8 @@ src_compile() {
}
src_install() {
- dobin ee
- doman ee.1
- dodoc Changes README.ee ee.i18n.guide ee.msg
+ dobin ${PN}
+ doman ${PN}.1
+ einstalldocs
keepdir /usr/share/${PN}
}