summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-01-03 10:29:21 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-05 13:29:53 -0500
commit1d6c0576ca10c63779d12d98db27d31b5aa3cfc4 (patch)
tree8c73f02fa9e141207de97269b3b85eef110974dd /app-editors
parentdev-util/devhelp: Version bump to 3.38.1 (diff)
downloadgentoo-1d6c0576ca10c63779d12d98db27d31b5aa3cfc4.tar.gz
gentoo-1d6c0576ca10c63779d12d98db27d31b5aa3cfc4.tar.bz2
gentoo-1d6c0576ca10c63779d12d98db27d31b5aa3cfc4.zip
app-editors/gedit: Version bump to 3.38.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gedit/Manifest1
-rw-r--r--app-editors/gedit/files/3.38-make-gspell-optional.patch59
-rw-r--r--app-editors/gedit/files/3.38-make-python-optional.patch86
-rw-r--r--app-editors/gedit/gedit-3.38.1.ebuild102
4 files changed, 248 insertions, 0 deletions
diff --git a/app-editors/gedit/Manifest b/app-editors/gedit/Manifest
index a226fc44cd02..25c9e8d17193 100644
--- a/app-editors/gedit/Manifest
+++ b/app-editors/gedit/Manifest
@@ -1,2 +1,3 @@
DIST gedit-3.34.1.tar.xz 14797588 BLAKE2B 8dfaac4660575d67e3f8396dfed675a737fc69bc2b34866ee467a3464a338240133cab8d067db7b87fdc129f06a2450b91f4e0f70a73912d4a274cca980196d6 SHA512 22968c678a2f7ecf062f490d5eedc97aaa53b15932db801ea83eb336f01f41e7a6037a85508a40164f38dee406f8db097b7ef6f1481ab44ea82668766d24966d
DIST gedit-3.36.2.tar.xz 14770004 BLAKE2B 505c01aa60e64e418a09c9fbd0c397a487c612117c3068e35a41b075a8d5440cf85daf6e011eeacee7b228306342cc5c4a3dc1af24d52583c9a896531355f6d0 SHA512 20c3592aaf08ad4a5842b14ecb1eb0c9ddbef190412dc3f70b60bbf6125c9c4791a48260c89402ce4773720ae65b36fab510f9d1e104f548e243d11bc49279b5
+DIST gedit-3.38.1.tar.xz 6861368 BLAKE2B 3b202dbb7df8e91b58bd345fcaa309546af07bce60dc4638a3c344996d6c04ef7fe8a4824360c0f55970b759f9d7e2929c207992a9c80ad686d39e94ff741b7a SHA512 cd52cbcece3b007692294ab01b95fae7deb744b08a44da2d3cafa82a86d94c104abcdd4dcbe10630e0d633c8cc3c75f5e5dc6c8452a8c4bc2e6bb3c0de7d5547
diff --git a/app-editors/gedit/files/3.38-make-gspell-optional.patch b/app-editors/gedit/files/3.38-make-gspell-optional.patch
new file mode 100644
index 000000000000..f1197ebb5222
--- /dev/null
+++ b/app-editors/gedit/files/3.38-make-gspell-optional.patch
@@ -0,0 +1,59 @@
+From 4f32833325a6c95ec451adf1a8d9691cceb14dd8 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 16 Aug 2020 23:20:31 +0300
+Subject: [PATCH 1/2] build: Make gspell optional
+
+---
+ meson.build | 3 ++-
+ meson_options.txt | 4 ++++
+ plugins/spell/meson.build | 4 ++++
+ 3 files changed, 10 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index acaad0dad..2c5dccb82 100644
+--- a/meson.build
++++ b/meson.build
+@@ -54,7 +54,7 @@ deps_basic_list = [
+ dependency('gobject-introspection-1.0'),
+ ]
+
+-gspell_dep = dependency('gspell-1', version: '>= 1.0')
++gspell_dep = dependency('gspell-1', version: '>= 1.0', required: get_option('spell'))
+ python3 = python.find_installation('python3')
+
+ # Configurations
+@@ -94,3 +94,4 @@ summary('Prefix', get_option('prefix'))
+ summary('API documentation', get_option('gtk_doc'))
+ summary('User documentation', get_option('user_documentation'))
+ summary('Require all tests', get_option('require_all_tests'))
++summary('Spell checker plugin', get_option('spell').enabled().to_string())
+diff --git a/meson_options.txt b/meson_options.txt
+index 4e842d1ea..bb3923dd1 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -14,6 +14,10 @@ option(
+ description: 'Require that all tests can be run, even those that depend on third party programs'
+ )
+
++option('spell',
++ type: 'feature', value: 'enabled',
++ description: 'Build spell checking plugin')
++
+ # This option exists for the developers, to speed up the install.
+ option(
+ 'user_documentation',
+diff --git a/plugins/spell/meson.build b/plugins/spell/meson.build
+index 8ce7634b7..cccb42fc1 100644
+--- a/plugins/spell/meson.build
++++ b/plugins/spell/meson.build
+@@ -1,3 +1,7 @@
++if not gspell_dep.found()
++ subdir_done()
++endif
++
+ libspell_sources = files(
+ 'gedit-spell-app-activatable.c',
+ 'gedit-spell-plugin.c',
+--
+2.26.2
+
diff --git a/app-editors/gedit/files/3.38-make-python-optional.patch b/app-editors/gedit/files/3.38-make-python-optional.patch
new file mode 100644
index 000000000000..7dccb18191cd
--- /dev/null
+++ b/app-editors/gedit/files/3.38-make-python-optional.patch
@@ -0,0 +1,86 @@
+From 9ed333a94ea15f74c420cbb2766909953aa6acb6 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 16 Aug 2020 23:34:42 +0300
+Subject: [PATCH 2/2] build: Make python optional
+
+---
+ gedit/meson.build | 2 ++
+ meson.build | 2 ++
+ meson_options.txt | 4 ++++
+ plugins/meson.build | 9 ++++++---
+ 4 files changed, 14 insertions(+), 3 deletions(-)
+
+diff --git a/gedit/meson.build b/gedit/meson.build
+index 9fc81468e..5e808a2d8 100644
+--- a/gedit/meson.build
++++ b/gedit/meson.build
+@@ -197,10 +197,12 @@ libgedit_gir = gnome.generate_gir(
+ install_dir_typelib: get_option('libdir') / 'gedit/girepository-1.0',
+ )
+
++if get_option('python')
+ python3.install_sources(
+ 'Gedit.py',
+ subdir: 'gi/overrides',
+ )
++endif
+
+ # Vala API
+ libgedit_vapi = gnome.generate_vapi(
+diff --git a/meson.build b/meson.build
+index 2c5dccb82..5e1e9340a 100644
+--- a/meson.build
++++ b/meson.build
+@@ -55,7 +55,9 @@ deps_basic_list = [
+ ]
+
+ gspell_dep = dependency('gspell-1', version: '>= 1.0', required: get_option('spell'))
++if get_option('python')
+ python3 = python.find_installation('python3')
++endif
+
+ # Configurations
+ config_h = configuration_data()
+diff --git a/meson_options.txt b/meson_options.txt
+index bb3923dd1..962b82934 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -14,6 +14,10 @@ option(
+ description: 'Require that all tests can be run, even those that depend on third party programs'
+ )
+
++option('python',
++ type: 'boolean', value: true,
++ description: 'Install GIR python overrides and python plugins')
++
+ option('spell',
+ type: 'feature', value: 'enabled',
+ description: 'Build spell checking plugin')
+diff --git a/plugins/meson.build b/plugins/meson.build
+index 50bc5d393..63bb7c094 100644
+--- a/plugins/meson.build
++++ b/plugins/meson.build
+@@ -18,14 +18,17 @@ msgfmt_plugin_cmd = [
+ subdir('docinfo')
+ subdir('filebrowser')
+ subdir('modelines')
+-subdir('pythonconsole')
+ subdir('quickhighlight')
+-subdir('quickopen')
+-subdir('snippets')
+ subdir('sort')
+ subdir('spell')
+ subdir('time')
+
++if get_option('python')
+ if get_option('plugin_externaltools')
+ subdir('externaltools')
+ endif
++
++ subdir('pythonconsole')
++ subdir('quickopen')
++ subdir('snippets')
++endif
+--
+2.26.2
+
diff --git a/app-editors/gedit/gedit-3.38.1.ebuild b/app-editors/gedit/gedit-3.38.1.ebuild
new file mode 100644
index 000000000000..f387f481f9aa
--- /dev/null
+++ b/app-editors/gedit/gedit-3.38.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+VALA_MIN_API_VERSION="0.26"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="+python gtk-doc spell"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# X libs are not needed for OSX (aqua)
+DEPEND="
+ >=dev-libs/glib-2.64:2
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=dev-libs/gobject-introspection-1.54:=
+ >=x11-libs/gtk+-3.22.0:3[introspection]
+ >=x11-libs/gtksourceview-4.0.2:4[introspection]
+ gui-libs/tepl:5
+
+ spell? ( >=app-text/gspell-0.2.5:0= )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+ gnome-base/gsettings-desktop-schemas
+ gnome-base/gvfs
+"
+BDEPEND="
+ ${vala_depend}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ dev-util/itstool
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+PATCHES=(
+ # Don't force off overlay scrollbars for dubious reasons that GNOME designers heavily
+ # disagree with; those wanting them off in general would set that globally for gtk
+ "${FILESDIR}"/restore-overlay-scrollbars.patch
+ # Make gspell and python optional
+ "${FILESDIR}"/3.38-make-gspell-optional.patch
+ "${FILESDIR}"/3.38-make-python-optional.patch
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use python)
+ $(meson_use gtk-doc gtk_doc)
+ -Duser_documentation=true
+ $(meson_feature spell)
+ )
+ meson_src_configure
+}
+
+# Only appdata and desktop file validation in v3.32.2
+src_test() { :; }
+
+src_install() {
+ meson_src_install
+ if use python; then
+ python_optimize
+ python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}