summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-05-29 17:44:55 +0530
committerSam James <sam@gentoo.org>2023-05-31 06:49:19 +0100
commit32e6dc7b18d9a20c05cf88351524d2ff10ea5f19 (patch)
treee5a8a30fc6fee4239283ef83854527727ca414de /app-editors
parentapp-editors/neovim: add 0.9.1 (diff)
downloadgentoo-32e6dc7b18d9a20c05cf88351524d2ff10ea5f19.tar.gz
gentoo-32e6dc7b18d9a20c05cf88351524d2ff10ea5f19.tar.bz2
gentoo-32e6dc7b18d9a20c05cf88351524d2ff10ea5f19.zip
app-editors/neovim: drop 0.8.3
Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31213 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/neovim/Manifest1
-rw-r--r--app-editors/neovim/files/neovim-0.8-cmake-darwin.patch65
-rw-r--r--app-editors/neovim/files/neovim-0.8-cmake_lua_version.patch11
-rw-r--r--app-editors/neovim/files/neovim-0.8-msgpack-6.0.0-fix.patch26
-rw-r--r--app-editors/neovim/files/neovim-0.8.0-cmake-release-type.patch28
-rw-r--r--app-editors/neovim/metadata.xml1
-rw-r--r--app-editors/neovim/neovim-0.8.3.ebuild130
7 files changed, 0 insertions, 262 deletions
diff --git a/app-editors/neovim/Manifest b/app-editors/neovim/Manifest
index e17ae435cf0f..bc6d1781931e 100644
--- a/app-editors/neovim/Manifest
+++ b/app-editors/neovim/Manifest
@@ -1,3 +1,2 @@
-DIST neovim-0.8.3.tar.gz 11406282 BLAKE2B 67f4d4d1857e4c0416639dd0986f34b3842883ef48b68d90704472b40f1f064798f1f5f3c29e485f04ef8b2ed387132549442e86624b43f2ababff05bc477312 SHA512 0ecf60b564a323eb95eb2e67f7dc7e1c1e7bfc70b08466a66eb668d1b75a7362ca42901cd5a64fda22292375e2921ba61c299ac846f820ac146dc55426813eb8
DIST neovim-0.9.0.tar.gz 11549103 BLAKE2B f07b61f02a11acf678358999ea364b6a64724451a9a75f2d6ca436edc5ead9c6422f1c7e99c4322dc0bb92daacf306e32e214ab34d10f78f28d4ffad17b878c7 SHA512 e42f09f408b83fc34e8f169321e0349d1f851e67a998265c53d2ddb1a4792c3f4777fabe32baf2c7eff7d3745ff60d4a07da542ccd272883f7f4e080b2c9c1bf
DIST neovim-0.9.1.tar.gz 11567358 BLAKE2B 7aa56c672f7d26db7d47df39941487de32008b9e78921d71860281e8319b30dc6cd889a029c83b61814baecac947f39a950245ed7e51c35509b30e9b39046a58 SHA512 339efd3d8c1a73aa3b43e8770d6943aeba9e4ce6a3598c0424e388f80759d50b14aa7c60fd435bf2d17997476e06d28b79e7e98670d02ca9ceec031841e8b9b8
diff --git a/app-editors/neovim/files/neovim-0.8-cmake-darwin.patch b/app-editors/neovim/files/neovim-0.8-cmake-darwin.patch
deleted file mode 100644
index ad47a46e1a7a..000000000000
--- a/app-editors/neovim/files/neovim-0.8-cmake-darwin.patch
+++ /dev/null
@@ -1,65 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -80,33 +80,6 @@ set(ENV{PKG_CONFIG_PATH} "$ENV{PKG_CONFIG_PATH}:${DEPS_PREFIX}/lib/pkgconfig")
- # used for check_c_compiler_flag
- include(CheckCCompilerFlag)
-
--if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
-- # CMake tries to treat /sw and /opt/local as extension of the system path, but
-- # that doesn't really work out very well. Once you have a dependency that
-- # resides there and have to add it as an include directory, then any other
-- # dependency that could be satisfied from there must be--otherwise you can end
-- # up with conflicting versions. So, let's make them more of a priority having
-- # them be included as one of the first places to look for dependencies.
-- list(APPEND CMAKE_PREFIX_PATH /sw /opt/local)
--
-- # If the macOS deployment target is not set manually (via $MACOSX_DEPLOYMENT_TARGET),
-- # fall back to local system version. Needs to be done both here and in cmake.deps.
-- if(NOT CMAKE_OSX_DEPLOYMENT_TARGET)
-- execute_process(COMMAND sw_vers -productVersion
-- OUTPUT_VARIABLE MACOS_VERSION
-- OUTPUT_STRIP_TRAILING_WHITESPACE)
-- set(CMAKE_OSX_DEPLOYMENT_TARGET "${MACOS_VERSION}")
-- endif()
-- message("Using deployment target ${CMAKE_OSX_DEPLOYMENT_TARGET}")
--
-- # Work around some old, broken detection by CMake for knowing when to use the
-- # isystem flag. Apple's compilers have supported this for quite some time
-- # now.
-- if(CMAKE_C_COMPILER_ID MATCHES "GNU")
-- set(CMAKE_INCLUDE_SYSTEM_FLAG_C "-isystem ")
-- endif()
--endif()
--
- if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Darwin")
- # Ignore case when comparing filenames on Windows and Mac.
- set(CASE_INSENSITIVE_FILENAME TRUE)
---- a/cmake.deps/CMakeLists.txt
-+++ b/cmake.deps/CMakeLists.txt
-@@ -112,13 +112,6 @@ if(CMAKE_CXX_COMPILER)
- set(DEPS_CXX_COMPILER "${CMAKE_CXX_COMPILER}")
- endif()
-
--if(CMAKE_OSX_SYSROOT)
-- set(DEPS_C_COMPILER "${DEPS_C_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
-- if(DEPS_CXX_COMPILER)
-- set(DEPS_CXX_COMPILER "${DEPS_CXX_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
-- endif()
--endif()
--
- if(CMAKE_OSX_ARCHITECTURES)
- string(REPLACE ";" "|" CMAKE_OSX_ARCHITECTURES_ALT_SEP "${CMAKE_OSX_ARCHITECTURES}")
- # The LuaJIT build does not like being passed multiple `-arch` flags
---- a/src/nvim/CMakeLists.txt
-+++ b/src/nvim/CMakeLists.txt
-@@ -181,10 +181,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
- foreach(gen_include ${gen_includes} ${LUA_PREFERRED_INCLUDE_DIRS})
- list(APPEND gen_cflags "-I${gen_include}")
- endforeach()
--if(CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_OSX_SYSROOT)
-- list(APPEND gen_cflags "-isysroot")
-- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")
--endif()
- string(TOUPPER "${CMAKE_BUILD_TYPE}" build_type)
- separate_arguments(C_FLAGS_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS})
- separate_arguments(C_FLAGS_${build_type}_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS_${build_type}})
diff --git a/app-editors/neovim/files/neovim-0.8-cmake_lua_version.patch b/app-editors/neovim/files/neovim-0.8-cmake_lua_version.patch
deleted file mode 100644
index 87a898032493..000000000000
--- a/app-editors/neovim/files/neovim-0.8-cmake_lua_version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -464,7 +464,7 @@ endif()
- option(PREFER_LUA "Prefer Lua over LuaJIT in the nvim executable." OFF)
-
- if(PREFER_LUA)
-- find_package(Lua 5.1 EXACT REQUIRED)
-+ find_package(Lua ${PREFER_LUA} EXACT REQUIRED)
- set(LUA_PREFERRED_INCLUDE_DIRS ${LUA_INCLUDE_DIR})
- set(LUA_PREFERRED_LIBRARIES ${LUA_LIBRARIES})
- # Passive (not REQUIRED): if LUAJIT_FOUND is not set, nvim-test is skipped.
diff --git a/app-editors/neovim/files/neovim-0.8-msgpack-6.0.0-fix.patch b/app-editors/neovim/files/neovim-0.8-msgpack-6.0.0-fix.patch
deleted file mode 100644
index ce5f7bb86dc4..000000000000
--- a/app-editors/neovim/files/neovim-0.8-msgpack-6.0.0-fix.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-# https://github.com/neovim/neovim/commit/46c4cbced567f5f05f2c95b91cd90084ea8b5528
-# Closes: https://bugs.gentoo.org/903629
-# Contributed by Olivier Huber <oli.huber@gmail.com>
---- a/cmake/FindMsgpack.cmake
-+++ b/cmake/FindMsgpack.cmake
-@@ -26,18 +26,8 @@
- set(MSGPACK_VERSION_STRING)
- endif()
-
--if(MSVC)
-- # The import library for the msgpack DLL has a different name
-- list(APPEND MSGPACK_NAMES msgpackc_import)
--else()
-- list(APPEND MSGPACK_NAMES msgpackc msgpack)
--endif()
--
--find_library(MSGPACK_LIBRARY NAMES ${MSGPACK_NAMES}
-- # Check each directory for all names to avoid using headers/libraries from
-- # different places.
-- NAMES_PER_DIR
-- HINTS ${PC_MSGPACK_LIBDIR} ${PC_MSGPACK_LIBRARY_DIRS})
-+find_library(MSGPACK_LIBRARY NAMES msgpackc msgpack msgpackc_import msgpack-c
-+ NAMES_PER_DIR)
-
- mark_as_advanced(MSGPACK_INCLUDE_DIR MSGPACK_LIBRARY)
-
diff --git a/app-editors/neovim/files/neovim-0.8.0-cmake-release-type.patch b/app-editors/neovim/files/neovim-0.8.0-cmake-release-type.patch
deleted file mode 100644
index 8114e2a92b74..000000000000
--- a/app-editors/neovim/files/neovim-0.8.0-cmake-release-type.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Ensure that :checkhealth is happy with the Gentoo build type.
-https://bugs.gentoo.org/757744
---- a/runtime/autoload/health/nvim.vim
-+++ b/runtime/autoload/health/nvim.vim
-@@ -135,7 +135,7 @@ function! s:check_performance() abort
- let buildtype = matchstr(execute('version'), '\v\cbuild type:?\s*[^\n\r\t ]+')
- if empty(buildtype)
- call health#report_error('failed to get build type from :version')
-- elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo)'
-+ elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo|Gentoo)'
- call health#report_ok(buildtype)
- else
- call health#report_info(buildtype)
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -137,12 +137,6 @@ else()
- message(STATUS "MIN_LOG_LEVEL=${MIN_LOG_LEVEL}")
- endif()
-
--# Default to -O2 on release builds.
--if(CMAKE_C_FLAGS_RELEASE MATCHES "-O3")
-- message(STATUS "Replacing -O3 in CMAKE_C_FLAGS_RELEASE with -O2")
-- string(REPLACE "-O3" "-O2" CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE}")
--endif()
--
- if(CMAKE_C_COMPILER_ID MATCHES "GNU")
- check_c_compiler_flag(-Og HAS_OG_FLAG)
- else()
diff --git a/app-editors/neovim/metadata.xml b/app-editors/neovim/metadata.xml
index 555238c9fc17..93b24740c1b1 100644
--- a/app-editors/neovim/metadata.xml
+++ b/app-editors/neovim/metadata.xml
@@ -8,7 +8,6 @@
<use>
<flag name="lto">Build with Link Time Optimization (LTO)</flag>
<flag name="nvimpager">Install nvimpager symlink to less.sh macro</flag>
- <flag name="tui">Build the neovim unix tui</flag>
</use>
<upstream>
<remote-id type="github">neovim/neovim</remote-id>
diff --git a/app-editors/neovim/neovim-0.8.3.ebuild b/app-editors/neovim/neovim-0.8.3.ebuild
deleted file mode 100644
index f511e1520665..000000000000
--- a/app-editors/neovim/neovim-0.8.3.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# RelWithDebInfo sets -Og -g
-CMAKE_BUILD_TYPE=Release
-LUA_COMPAT=( lua5-{1..2} luajit )
-inherit cmake lua-single optfeature xdg
-
-DESCRIPTION="Vim-fork focused on extensibility and agility"
-HOMEPAGE="https://neovim.io"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/neovim/neovim.git"
-else
- SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~x64-macos"
-fi
-
-LICENSE="Apache-2.0 vim"
-SLOT="0"
-IUSE="+lto +nvimpager test +tui"
-
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-# Upstream say the test library needs LuaJIT
-# https://github.com/neovim/neovim/blob/91109ffda23d0ce61cec245b1f4ffb99e7591b62/CMakeLists.txt#L377
-REQUIRED_USE="test? ( lua_single_target_luajit )"
-# TODO: Get tests running
-RESTRICT="!test? ( test ) test"
-
-# Upstream build scripts invoke the Lua interpreter
-BDEPEND="${LUA_DEPS}
- >=dev-util/gperf-3.1
- >=sys-devel/gettext-0.20.1
- virtual/libiconv
- virtual/libintl
- virtual/pkgconfig
-"
-# Check https://github.com/neovim/neovim/blob/master/third-party/CMakeLists.txt for
-# new dependency bounds and so on on bumps (obviously adjust for right branch/tag).
-DEPEND="${LUA_DEPS}
- >=dev-lua/luv-1.44.2[${LUA_SINGLE_USEDEP}]
- $(lua_gen_cond_dep '
- dev-lua/lpeg[${LUA_USEDEP}]
- dev-lua/mpack[${LUA_USEDEP}]
- ')
- $(lua_gen_cond_dep '
- dev-lua/LuaBitOp[${LUA_USEDEP}]
- ' lua5-{1,2})
- >=dev-libs/libuv-1.44.2:=
- >=dev-libs/libvterm-0.3
- >=dev-libs/msgpack-3.0.0:=
- >=dev-libs/tree-sitter-0.20.2:=
- tui? (
- >=dev-libs/libtermkey-0.22
- >=dev-libs/unibilium-2.0.0:0=
- )
-"
-RDEPEND="
- ${DEPEND}
- app-eselect/eselect-vi
-"
-BDEPEND+="
- test? (
- $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]')
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.8-cmake_lua_version.patch"
- "${FILESDIR}/${PN}-0.8-cmake-darwin.patch"
- "${FILESDIR}/${PN}-0.8-msgpack-6.0.0-fix.patch"
-)
-
-if [[ ${PV} != 9999 ]]; then
- PATCHES+=(
- "${FILESDIR}/${PN}-0.8.0-cmake-release-type.patch"
- )
-fi
-
-src_prepare() {
- # Use our system vim dir
- sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
- -i src/nvim/globals.h || die
-
- # https://forums.gentoo.org/viewtopic-p-8750050.html
- xdg_environment_reset
- cmake_src_prepare
-}
-
-src_configure() {
- # Upstream default to LTO on non-debug builds
- # Let's expose it as a USE flag because upstream
- # have preferences for how we should use LTO
- # if we want it on (not just -flto)
- # ... but allow turning it off.
- # TODO: Investigate USE_BUNDLED, doesn't seem to be needed right now
- local mycmakeargs=(
- -DENABLE_LTO=$(usex lto)
- -DFEAT_TUI=$(usex tui)
- -DPREFER_LUA=$(usex lua_single_target_luajit no "$(lua_get_version)")
- -DLUA_PRG="${ELUA}"
- -DMIN_LOG_LEVEL=3
- )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
-
- # install a default configuration file
- insinto /etc/vim
- doins "${FILESDIR}"/sysinit.vim
-
- # conditionally install a symlink for nvimpager
- if use nvimpager; then
- dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- optfeature "clipboard support" x11-misc/xsel x11-misc/xclip gui-apps/wl-clipboard
- optfeature "Python plugin support" dev-python/pynvim
- optfeature "Ruby plugin support" dev-ruby/neovim-ruby-client
- optfeature "remote/nvr support" dev-python/neovim-remote
-}