summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-16 19:54:25 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-16 20:10:58 +0100
commit38ccc8b4caec1a37cbd01b5d36eb1cf9d0cd424c (patch)
treea267cc596e10d49ff13164dd3744bc4ed56648c8 /app-editors
parentapp-editors/gedit: Port to python-single-r1 (diff)
downloadgentoo-38ccc8b4caec1a37cbd01b5d36eb1cf9d0cd424c.tar.gz
gentoo-38ccc8b4caec1a37cbd01b5d36eb1cf9d0cd424c.tar.bz2
gentoo-38ccc8b4caec1a37cbd01b5d36eb1cf9d0cd424c.zip
app-editors/gedit-plugins: Port to python-single-r1
Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4175
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-3.20.0.ebuild8
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-3.22.0.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/app-editors/gedit-plugins/gedit-plugins-3.20.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-3.20.0.ebuild
index efdc73d945d9..c7b357851c26 100644
--- a/app-editors/gedit-plugins/gedit-plugins-3.20.0.ebuild
+++ b/app-editors/gedit-plugins/gedit-plugins-3.20.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{4,5} )
PYTHON_REQ_USE="xml"
VALA_MIN_API_VERSION="0.28"
-inherit eutils gnome2 multilib python-r1 vala
+inherit eutils gnome2 multilib python-single-r1 vala
DESCRIPTION="Official plugins for gedit"
HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"
@@ -22,7 +22,7 @@ IUSE="+python ${IUSE_plugins}"
REQUIRED_USE="
charmap? ( python )
git? ( python )
- python? ( ^^ ( $(python_gen_useflags '*') ) )
+ python? ( ${PYTHON_REQUIRED_USE} )
terminal? ( python )
zeitgeist? ( python )
"
@@ -59,7 +59,7 @@ DEPEND="${RDEPEND}
"
pkg_setup() {
- use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+ use python && [[ ${MERGE_TYPE} != binary ]] && python-single-r1_pkg_setup
}
src_prepare() {
diff --git a/app-editors/gedit-plugins/gedit-plugins-3.22.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-3.22.0.ebuild
index cba41efe3e1c..83a4559f736f 100644
--- a/app-editors/gedit-plugins/gedit-plugins-3.22.0.ebuild
+++ b/app-editors/gedit-plugins/gedit-plugins-3.22.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -7,7 +7,7 @@ PYTHON_COMPAT=( python3_{4,5} )
PYTHON_REQ_USE="xml"
VALA_MIN_API_VERSION="0.28"
-inherit eutils gnome2 multilib python-r1 vala
+inherit eutils gnome2 multilib python-single-r1 vala
DESCRIPTION="Official plugins for gedit"
HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ShippedPlugins"
@@ -22,7 +22,7 @@ IUSE="+python ${IUSE_plugins}"
REQUIRED_USE="
charmap? ( python )
git? ( python )
- python? ( ^^ ( $(python_gen_useflags '*') ) )
+ python? ( ${PYTHON_REQUIRED_USE} )
terminal? ( python )
zeitgeist? ( python )
"
@@ -59,7 +59,7 @@ DEPEND="${RDEPEND}
"
pkg_setup() {
- use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+ use python && [[ ${MERGE_TYPE} != binary ]] && python-single-r1_pkg_setup
}
src_prepare() {